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Foreword

INTRODUCTION This manual teaches you how to produce a wide
range of presentation-quality graphics with DR
DrawTM, including organizational charts, flow
charts, structured analysis diagrams, and line
illustrations . You can display pictures
created with DR Draw on color and monochrome
display monitors, or you can use a printer or
plotter to present your pictures on paper or
transparencies .

STRUCTURE OF

	

The DR DrawTMGraphic Application User's Guide
THIS MANUAL

	

contains six sections and two appendixes .

• Section 1 is a brief overview of DR Draw,
after which you begin the first of two
tutorials .

• Section 2 is a beginning tutorial in which
you draw a basic organizational chart and a
graphic design that you might use for a
report cover .

• Section 3 is an advanced tutorial in which
you modify and embellish the designs you
created in the beginning tutorial .

•

	

Section 4 describes several concepts that are
fundamental to DR Draw .

•

	

Section 5 describes each of DR Draw's
functions in alphabetical order .

•

	

Section 6 describes DR Draw's seven design
elements, also in alphabetical order .

• Appendix A describes the font library, which
lets you enter text in several different type
styles, including Roman, italic, script,
Greek, and gothic fonts .

•

	

Appendix B describes six error messages that
you might see while starting or using DR
Draw .
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CONVENTIONS

	

This manual uses several conventions involving
capitalization and colored type .

In the text, DR Draw's functions, design
elements, and layouts are capitalized, although
they are not capitalized in the menus you see
on your display monitor . For example, the text
refers to the COPY function, the POLYGON design
element, and the PORTRAIT layout . Functions,
including LAYOUT, are described in Section 5 ;
design elements are described in Section 6 .

To help you identify filenames and filetypes
(like CHART .PIX), they are capitalized in the
text and in examples of prompts and messages .
However, you need not capitalize filenames when
you use DR Draw .

The names of three keystrokes, PICK, DONE, and
RETURN, are also capitalized in the text .

DR Draw's menus and submenus appear with
initial capitalization . You will see
references to the Main Menu, Edit Menu, and
Change Submenu, among others .

Examples of DR Draw's prompts and messages
appear in colored type .

RELATED

	

Before you start to use DR Draw, be sure you
PUBLICATIONS read the DR Draw User's Guide Supplement (cited

as Supplement in this manual) you received with
DR Draw . The Supplement describes how to copy
your DR Draw diskettes, format a picture file
diskette, and start DR Draw . It also provides
information about the devices you can use with
DR Draw .

In addition, you should be familiar with your
hardware and software . For information on the
particulars of your system, refer to the
documentation that came with your computer,
display monitor, printer, plotter, and mouse .
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Section I

Overview

INTRODUCTION

	

DR Draw allows you to use your microcomputer to
communicate your ideas with high-quality
graphics . DR Draw's capabilities give form to
your imagination, allowing you to create your
own graphic designs .

	

With DR Draw you can
create, preview, change, and refine a drawing
before you print or plot it .

This section introduces you to DR Draw,
explains its features and capabilities, and
previews the sections that follow .

YOUR COMPUTER

	

Your computer and its output devices (display
monitor, plotter, and printer) use DR Draw to
help you create effective presentations . The
computer frees you from the repetitive tasks of
aligning, changing, and repeating figures .
Your monitor is a window into a two-dimensional
drawing surface where you can create drawings
that bring your ideas to life .

computer . The computer graphically drafts your
ideas while you concentrate on developing a
design that best communicates your thoughts .

The pictures you create may be charts,
diagrams, or free-form graphics . The pictures
are easily reproduced on paper or
transparencies for presentation . Your design
and the capabilities of DR Draw combine to
produce pleasing and imaginative pictures like
the one shown in Figure 1-1 .

DR Draw Your first step in creating a graphic design is
to tell the computer what you want to draw . DR
Draw lets you communicate your ideas to the
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DR Draw

Figure 1-1 . Picture Created With DR Draw

CAPABILITIES

	

With DR Draw you can do the following :

•

	

add a variety of design elements that include

- circles
- polygons
- bars
- lines
- arcs
- text

•

	

combine design elements to create pictures

•

	

change size and dimensions of design elements

•

	

use a palette of colors to enhance pictures

•

	

use a library of typefaces

•

	

create word-slides with text alone

•

	

edit your picture

1-2
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Capabilities

•

	

save pictures on diskette

•

	

get a presentation-quality copy of your work
from a printer or plotter

•

	

enlarge part of a picture

•

	

expand a design beyond the confines of the
display monitor

USING THIS MANUAL Two tutorials in this manual help you build a
foundation for success with DR Draw .

The tutorials acquaint you with the basics of
D R Draw and allow you to progress rapidly .
Section 2 contains the first tutorial and
provides step-by-step practice in basic DR Draw
functions . You learn by creating charts and
designs on the drawing surface . In this
beginning tutorial, you also learn how to save
your picture files on diskette .

Section 3 presents the advanced tutorial, which
builds upon skills acquired in the beginning
tutorial . It introduces to you more powerful
features of DR Draw that let you create more
complex designs .

Section 4 provides detailed descriptions of
concepts the tutorials introduce . Section 5
provides descriptions of all DR Draw functions
and Section 6 explains the DR Draw design
elements .

Appendix A describes DR Draw's font library .
Appendix B lists and explains six error
messages that can occur when you start or use
DR Draw .

Use this manual with the Supplement, which
tells you how to install and start DR Draw on
your computer system .

USING DR Draw DR Draw can be used with a variety of computers .
You can use either a mouse or keyboard to
communicate with DR Draw .

1- 3
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Using DR Draw

You use two special keystrokes or mouse buttons
to perform two important DR Draw functions :
PICK and DONE . PICK allows you to select a
menu item or location on the drawing surface .

DONE completes an operation . In some cases,
PICK performs and ends an operation without
requiring DONE .

Table 1-1 shows the keys or buttons used for
PICK and DONE :

Table 1-1 . PICK and DONE (Keyboard/Mice)

2-Button

	

3-Button

PICK

DONE

Keyboard

MENU MAP

	

The Menu Map on the following page routes you
through the menus offered by DR Draw .

Mouse Mouse

DR Draw MENUS DR Draw is a menu-driven program . You choose
functions from a series of menus which offer a
list of functions and prompt you for additional
information . The Main Menu provides a list of
major DR Draw functions ; several lead to
submenus that contain more functions .

SPACE BAR

RETURN
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Menu Map

Add	Change

submenu submenu
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Figure 1-2 . Menu Map
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Section 2
Getting Started

INTRODUCTION

	

With DR Draw you can easily create many kinds of
charts, diagrams, and other graphic designs .
This section helps you teach yourself to use DR
Draw .

By following the steps in this tutorial, you
quickly become familiar with DR Draw's
capabilities and learn to create your own
pictures .

In this tutorial you create two sample
drawings :

	

an organizational chart, and a
design suitable for a report cover .

START DR Draw

	

You must set up your computer and start DR Draw
before you begin the tutorial .

Your method of starting DR Draw depends on the
type of computer system you use . Refer to the
Supplement for information on starting DR Draw .

You need two diskettes to operate DR Draw : the
work diskette that contains DR Draw and a
formatted diskette on which to store your
picture files .

	

Refer to the Supplement for
information on formatting diskettes .

CREATE A CHART An organizational chart communicates the
hierarchy of a business . In the first part of
this tutorial, you learn how to create the
first few boxes in the organizational chart
shown in Figure 2-1 .
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TINA GANZ
CONSULTANT

JEAN STAVROS
SAI FS

NANCY TENG

MARKETING

TUNNEY El FCTRONICS CORPORATION

HUME CLAYBURN

ADVERTISING

DAVE MITRE

DIRECTOR

Figure 2-l . Organizational Chart

Create A Chart

TYRONE SMITH

MANUFACTURING j

,

This tutorial teaches you how to do the
following :

•

	

create a picture file
•

	

use the grid
•

	

add design elements, including text
•

	

copy design elements
•

	

move a design element to another location
•

	

save and recall your picture file
•

	

print output from the picture file
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Main Menu

MAIN MENU

	

When you start DR Draw, a copyright message
appears on the screen . The message is soon
followed by the Main Menu, a bar at the top of
the screen that lists the main functions of DR
Draw .

e.ve

	

I vlkreclary

Figure 2 -2 . Main Menu
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Create A Picture File

CREATE A PICTURE

	

Now begin a picture by using PICK to select
FILE

	

a menu item . If you are using a mouse, press
the button on the far left to PICK . On the
keyboard, press the SPACE BAR to PICK . To
avoid confusion, the action is referred to
simply as PICK throughout this guide .

If you are using a mouse, you can move through
the menu by moving the mouse left or right .
For systems without a mouse, use the TAB key to
move through the menu, left to right .

	

The
BACKSPACE key reverses movement through the
menu, right to left . On keyboard systems and
some mouse systems, the menu selection appears
in reverse video .

Practice moving through the menu bar a few
times .

From the Main Menu, PICK the CREATE function to
create a picture file .

When you PICK the CREATE function, DR Draw
prompts you to name the picture file :

Picture filename?

When you type a filename, you must tell DR Draw
which drive contains your picture diskette . DR
Draw stores the picture file on that diskette .
For example, if your picture diskette is in
drive B, you type the drive identifier

B :

before the filename .

In response to the picture filename prompt,
type the correct drive identifier and the
filename :

B :CHART

If you misspell the filename, use the BACKSPACE
key to erase the mistake and retype the name .
Press the RETURN key .

For the filename you can use any combination of
letters or numbers that does not exceed eight
characters . DR Draw ignores characters after
the eighth character .

	

Also, do not use
punctuation marks or spaces .

2- 4
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Create A Picture File

The Main Menu disappears and a rectangle
appears, rapidly filling with a grid of points .
The rectangle is the window frame . It encloses
the drawing surface where you work . A new menu
bar replaces the Main Menu . This is called the
Edit Menu, and it lists the functions you can
use to make your organizational chart . The
grid of points acts like electronic graph paper
to help you align different design elements .

Figure 2-3 . Edit Menu, Grid, and Window Frame
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Draw Elements

DRAW ELEMENTS

	

To draw the organizational chart, you add
different design elements to the grid one by
one, much in the way a graphic artist builds a
design with overlays . A design element is any
shape, symbol, or unit of text that you use in
the picture . You begin by using lines to draw
boxes .

PICK AND DONE

	

If you pick the wrong menu item here or anywhere
in the tutorial, press the DONE key to return
to the previous menu and start the operation
again .

	

On keyboard systems, you press the
RETURN key for DONE . On a mouse, the second
button from the left signals DONE .

If you press the DONE key when you are in the
Edit Menu, your picture disappears from the
screen, and the Main Menu appears . To return
to the Edit Menu and continue working on your
picture, PICK the EDIT function from the Main
Menu .

PICK the ADD function from the Edit Menu . A
new menu of shapes and figures appears below
the Edit Menu . These are the design elements
you use to create your picture .

	

Refer to
Section 6 for descriptions of DR Draw's design
elements .
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Figure 2-4 . Edit Menu and Add Submenu

PICK and DONE

DRAW LINES

	

PICK the LINES design element from the Add
Submenu . A cross hair (+), called the graphics
cursor, appears at the center of the drawing
surface . The center of the cursor marks your
position on the drawing surface . The graphics
cursor appears when you PICK a menu item that
adds a design element or changes a picture
element . The cursor also appears when you need
to PICK a point for repositioning elements or
changing your view of the drawing surface . For
details on the graphics cursor, refer to
Section 4 .
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Draw Lines

On the second menu line, DR Draw tells you

PICK points, press DONE when finished

You begin creating the organizational chart by
drawing lines . You use PICK to specify
starting and ending points . DR Draw joins the
two points to form a line . You can add
additional line segments by adding successive
points to the element .

If you are using a mouse, move it, and the
graphics cursor moves correspondingly . On a
keyboard system, use the arrow keys to move the
cursor . If you are using arrow keys, note that
each press of an arrow key moves the cursor
part of the distance between grid points . For
example, you might press the cursor key five
times to move 4 grid points across the drawing
surface .

To actually begin drawing the chart, locate
your cursor at the center grid point on the
drawing surface . Move the cursor straight up 3
grid points and PICK . This is your starting
point . No line appears, but you might have
noticed that the cursor attaches to the nearest
grid point if you were not directly over a grid
point . This is the SNAP feature, which helps
you align design elements by "snapping" the
cursor to the nearest grid point on the drawing
surface . The SNAP feature is useful for
aligning design elements in a picture .

Move the cursor left 4 grid points . On most
systems, a line follows the cursor . This is DR
Draw's rubberband line, which allows you to see
how the line looks before you PICK an endpoint .

PICK the point . The dashed line becomes a
solid line between the two points you PICKed--
the beginning of a box . See Figure 2-5, "First
Line Segment ."
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Figure 2-5 . First Line Segment

Draw Lines

Now move the cursor up 3 grid points on the
grid and PICK again .

	

Another solid line
appears .

You can move the cursor over the drawing
surface freely . Line segments join only the
points that you PICK .

Move the cursor 8 grid points to the right and
PICK once more . Another line appears . Your
box is more than half complete .
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Move the cursor 3 grid points down and PICK .
One more line segment completes the box . Move
the cursor 4 grid points to the left to the
point where you began and PICK . The final line
closes the box . Now press the DONE key to tell
DR Draw that the element is complete . You have
created your first design element with DR Draw .

Move

	

copy

i

	4

Figure 2-6 . First Box
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Draw Lines
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Draw Lines

The Add Submenu and the graphics cursor
disappear . A broken line, enclosing the box
you just drew, appears on the drawing surface .

The broken line is the extent . It marks the
current element . The current element is the
only design element you can change . Ordinarily
the current element is the most recent design
element you worked on . However, when you save
a picture file on diskette and recall the file,
the first element you added to the picture
becomes the current element .

The advanced tutorial in Section 3 explains how
to use the SELECT function to name a new
current element .

DELETE AND

	

If you made a mistake and want to redraw the
UNDELETE

	

box, you can delete the design element with DR
Draw's DELETE function .

	

DELETE removes the
current element from the drawing surface .

If you accidentally delete an element, the
UNDELETE function redraws the last element you
deleted, regardless of the number of operations
you performed since the deletion .

Practice DELETE and UNDELETE . PICK the DET,F,TE
function from the Edit Menu . DR Draw erases
the box .

Notice that the grid points below the deleted
box also disappear . You can restore the grid
points by using the REDRAW function . PICK the
CHANGE function from the Edit Menu . From the
Change Submenu, PICK the REDRAW function . DR
Draw erases the grid, then redraws the grid,
restoring the missing grid points .

PICK the UNDELETE function . DR Draw redraws
the box you deleted on the drawing surface .
The extent reappears, defining the box as the
current element .
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COPY ELEMENTS

	

To proceed with the organizational chart, you
want to draw several more rectangles . You do
not have to redraw each box with the LINES
design element . Instead, use another DR Draw
function, COPY .

PICK the COPY function from the Edit Menu . The
graphics cursor reappears . DR Draw prompts

PICK reference point

Y 5

Move the cursor to the upper left corner of the
current element . By positioning the cursor on
or near the extent corner, you can more easily
locate new elements .

I
~	I

r,	

Figure 2-7 . Cursor Position (COPY)

Copy Elements
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PICK the point . A new prompt appears .

PICK location(s), press DONE to finish

Move the cursor 7 grid points down, then
grid points left . PICK aqain . A duplicate
your first box appears below and to the left
the original . The extent now surrounds the new
box, which is the current element . The prompt
remains on the screen .

~e1,ec,

IVk location(s), press DONE to finish

ove 1 1-1 p '.4

Figure 2-8 . Second Box

COPY allows you to make as many copies as you
wish in the same operation, as long as the
total number of elements in the picture does
not exceed 200 .

nde e e De

Copy Elements

e e
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to the right and PICK once more . Another copy
of the box appears, surrounded by the extent .

Press the DONE key to finish copying . DR Draw
returns you to the Edit Menu .

The last box you added to the picture is
slightly off center . DR Draw's MOVE function
makes it easy to realign your chart .

MOVE ELEMENTS

	

The MOVE function allows you to move the current
element anywhere on the drawing surface .

PICK the MOVE function from the Edit Menu . DR
Draw prompts

PICK reference point

Move the cursor to the upper left corner of the
extent . PICK the point . A prompt appears .

PICK new location, press DONE to finish

Move the cursor 1 grid point to the left and
PICK . The box shifts to the new position . You
are still in the MOVE function, so you could
move the box again if necessary . Press the
DONE key to return to the Edit Menu .

DR Draw User's Guide Copy Elements

Now add another box to the chart . Using the
upper left corner of the new box as the
starting point, move the cursor 21 grid points
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Figure 2-9 . Third Box

CHANGE GRID SIZE

	

Before you add text to the boxes you should
substitute a denser grid for the present grid .
Adding more grid points to the drawing surface
lets you more easily position text within the
boxes . The GRID function allows you to change
grid density .

Move Elements
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Change Grid Size

From the Edit Menu,'PICK the CHANGE function .
The Change Submenu appears under the Edit Menu .
PICK the GRID function .

	

The Grid Submenu
replaces the Change Submenu . PICK the SIZE
0 .5X function . The grid disappears, line by
line, and a new, denser grid appears on the
drawing surface .

	

The new grid is twice as
dense as the original grid . The Grid Submenu
disappears .

ADD TEXT

	

The trio of boxes is a start, but you need to
add labels to them . Like shapes, you add text
with the ADD function .
PICK the ADD function from the Edit Menu . When
the Add Submenu appears, PICK the TEXT design
element . DR Draw prompts

PICK start, type, RETURN ; DONE finishes

If you are using the arrow keys to move the
cursor, you can more easily locate grid points
by slowing the cursor . A designated key on
your keyboard changes the cursor's speed .
Refer to the Supplement to identify the key .

You change the cursor speed by pressing the key
to increase or decrease speed .

	

When you
identify the cursor speed key, practice moving
the cursor around the drawing surface,
alternating between fast and slow speed .

When you feel comfortable with changing cursor
speed, you can add text to the first box you
created by completing the following
instructions .

Within the top box, move the cursor 3 grid
points up from the box's lower left corner,
then move the cursor 4 grid points to the
right . PICK the point . The graphics cursor
disappears . An underscore, the text cursor,
replaces the graphics cursor .
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Add Text

------------------------------------------------------------

Figure 2-10 . Text Cursor

Type the following :

DAVE MITRE

If you make a typing error, use the BACKSPACE
key and retype the box label .

After you type the text string, press the
RETURN key . The graphics cursor appears below
the letter D .
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Add Text

Press the DONE key to finish entering text .
The extent appears around the text you just
typed .

For detailed information on entering text,
refer to Section 6 .

Figure 2-11 . Box Label



between different computers and output devices,
so you want to change the font style to one of
the typefaces included with DR Draw . These
fonts remain the same on screen, plotter, and
printer outputs .

PICK the CHANGE function from the Edit Menu .
When the Change Submenu appears, PICK the STYLE
function . A submenu of font options appears .
PICK the Simplex submenu selection . The font
Simplex Roman replaces the initial style in the
box label .

ADD MORE TEXT Now add a title to the name you entered in the
first box . PICK the ADD function from the Edit
Menu . From the Add Submenu, PICK the TEXT
design element . DR Draw prompts

PICK start, type, RETURN ; DONE finishes

Use the lower left corner of the first box as a
starting point . Move the cursor up 1 grid
point and 5 grid points to the right of the
box's lower left corner .

DR Draw User's Guide Change Text Style

CHANGE TEXT STYLE The style of text DR Draw used for your text
entry is known as machine font . This is the
initial style that DR Draw uses for all text
until you specify otherwise .

	

The size and
shape of machine font characters may vary
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PICK start, ype, RETURN ; DONE finishes

ove copy

Figure 2-12 . Cursor Position (TEXT)

Add More Text

PICK this point . The text cursor replaces the
graphics cursor . Type the following :

DIRECTOR

The words appear in the machine font as you
type . A bouncing extent surrounds the text to
show you the size of the element as it will
appear in the current font style, Simplex
Roman . Press the RETURN key . The font style
changes to Simplex Roman, and the cursor moves
to the next line .
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NANCY TENC
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When you press the RETURN key after typing a
string of text, you can use the mouse or arrow
keys to move anywhere on the drawing surface,
PICK a point, and type another text string .
This feature enables you to add the remaining
box labels in one operation .

Using the labels in Figure 2-13, add text to
the remaining boxes . Type the names on the
third row of grid points above the boxes' lower
edges . Type the titles on the first grid row
above the lower edges . Do not worry i f the
text is not centered perfectly the first time
you add the labels . Press the DONE key when
you are finished .

	7
0 °-,v'E h .1ITRE
DIRECTQR

	 ~

Figure 2-13 . Labeled Boxes

Add More Text
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Change Grid

CHANGE GRID Before you join the labeled boxes with lines,
change the grid density . A sparser grid of
dots lets you more easily count grid points for
centering lines .

From the Edit Menu, PICK the CHANGE function .
When the Change Submenu appears, PICK the GRID
function . The Grid Submenu replaces the Change
Submenu . PICK the SIZE 2X function . The grid
disappears, line by line, and a new, less dense
grid appears on the drawing surface . The new
grid is half as dense as the previous grid .

PICK the ADD function from the Edit Menu . When
the Add Submenu appears, PICK the LINES design
element .

DR Draw tells you

PICK points, press DONE when finished

Use PICK to draw line segments between the
boxes . Starting from the lower right corner of
the top box, move the cursor 4 grid points to
the left . Because the cursor snaps to the
nearest grid point when you PICK, move the
cursor close to the center grid point on the
box's lower edge . See Figure 2-14 . PICK the
point . The cursor snaps to the nearest grid
point .

ADD LINES To complete the chart, you need to join the
rectangles with lines .
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Figure 2-14 .

	

Cursor Position (Adding Lines)

Move the cursor down 2 grid points and PICK . A
line appears between the two points . Now you
want to create two line segments that branch
out to the remaining boxes . Move the cursor 10
grid points to the right . PICK the point .

Now move the cursor down 2 grid points and
PICK . A line joins the two boxes .

Add Lines
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Figure 2-15 . Boxes Joined With Line
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Add Lines

You now want to join the box on the left to the
rest of the diagram . You can do this by
pressing the DONE key and PICKing the LINES
design element again from the Add Submenu, or
you can retrace your steps by completing the
following instructions .

Move the cursor back up 2 grid points and PICK
again .

Your figure looks the same because you have
drawn a line on top of another line . Move the
cursor 20 grid points to the left . PICK the
point .
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Add Lines

SAVE A PICTURE

As you move the cursor, the right side of your
line may disappear .

	

The rubberband line
following the cursor creates this effect . Your
line is still there .

To draw the final line, move the cursor down 2
grid points and PICK .

Press the DONE key to complete the line
element .

	

Notice that the extent traces a
rectangle around the entire line element .

You have drawn a simple organizational chart
with DR Draw . The advanced tutorial in Section
3 teaches you how to expand this chart into the
organizational chart shown in Figure 2-1 .

Now that your chart is complete, you can save it
on diskette for future reference .

Press the DONE key . The organizational chart,
window frame, and grid disappear . The Main
Menu replaces the Edit Menu at the top of your
screen .

PICK the SAVE function . DR Draw prompts

B :CHART? (or type new name)

DR Draw i s giving you the opportunity to change
the filename . Changing a filename is discussed
in "Rename Picture File" later in this
tutorial .

	

You can also change the drive
identifier if you want to store the picture
file in a different drive . Refer to "Create A
Picture File" at the beginning of this section
for an explanation of drive identifiers .

To keep the same picture filename and drive
identifier, press the RETURN key .

	

DR Draw
replies

.B :CHART : saving file
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Check Directory

CHECK DIRECTORY

	

Now check your directory of picture files to
ensure CHART has been saved on the diskette .

To list the picture files on diskette, PICK the
DIRECTORY function from the Main Menu . DR Draw
prompts

On which drive?

Type the letter of the drive that contains your
picture diskette and press the RETURN key . DR
•raw lists the picture files on the diskette
and prompts

DIRECTORY complete, press DONE

Check to see if the picture file CHART is
listed .

	

Press the DONE key .

	

The directory
•

	

isappears, and you return to the Main Menu .

RECALL PICTURE

	

To retrieve your picture file to display or
FILE

	

modify it, use the RECALL function . I n this
case you will be preparing the picture file for
printing .

PICK the RECALL function from the Main Menu .
DR Draw prompts

•

	

icture filename?

Type the following

B :CHART

After you press the RETURN key, DR Draw prompts

•

	

:CHART : reading file

DR Draw draws your chart on the screen and
• isplays the Edit Menu . The first element
created, a box, is now the current element .
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LAYOUT

	

Before you print the picture file, use the
LAYOUT function to format your picture file .
DR Draw only prints the portion of a picture
file that lies within the layout .

	

Elements
outside the layout are not printed even though
they are part of the picture file .

DR Draw gives you a choice of three layouts :
PORTRAIT, LANDSCAPE, and SCREEN . The examples
in Figures 2-16a through 2-16c illustrate the
three different layouts .

	~iar!~e	:Piart	MOVE	CcF~	UnE +RtC	~, eletE	

Figure 2-16a . SCREEN Layout
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Figure 2-16b . PORTRAIT Layout

LAYOUT
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Figure 2-16c . LANDSCAPE Layout

LAYOUT

SCREEN is the default layout, the format that
DR Draw uses if you do not select a layout .

Now look at how LAYOUT can affect the picture
file . PICK the CHANGE function from the Edit
Menu . When the Change Submenu appears, PICK
the LAYOUT function .

	

The Layout Submenu
appears . PICK the PORTRAIT layout . DR Draw
adds a solid-line rectangle to the grid . You
can see that part of the chart lies outside the
PORTRAIT layout .
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PICK the ZOOM FULL function .

	

DR Draw
proportionally reduces the contents of the
picture file to fit the LANDSCAPE layout .

Now try the LANDSCAPE layout . PICK the CHANGE
function from the Edit Menu . When the Change
Sub menu appears, PICK the LAYOUT function .
PICK the LANDSCAPE layout from the Layout
Submenu . DR Draw replaces the PORTRAIT layout
with the LANDSCAPE layout . Note that in this
case LANDSCAPE, like PORTRAIT, does not frame
all the elements in the organizational chart .

Refer to Section 5 for more details on
LAYOUT function .

the

ZOOM FULL You can fit the organizational chart into the
LANDSCAPE layout by using DR Draw's ZOOM FULL
function . ZOOM FULL reduces or enlarges the
picture file to fit the current layout . From
the Edit Menu, PICK the CHANGE function . When
the Change Submenu appears, PICK the VIEW
function .

	

The View Submenu appears on the
screen .
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Figure 2-17 . Organizational Chart in LANDSCAPE Layout

RENAME PICTURE

	

You can only print a picture file when it is
FILE

	

saved on diskette . Press the DONE key to return
to the Main Menu . PICK the SAVE function from
the Main Menu . DR Draw prompts

B :CHART? (or type new name)

--i
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Rename Picture File

Because you need to keep the original CHART for
the advanced tutorial in Section 3, you must
rename this version of the picture file . Type

B :CHART2

in response to the prompt, and press the RETURN
key . DR Draw displays this message :

B :CHART2 : saving file

When the message disappears, DR Draw has saved
the new picture file on diskette .

You now have two versions of the organizational
chart on your picture diskette . CHART is your
original version in SCREEN layout . CHART2
contains the same design elements, but the file
is in LANDSCAPE layout .

If you had pressed the RETURN key without
typing a new filename, DR Draw would have
replaced the version of CHART saved on your
diskette with the version on which you have
been working .

PRINT PICTURE

	

Use the OUTPUT function to print the picture
file CHART 2 .

PICK the OUTPUT function from the Main Menu .
DR Draw displays a new menu that offers a
choice of output devices .
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Figure 2-18 . Output Menu

PICK PRINTER from the Output Submenu . The
Output Submenu disappears and DR Draw prompts

Picture filename :'

Type

B :CHART 2

LX1 1t

Print Picture
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Print Picture

Include the drive identifier, if necessary .
Press the RETURN key . The Main Menu disappears
and DR Draw informs you

Preparing file for landscape output

After a pause, the message disappears, and the
picture file prints .

	

When printing is
complete, the Main Menu reappears .

Congratulations, you have completed the first
sample drawing in this tutorial and learned
some basic DR Draw functions in the process .
The sample picture that follows introduces you
to more DR Draw functions .

If you want to take a break from the tutorial,
PICK the EXIT function from the Main Menu to
return to the operating system . The operating
system prompt appears, which signals your
departure from DR Draw . To restart DR Draw,
follow the instructions in the Supplement .

CREATE A DESIGN

	

In addition to creating charts and other
diagrams, DR Draw allows you to create designs
or pictures .

	

In this part of the beginning
tutorial, you use DR Draw to create a pencil
design .

Figure 2-19 . Pencil Design
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Create A Design

If you took a break from the tutorial, restart
D R Draw . If you do not remember how to do
this, refer to the Supplement .

CREATE A

	

To begin, create a picture file in the same
PICTURE FILE

	

way you created CHART .

From the Main Menu, PICK the CREATE function .
DR Draw prompts you for a filename :

Picture filename?

Type the following, then press the RETURN key :

B :PENCIL

The rectangular window frame returns to the
drawing surface . The Edit Menu replaces the
Main Menu . You are ready to draw .

DRAW CIRCLE Start by drawing a circle . PICK the ADD
function from the Edit Menu . The Add Submenu
appears below the Edit Menu . PICK the CIRCLE
design element . The graphics cursor (+)
appears at the center of the drawing surface
and DR Draw prompts

PICK circle center

Position the cursor on the center grid point on
the drawing surface and PICK . An asterisk
marks the point . DR Draw now prompts

PICK circle radius

You are ready to tell DR Draw how large the
circle will be . Move the cursor 6 grid points
to the left and PICK . Another asterisk marks
the point .
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The graphics cursor disappears and a new
submenu offers you the choice of creating an
OPEN circle or a FILLED circle . An OPEN circle
is a circular line .

	

A FILLED circle is a
circular line with one of several fill patterns
inside .

PICK the OPEN circle .

	

After a pause, the
circle appears on the drawing surface,
surrounded by the extent .

-~W 1-1 1

Figure 2-20 . Circle and Extent

Draw Circle



DR Draw User's Guide

	

Add Polygon

ADD POLYGON

	

Now add another element to the design . The
POLYGON design element allows you to create a
filled element with as many sides as you want .
In this picture, you will be drawing a
triangle .

From the Edit Menu, PICK the ADD function
again . When the Add Submenu reappears, PICK
the POLYGON design element .

The graphics cursor appears and DR Draw prompts

PICK points, press DONE when finished

Starting from the center point of the circle
you just created, move the cursor 14 grid
points to the left and PICK . You have now
marked a corner of the triangle . Now move the
cursor up 1 grid point and 3 grid points to the
right . PICK the second point . The first side
of the triangle appears on the screen .

To choose the final corner of the triangle,
move the cursor down 2 grid points and PICK .
Another side of the polygon appears .

To rejoin the starting point, move the cursor 3
grid points to the left and 1 grid point up .
PICK the point . Press the DONE key .

The cursor disappears and the triangle turns
solid . This solid fill is known as the initial
style .

	

If you do not specify another fill
pattern, DR Draw assumes you want the solid
fill . Notice that your screen shows the solid
area in light shading . When you print or plot
the picture, this area is black or solid
colored . You will learn how to add or change
colors in the "Color" subsection of this
tutorial . For more information on the STYLE
function, refer to Section 5 .
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Figure 2-21 . First Polygon
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Add Polygon

e

ADD ANOTHER

	

Now, use the POLYGON design element to add
POLYGON

	

another element to the picture .

PICK the ADD function from the Edit Menu . When
the Add Submenu appears, PICK the POLYGON
design element .

The cursor reappears and DR Draw prompts

PICK points, press DONE when finished

To locate a starting point, move the cursor to
the upper right corner of the triangle you just
created . PICK the point .

i

2 -38
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Add Another Polygon

Move the cursor up 1 grid point and 3 grid
points to the right . PICK the point to draw
the first side of the polygon .

Move the cursor down 4 grid points and PICK
again .

Draw the third side of the design element by
moving the cursor 3 grid points to the left and
up 1 grid point . PICK the point .

Complete the polygon by moving the cursor up 2
grid points . PICK the point . Press the DONE
key . The solid fill appears in the polygon .
The cursor disappears, and the extent encloses
the polygon .

STYLE

	

To change the fill pattern of the polygon, use
the STYLE function .

PICK the CHANGE function from the Edit Menu .
When the Change Submenu appears, PICK the STYLE
function . A menu of different fill patterns
appears .

PICK the first fill pattern . The solid fill
disappears, leaving the outline of the polygon .
The new fill i s the hollow fill . Although the
element looks empty, the hollow fill masks any
element underneath it . Refer to Section 4 for
details on hollow fill .
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BARS

Figure 2-22 . Second Polygon

Now use the BAR design element, to draw the body
of the pencil . With the BAR design element,
you can draw rectangles in all sizes, ranging
from long, thin bars to squares . From the Edit
Menu, PICK the ADD function .

	

From the Add
Submenu, PICK the BAR design element . DR Draw
prompts

PICK corner of bar

You define the bar by choosing corners that are
diagonally opposite each other .

STYLE
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Bars

Move the cursor to the lower right corner of
the hollow-filled polygon and PICK . An
asterisk marks the point . DR Draw prompts

PICK opposite corner of bar

Move the cursor up 4 grid points, then 16 grid
points to the right . PICK the point . A hollow
bar appears, and the extent encloses the new
element .

Now change the new element's fill to a solid
fill . PICK the CHANGE function from the Edit
Menu . When the Change Submenu appears, PICK
the STYLE function . From the menu of fill
patterns, PICK the second style . The solid
fill replaces the hollow fill in the bar .

i

Figure 2-23 . Bar

V'. NI w l wt : i
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Bars

You have now created three different elements
and are well on your way to completing the
picture .

COLOR (Optional)

	

The DR Draw COLOR function allows you to add
color to your design elements .

	

If your
computer or output devices have color
capabilities, you will want to experiment with
the COLOR function .

	

Skip this section if
neither your computer or output devices have
color capability .

To see the Color Submenu, PICK the CHANGE
function from the Edit Menu . From the Change
Submenu, PICK the COLOR function .

The Color Submenu contains eight rectangles
numbered 0 through 7 . On some color monitors
the rectangles also contain the color
represented by the number .

Printers and plotters do not necessarily have
as many colors or the same colors as the
monitor . For example, your monitor might have
four colors, and your printer might only have
three .

	

In addition, color number 2 on your
monitor might be blue, but on your printer it
might be magenta .

To learn which colors you have on your monitor
and printer or plotter, you can make a sample
color file, as described in the description of
the COLOR function in Section 5 .

If you are working with a monochrome monitor,
design elements remain monochrome on the
display screen, but you can still print or plot
in color .
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Figure 2-24 . Color Submenu

CHANGING COLOR

	

To change the color of the BAR design element,
PICK color number 3 from the submenu . The
Color Submenu disappears . If you are working
in color on the screen, the bar changes its
color to the hue corresponding to number 3 in
the menu .

COLOR (Optional)
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Arcs

ARCS Use the ARC design element to finish creating
the pencil . An arc is either part of the
circumference of a circle, or it is a filled
pie section . All of the examples in Figure 2-
25 are arcs .

r

i

Figure 2-25 . Arcs, a Variety

Figure 2-26 shows two arcs whose beginning and
end points are the same distance from the arc
center . The arcs are different because DR Draw
always draws arcs counterclockwise from the
beginning point . The beginning point of the
arc on the left is directly above the center .
The beginning point of the arc on the right is
to the right of the center .
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Figure 2-26 . Arcs with Same Points Drawn in Different Order

To add an arc to the design, PICK the ADD
function from the Edit Menu, then PICK the ARC
design element from the Add Submenu . DR Draw
prompts

PICK arc center

Move the cursor down 2 grid points from the
upper right corner of the bar, then 1 grid
point to the right .

PICK the point .

	

An asterisk marks the arc
center . DR Draw prompts

PICK arc radius/beginning of arc

Arcs



DR Draw User's Guide

	

Arcs

Move the cursor down 2 grid points and PICK .
Another asterisk appears and DR Draw prompts

PACK end of arc

Move the cursor up 4 grid points and PICK the
point . Before the arc appears, DR Draw asks
you i f you want the arc OPEN or FILLED . PICK a
FILLED arc . After a pause, the arc appears .
The arc completes the pencil figure . You have
created a drawing that demonstrates some of DR
Draw's many functions .

r

Figure 2-27 . Arc Element

R * r



From the Main Menu, PICK the SAVE function . DR
Draw prompts

B :PENCIL? (or type new name)

I f you want to save the picture file on this
drive and with this name, press the RETURN key .
DR Draw prompts

B :PENCIL : saving file

If you want to save the picture file on another
drive, type the new drive identifier, a colon,
and the filename . For example,

A :PENCIL

Then press the RETURN key .

When the prompt disappears, DR Draw has saved
the picture file on diskette .

	

You return to
the Main Menu .

If you wish to print the PENCIL picture, refer
to the print instructions in "Print Picture" in
this tutorial .

EXIT DR Draw

	

Congratulations, you have completed the first
tutorial . If you want to leave DR Draw, PICK
the EXIT function . The operating system prompt
signals your return to the operating system .
If you want to review what you have learned,
try the tutorial again . If you are ready to
learn new DR Draw functions, turn to Section 3 .
In its advanced tutorial, you learn DR Draw
functions that let you

•

	

select a new current element

•

	

scale element size

•

	

zoom in on parts of the drawing surface

2-47

DR Draw User's Guide Save The Picture

SAVE THE PICTURE You need to save your drawing for the advanced
tutorial in Section 3, where you will add some
new twists to the design . Press the DONE key
to return to the Main Menu . The pencil drawing
disappears .
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Exit DR Draw

•

	

pan across the drawing surface

•

	

adjust the relationship of overlapping design
elements with the PUT TO BACK function

End of Section 2



Section 3
Advanced Tutorial

INTRODUCTION

	

Building on concepts learned in Section 2, you
learn in this tutorial how to do the following

•

	

pan across the drawing surface

•

	

change the style for LINES

•

	

zoom full

•

	

select a new current element

•

	

zoom out from the drawing surface

•

	

zoom in on the drawing surface

•

	

scale an element

•

	

use PUT TO BACK to change the relationship of
overlapping design elements

First you will add more boxes to the
organizational chart you created in Section 2 .
Next you will use DR Draw to enhance the pencil
drawing you created .

RECALL THE

	

Begin by displaying your original picture
PICTURE FILE

	

file of the organizational chart . From the Main
Menu, PICK the RECALL function .

	

DR Draw
prompts

Picture filename?

Type the drive identifier and filename :

B : CHART

Press the RETURN key . DR Draw prompts

B :CHART : reading file

The organizational chart appears on the screen,
along with the Edit Menu .
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PAN

PAN The PAN function allows you to move the window
frame horizontally, vertically, or diagonally
across the drawing surface . In this way, you
can add design elements to areas of the drawing
surface that are not currently inside the
window frame .

PICK the CHANGE function from the Edit Menu .
From the Change Submenu, PICK the VIEW
function . The View Submenu appears under the
Edit Menu .

PICK the PAN function . DR Draw indicates the
center of the window with intersecting
horizontal and vertical lines . You see the
prompt :

PICK new center of window

Starting at the center of the window (the
intersection of the two lines) , move the cursor
10 grid points to the left, then down 1 grid
point . PICK the point . DR Draw redraws the
chart with the point you PICKed now at the
center .



DR Draw User's Guide

	

PAN

Figure 3-1 . Chart, Pan Left

COPY

	

Now you want to add more boxes to the chart .
You can do this by copying one of the existing
boxes . The extent marking the current element
encloses the upper box of the chart . To copy
that element, PICK the COPY function from the
Edit Menu . DR Draw prompts

K reference point

Move the cursor to the upper left corner of the
extent . PICK the point . DR Draw tells you

PICK location(s), press DONE to finish

3-3
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10 B

Starting from the reference point you PICKed,
move the cursor down 14 grid points, then 4
grid points to the left . PICK this point . A
new box appears on the drawing surface .

re 55 D0
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Figure 3-2 . New Box

To add another box to the chart .. start from the
upper left corner of the new current element,
and move the cursor 12 grid points to the left .
PICK the point . Another box appears .

once lete r .

f,	

e ye

COPY
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Figure 3-3 . Second New Box

J
j

Add one more box to the chart . Starting from
the last point you picked, move the cursor up 5
grid points, then 5 grid points to the left .
PICK the point . The final box in the chart
appears . Press the DONE key to finish copying .
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Figure 3-4 . Third New Box

COPY

ADD AND CHANGE

	

Your new boxes need to be labeled . First
TEXT

	

make the grid more dense by using the functions
you learned in "Change Grid Size" in Section 2 .

After you have changed the grid, PICK the ADD
function from the Edit Menu . When the Add
Submenu appears, PICK the TEXT design element .
DR Draw prompts

PICK start, type, RETURN ; DONE finishes
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It

I

Move the cursor to the lower left corner of the
last box . Move the cursor up 3 grid points,
then 4 grid points to the right .

	

PICK the
point, and type

TINA GANZ

in the box . Press the RETURN key to end the
text string .

	

Press the DONE key to finish
entering text and return to the Edit Menu .

	 ~

F

---------------

Figure 3-5 . Label In Box

The text you entered differs from the text in
the original boxes . When you saved the CHART
picture file, the current text style reverted
to the machine font .

Add and Change Text

----------------
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Add and Change Text

To change the font style to Simplex Roman, PICK
the CHANGE function from the Edit Menu . From
the Change Submenu, PICK the STYLE function .
The menu of font styles appears .

PICK the Simplex submenu selection . The name
TINA GANZ appears in the font Simplex Roman .

Now add a title to the box . PICK the ADD
function from the Edit Menu . PICK the TEXT
function from the Add Submenu . Use the lower
left corner of the TINA GANZ box as a starting
point . Move the cursor 3 grid points to the
right and up 1 grid point . PICK the point and
type

CONSULTANT

As you type, the text appears in the machine
font with the bouncing extent . When you press
the RETURN key, the font Simplex Roman replaces
the machine font .

Fill in the remaining boxes, using the labels
in Figure 3-6 . Now that you have changed the
text font style, all new text strings appear in
the font Simplex Roman . Press the RETURN key
at the end of each text string, and move the
cursor to the point at which the next string
will begin .

You can correct typing errors with the
BACKSPACE key . If you have already pressed the
RETURN key, you can press the DONE key to
finish entering text, then PICK the DELETE
function to erase the string you just entered .
If the string is not correctly located in the
box, you can relocate it with the MOVE
function . For details on the DELETE and MOVE
functions, refer to Section 5 .

Press the DONE key when you are finished .
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Figure 3-6 . Labeled Boxes

Add and Change Text

Now use the LINES design element to join the new
boxes to the rest of the chart . First make the
grid less dense . PICK the CHANGE function from
the Edit Menu . From the Change Submenu, PICK
the GRID function, then PICK the SIZE 2X
function from the Grid Submenu . A sparser grid
returns to the drawing surface .

Now PICK the ADD function from the Edit Menu .
When the Add Submenu appears, PICK the LINES
design element . DR Draw prompts

PICK points, press DONE when finished
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Add Lines

Locate the cursor at the upper left corner of
the box labeled HUME CLAYBURN . Move the cursor
4 grid points to the right and PICK .

Move the cursor up 2 grid points and PICK
again . DR Draw draws a line between the two
points .

Now move the cursor 6 grid points to the left
and PICK . Move the cursor up 2 grid points and
PICK again . Two boxes are joined .

To join these boxes to the SALES box, retrace
the last line segment by moving the cursor down
2 grid points and PICKing . Now move the cursor
6 grid points to the left and PICK again .

Finally, move the cursor down 2 grid points and
PICK .

	

Press the DONE key .

	

The cursor
disappears and the extent appears around the
line .
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Figure 3-7 . Lines Added

Now join the CONSULTANT box to the rest of the
chart . You need to start the line from the
center of the box's right edge . To do this,
you can make the grid more dense, or use SNAP
OFF to turn the SNAP off, allowing you to PICK
a point between grid points .

PICK the CHANGE function from the Edit Menu .
From the Change Submenu, PICK the GRID
function . When the Grid Submenu appears, PICK
the SNAP OFF function . When the Grid Submenu
disappears and the Edit Menu returns, DR Draw
has turned off the SNAP .

ThVE 'MITRE'

DIRE7: C) R, '

Add Lines
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Add Lines
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SALES

Now add the final line to the organizational
chart . PICK the ADD function from the Edit
Menu . From the Add Submenu, PICK the LINES
design element . DR Draw prompts

PICK points, press DONE when finished

Center the cursor on the right edge of the box
labeled CONSULTANT .

	

If you are using the
keyboard arrow keys, you can locate the cursor
more easily by changing to the slow cursor
speed . The vertical part of the cross hair
disappears when the cursor is positioned
directly over the line . See Figure 3-8 . PICK
the point .

0

'NANCY TENra

'MARKETING: '

I

HUME 0 LA •i •BL RN
'ADVERTISING

Figure 3 -8 . Cursor Position (Adding Lines)
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Add Lines

Now move the cursor horizontally to the right,
and center it over the line descending from the
box labeled MARKETING . PICK the point . Press
the DONE key . The cursor disappears, and the
new extent marks the line as the current
element .

Return to the GRID function and turn the SNAP
function back on before continuing .

CHANGE LINE STYLE In an organizational chart, a broken line often
indicates an indirect relationship .

	

To
illustrate such a relationship, change the
style of the line you just added to the chart .

•

	

ICK the CHANGE function from the Edit Menu .
From the Change Submenu, PICK the STYLE
function .

•

	

ICK the dotted line, the third style in the
menu . The dotted line replaces the solid line .

Now you are ready to use the LAYOUT and VIEW
functions to prepare the picture file for
output .

LAYOUT and

	

Use the LAYOUT function to ready the
ZOOM FULL

	

organizational chart for output to a screen,
printer, or plotter .

•

	

ICK the CHANGE function from the Edit Menu .
When the Change Submenu appears, PICK the
LAYOUT function .

	

Next PICK the LANDSCAPE
layout from the Layout Submenu . The LANDSCAPE
layout appears on the drawing surface .

Now use the ZOOM FULL function to fit the
picture file into the layout .

3-13

From the Edit Menu, PICK the CHANGE function .
When the Change Submenu appears, PICK the VIEW
function . The View Submenu appears below the
Edit Menu .

PICK the ZOOM FULL function . DR Draw redraws
and reduces the organizational chart so that it
fits in the layout .



DR Draw User's Guide

	

Add A Title

ADD A TITLE

	

Use the TEXT design element to add TUNNEY
ELECTRONICS CORPORATION to the chart . Position
the title above and to the left of the box
labeled DAVE MITRE, and keep the title within
the layout .

SAVE Now that your chart is complete, you can save it
for future editing, viewing, or output . Press
the DONE key to return to the Main Menu . When
the Main Menu appears, PICK the SAVE function .
DR Draw prompts

B :CHART? (or type new name)

Enter a new filename so that the original
picture file, CHART, will be available for
practice . Type

B :CHART3

and press the RETURN key .

You can, if you wish, continue this tutorial
when DR Draw finishes saving the file on
diskette .

However, if you want to take a break from the
tutorial, you can PICK the EXIT function from
the Main Menu to return to the operating
system .

REPORT COVER

	

Now use some new DR Draw functions to enhance
DESIGN

	

the pencil design you created in Section 2 . You
could use such a design as a report cover .

I f you need help restarting DR Draw, refer to
the Supplement for instructions .
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Recall Picture File

RECALL PICTURE

	

From the Main Menu, PICK the RECALL function .
FILE

	

DR Draw prompts

Picture filename?

Type the drive identifier and the filename

B :PENCIL

Press the RETURN key . DR Draw displays the
message

B :PENCIL : reading file

After a pause, the picture of the pencil
appears on the screen .

Figure 3 9. PENCIL Picture File
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DELETE and SELECT

DELETE AND SELECT To begin changing the picture, delete the CIRCLE
and ARC design elements from the drawing .

The extent surrounds the circle, so you can
delete the element easily .

PICK the DELETE function from the Edit Menu .
The circle disappears, and the extent appears
around the triangle . An area of the pencil
body corresponding to the circle outline also
disappears . If you wish, redraw the picture as
you learned in Section 2 .

Now you want to DELETE the arc that forms the
pencil's eraser . Because you can only DELETE
the current element, you must SELECT the arc as
the new current element . For more information
on the current element, turn to Section 4 .

PICK the SELECT function from the Main Menu .
DR Draw prompts

PICK corner of rectangle

Move the cursor to a point slightly above and
to the left of the arc . PICK the point . A
pair of intersecting lines appears . DR Draw
prompts

PICK opposite corner of rectangle

Move the cursor to a point slightly below and
to the right of the arc .

	

PICK the point .
Another pair of intersecting lines appears .
See Figure 3-10 . DR Draw prompts

PICK moves second corner, DONE finishes

D R Draw lets you change the second corner if
the element you are selecting does not lie
within the rectangle formed by the two pairs of
intersecting lines .
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Figure 3-10 . Pairs of Intersecting Lines Around Arc

If you are satisfied with the rectangle, press
the DONE key . The extent appears around the
arc, which indicates that the arc is now the
current element .

PICK the DELETE function from the Main Menu .
DR Draw removes the arc from the drawing
surface . The extent appears around the bar,
which you drew just before the arc . The bar is
now the current element .

r
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DELETE and SELECT

Uncle l ete , Delete
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ZOOM OUT

ZOOM OUT

	

Now you are going to make the pencil longer .
First, you need more room on the drawing
surface . You can use the ZOOM OUT function to
make available a larger portion of the drawing
surface in the window frame .

PICK the CHANGE function from the Edit Menu .
When the Change Submenu appears, PICK the VIEW
function . The View Submenu appears below the
Edit Menu . PICK the ZOOM OUT function . DR
Draw reduces the grid and the design elements .
The effect i s similar to stepping back from the
picture . The grid is now twice as dense as it
was before .

CHANGE ELEMENT

	

To lengthen the pencil, you need to CHANGE
SCALE

	

the dimensions of the pencil body . PICK the
CHANGE function from the Edit Menu . When the
Change Submenu appears, PICK the SCALE
function . Below the Edit Menu, DR Draw offers
two options for changing element size, UNIFORM
and NON-UNIFORM . UNIFORM changes the element
size without changing the proportions of the
element .

	

NON-UNIFORM changes the element's
proportions as well as its size .

Because you want to change the width of the bar
but retain the height, PICK the NON-UNIFORM
function . DR Draw prompts

PICK corner of new extent

Move the cursor to the grid point marking the
upper left corner of the bar . If necessary,
use the cursor speed key to slow the cursor .
PICK the point . A pair of intersecting lines
appears . DR Draw prompts

PICK opposite corner of new extent

Move the cursor to the grid point marking the
lower right corner of the bar, then move 6 grid
points to the right . PICK the point . Another
pair of intersecting lines appears . The two
pairs of lines show you how the pencil body
will look after it is stretched . DR Draw now
prompts

PICK moves second corner, DONE finishes

3-18
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Change Element Scale

This prompt allows you to relocate the second
point and define a different shape . In this
case, because you are satisfied with the second
point's location, press the DONE key . DR Draw
erases the bar and redraws it in the new shape .

	C ,Iange Select

	

Move Jndelete De e .

Figure 3-11 . Redrawn Bar

e
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ADD BORDER

	

Now ADD a decorative border to the picture . If
your system has color capability, try changing
the color of the new elements as you add them
to the picture .

First, make the grid less dense . From the Edit
Menu, PICK the CHANGE function . PICK the GRID
function from the Change Submenu . When the
Grid Submenu appears, PICK the SIZE 2X
function . The current grid disappears and a
new, less dense grid appears on the drawing
surface .

Now use the BAR design element to draw part of
the border . PICK the ADD function from the
Edit Menu . From the Add Submenu, PICK the BAR
design element . DR Draw prompts

PICK corner of bar

Move the cursor to the first grid point in the
top row . See Figure 3-12 . PICK the point .

Add Border
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Figure 3-12 . Cursor Position (Adding Border)

DR Draw displays another prompt :

PICK opposite corner of bar

Move the cursor down 2 grid points, then 2 grid
points to the right . PICK the point . A square
bar appears .

Add Border



DR Draw User's Guide

PICK location(s

Figure 3-13 . First Bar

Now add three more squares to the picture by
PICKing the COPY function from the Edit Menu .
DR Draw prompts

PICK reference point

Locate the cursor on the grid point that marks
the lower right corner of the current element .
PICK the point . DR Draw prompts

DE E ", E

), press DONE to finish

Add Border

I

Starting from the point you PICKed, move the
cursor straight down 11 grid points and PICK .
A copy of the bar appears .
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Add Border

1- :.E l E'ct M Ue

Figure 3-14 . Second Bar

To add the find two bars shown in Figure 3-15,
move the cursor to the grid point on the right
end of the same row . PICK again . A third bar
appears .

Move the cursor straight up the right edge of
the window to the third row from the top . PICK
this point . The last bar appears . Press the
DONE key to finish copying .

	~~1ce.e	elf. e



DR Draw User's Guide

v 1 i
r
i " E v 1

r ,

I

N

	

C

Figure 3-15 . Four Corner Bars

Add Border

Now use the LINES design element to complete
the picture border . PICK the ADD function from
the Edit Menu . When the Add Submenu appears,
PICK the LINES design element . DR Draw prompts

PICK points, press DONE when finished

ADD two rectangles to the border using the
LINES design element . Look at Figure 3-16 for
reference . PICK the upper right corner of the
square at the top right of the window . To draw
the border, do the following :
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Add Border

1 . Move the cursor left to the upper left
corner of the first square, and PICK .

2 . Move the cursor down to the bottom left
corner of the second square, and PICK .

3 . Move the cursor right to the bottom right
corner of the third square, and PICK .

4 . Move the cursor up to the bottom right
corner of the fourth square, and PICK .

Now move the cursor to the inside corners of
each square, PICKing each point as you go,
until. you return to the fourth square . Press
the DONE key when the two rectangles are
complete .

3-25

Figure 3-16 . Complete Border

DE ~ Ete
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You have added a border to the pencil picture
using some familiar functions . Now you use a
new DR Draw function to add more design
elements to the pencil .

ZOOM IN

	

The ZOOM IN function allows you to enlarge part
of the drawing surface . With ZOOM IN, you can
make detail changes in the picture or examine
elements more closely . Here, you will ZOOM IN
on the tapered part of the pencil between the
point and the bar that makes up the pencil's
main body .

PICK the CHANGE function from the Edit Menu .
When the Change Submenu appears, PICK the VIEW
function . From the View Submenu, PICK the ZOOM
IN function . DR Draw prompts

PICK corner of window

DR Draw is asking you to define the part of the
drawing surface you wish to fill the window .
Move the cursor to the upper left corner of the
inner, border rectangle . Now move the cursor
down 1 grid point and 1 grid point to the
right . PICK the point . Two lines intersect at
the point . DR Draw prompts

PICK opposite corner of window

Add Border
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t	Add	 ect
t

PICK moves second corner, DOSE fini he_

Figure 3-17 . Pairs of Intersecting Lines (ZOOM IN)

Using the point where the lines intersect as a
starting point, move the cursor down 6 grid
points, then 4 grid points to the right . PICK
the point . Another pair of intersecting lines
appears on the screen, and DR Draw prompts

PICK moves second corner, DONE finishes

The rectangle defined by the two pairs of
intersecting lines shows the area that will be
enlarged to fill the new window frame . Press
the DONE key .

i
~;' de I e

t
4 e

ZOOM IN

i
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ZOOM IN

DR Draw redraws the picture, blowing up the
part of the drawing surface you PICKed to fill
the window frame . Notice that the grid points
are now considerably farther apart on the
drawing surface .

To work in detail you can make the grid more
dense . PICK the CHANGE function from the Edit
Menu . When the Change Submenu appears, PICK
the GRID function .

From the Grid Submenu, PICK the SIZE 0 .5X
function . DR Draw replaces the current grid
with a denser grid . The new grid is still not
dense enough to perform the detailed work you
will be doing . Repeat the steps above, and
again PICK the SIZE 0 .5X function from the Grid
Submenu .

Figure 3-18 shows the drawing surface after you
ZOOM IN and make the grid more dense . You are
now ready to add some new elements to the
pencil .
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ZOOM IN

mange Se lec' o' e Dopy nd . t e D 1,E

Figure 3-18 . New Window Frame

ADD THREE ARCS

	

Now use the ARC design element to draw three
arcs where the pencil body begins to taper down
to the point . Use Figures 3-19a through 3-19d
as a guide . Use FILLED arcs . If you need to
review the ARC design element, refer to "Arcs"
in Section 2, or to the description of the ARC
design element in Section 6 . Use the DELETE
function if you make a mistake drawing any of
the arcs .
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H :c Change Select Move	1	Cop'_	I UUnde.~	I	I	 W .	i

Figure 3-19a . First Arc Points

Add Three Arcs

arc center (first point)

arc radius (second point)
end of arc (third point)
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Figure 3-19b . Second Arc Points

Add Three Arcs

arc center (first point)
arc radius (second point)
end of arc (third point)
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Move Copy Undelete Je eve

Figure 3-19c . Third Arc Points

Add Three Arcs

arc center (first point)
arc radius (second point)
end of arc (third point)
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Select Move Undeletc

3-33

Figure 3-19d . Three Arcs

After you add the three arcs to the picture,
you can look at the entire picture by using the
ZOOM FULL function .

PICK the CHANGE function from the Edit Menu .
When the Change Submenu appears, PICK the VIEW
function . From View Submenu, PICK the ZOOM
FULL function . DR Draw redraws the picture,
fitting all the design elements into the window
frame . Because the current layout is SCREEN,
the default layout, the picture fills the
entire window frame .

Notice that the grid is very dense . Before
continuing, use the SIZE 2X function of the
Grid Submenu to make the grid less dense .

Add Three Arcs

eee

J
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Background Element

BACKGROUND ELEMENT If you want to use a design element as a
background for the pencil, the ADD and VIEW
functions permit you to do this .

First, draw the background element . Use the
BAR design element to draw a solid rectangle
over the inner rectangle surrounding the
pencil . PICK the upper right and lower left
corners of the rectangle so the bar will have
the same dimensions as the rectangle . The bar
element appears in solid fill, blocking the
pencil from view .

	S'hs1'ge	1	Se (ect'	'	MOVE
t

	

I

	

i

Figure 3-20 . Bar Covers Pencil

Je ~ ete
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Change Style

CHANGE STYLE

	

The new bar has the same fill style as the
pencil body . Next contrast the two elements by
changing the fill style of the new bar .

PICK the CHANGE function from the Edit Menu .
When the Change Submenu appears, PICK the STYLE
function . The Style Submenu appears .

I	

PICK the fourth style from the left . DR Draw
fills the bar with the style fill pattern you
have chosen and returns you to the Edit Menu .

E' EC

Figure 3-21 . New Bar Style

--------------------

E E E
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PUT TO BACK

	

Now you can place the new bar behind the pencil .

	m
Ch nee

PICK the CHANGE function from the Edit Menu .
When the Change Submenu appears, PICK the VIEW
function . PICK the PUT TO BACK function from
the View Submenu .

When DR Draw redraws the picture, it places the
current element, the new bar, on the drawing
surface first, then draws the other design
elements . The pencil is now visible, and the
current element is in the background .

:elec1 dove

--------------------------------

--------------------------------

Figure 3-22 . Bar Put To Back

Copy n elegy . De1e e

PUT TO BACK
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Add Title

ADD TITLE

	

To complete your picture, add a title to the
report cover .

To begin, make some room for the title by using
the ZOOM OUT function .

	

PICK the CHANGE
function from the Edit Menu . When the Edit
Menu appears, PICK the VIEW function . From the
View Submenu, PICK the ZOOM OUT function . DR
Draw reduces the picture .

From the Bdit Menu, PICK the ADD function .
PICK the TEXT design element from the Add
Submenu and type under the picture

MOUNTAIN PENCILS ANNUAL SALES

Using the CHANGE and STYLE function, PICK the
Simplex submenu selection . The text appears in
the font Simplex Roman . Use the MOVE function
to center the title beneath the picture . See
Figure 3-23 . Your design is complete . If you
want to change the layout of the picture, do so
now before you save the picture .
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MOUNTAIN PIN( ILS

	

ANNUAI SALLS

Copy rice 1,e

Figure 3-23 . Complete Picture

e De ~e le

Add Title

SAVE THE DRAWING

	

To save the picture file on the diskette, press
the DONE key to return to the Main Menu . PICK
the SAVE function from the Main Menu . DR Draw
prompts

B :PENCIL? (or type new name)

Press the RETURN key, or type a new filename
and press the RETURN key . In the first case,
DR Draw displays the message

B :PENCIL : saving file
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Save the Drawing

When the message disappears, DR Draw has saved
the file on diskette .

	

You can now use the
OUTPUT function to see your drawing displayed
on a plotter, printer, or the screen .
Otherwise, you can leave DR Draw by PICKing the
EXIT function from the Main Menu .

	

The
operating system prompt appears to signal your
return to the operating system .

Congratulations, you have completed the
advanced tutorial and learned some
sophisticated DR Draw functions in the process .
These tutorials, together with Sections 4, 5,
and 6, enable you to develop your skills
further with DR Draw .

End of Section 3





Section 4
Concepts

INTRODUCTION

	

By working through the tutorials in Sections 2
and 3, you learned the essentials of creating
and editing pictures with DR Draw .

	

This
section describes the following DR Draw
concepts :

•

	

DR Draw menus
•

	

the drawing surface
•

	

cursors
•

	

the current element
•

	

style
•

	

filenames
•

	

active picture files
•

	

picture file diskettes

DR Draw MENUS

	

DR Draw's menus contain functions and design
elements . The menus appear in two lines across
the top of the display screen . The Main Menu
and the Edit Menu appear at different times in
the top line . Submenu s , prompts, and messages
appear in the second menu line ; all are
described later in this section .

Main Menu

	

When you start a session in DR Draw, the Main
Menu appears in the top menu line . The line
below it is empty .

	

The Main Menu contains
seven functions .

Create Recall Edit Save

Figure 4-1 . Main Menu

4 -1

Di rectory Output Exit
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DR Draw Menus

Using the Main Menu functions, you can

•

	

create a new picture file

•

	

recall an existing picture file

•

	

edit a picture file that you create or recall

•

	

save a picture file

•

	

display a directory of picture files

•

	

produce output from a picture file

•

	

exit DR Draw and return to the operating
system

Section 5 describes all Main Menu functions .

Edit Menu You must be in the EDIT function to draw a new
picture or make changes to an existing picture
file . When you PICK the CREATE or RECALL
function and give a valid filename, you
automatically pass to the EDIT function .
Filenames are discussed in detail later in this
section .

When you are in the EDIT function, the Edit
Menu replaces the Main Menu in the first line .
The line below it is empty . The Edit Menu
contains the following seven functions .

Add Change Select Move Copy Undelete Delete j

Figure 4- 2 . Edit Menu
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DR Draw Menus

With the Edit Menu functions, you can

•

	

add design elements to a picture file

•

	

change the characteristics of individual
design elements or of the DR Draw environment

•

	

select a new current element

•

	

move a design element

•

	

copy a design element

•

	

undelete a deleted design element

•

	

delete a design element

Section 5 describes all Edit Menu functions .
Section 6 describes design elements, which you
add by PICKing the ADD function .

Submenus Two Main Menu functions, EDIT and OUTPUT, have
submenus that appear on the second menu line .
Contents of the submenus include functions,
design elements, and other choices that supply
DR Draw with necessary additional information .

For example, i f you PICK the ADD function from
the Edit Menu, you need to tell DR Draw which
of the seven design elements to add . The Add
Submenu lists the seven and allows you to PICK
one of them .

Prompts and

	

DR Draw uses prompts to give you instructions
Messages

	

and to request information from you . Prompts
appear in the second menu line in place of
submenus .

Some prompts require that you type a response .
The response appears on the second line
immediately following the prompt .

In addition, DR Draw displays a variety of
informational and error messages, most of which
also appear on the second line .

4-3



briefly describe the problem and give you
instructions on what to do next .

In Section 5, the description of each function
lists the error messages associated with the
function and describes the cause of the error .

DRAWING SURFACE The drawing surface is two-dimensional . It is
visible inside a rectangle located just below
the menu lines, as Figure 4-3 illustrates . The
drawing surface is visible only when you are in
the EDIT function ; at other times that part of
the screen is empty .

menu
lines

Figure 4- 3 . Drawing Surface

window
frame

drawing
surface

grid

DR Draw User's Guide DR Draw Menus

Error Messages DR Draw displays error messages when it
encounters problems that prevent it from
proceeding as requested . Error messages
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Drawing Surface

Window and Window The display screen acts as a window to the
Frame

	

drawing surface ; the rectangular outline is the
window frame .

You control how much of the picture file is
visible in the window frame .

	

If design
elements are outside the window frame, they are
still part of the picture file, but they are
not visible . With the VIEW function described
in Section 5, you can

•

	

move the window over the drawing surface to

- look at other parts of your picture file

- add or modify design elements

•

	

zoom in on the drawing surface for a more
detailed view

•

	

zoom out for a broader view

•

	

fit the entire picture file into an output
layout

Grid and Snap

	

When you begin a new picture file, the drawing
surface is filled with a grid of evenly spaced
points that help you locate and align design
elements .

To further help you locate design elements, DR
Draw automatically snaps to the nearest grid
point when you PICK a point on the drawing
surface .

The GRID function, described in Section 5,
allows you to turn the grid and snap off when
you do not wish to use the points for
alignment .

CURSORS

	

Cursors mark your position in the menus and on
the drawing surface .

	

DR Draw uses three
cursors : a menu cursor, a graphics cursor, and
a text cursor .
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Cursors

Menu Cursor

	

The menu cursor marks your position on one of
the menu lines . To PICK a function or design
element, move the menu cursor to the correct
position and press the PICK key .

The menu cursor can be a reverse video bar or a
cross hair (+), depending on your computer .

Reverse video describes the appearance of
characters against the display's background
color . For example, a screen that ordinarily
shows light characters on a dark background
indicates the cursor's position in reverse
video by showing dark characters on a light
background .

You do not have to place the cross hair
directly on top of the menu .

	

To PICK a
function or design element, you can locate the
cursor on or below your choice and press the
PICK key .

The menu cursor's operation varies from
keyboard to mouse . Table 4-1 outlines these
differences .

Table 4-1 . Menu Cursor

Input
Device

Cursor Movement
PICK DONELeft-Right I Right-Left

keyboard TAB BACKSPACE

	

SPACE BAR RETURN

mouse mouse movement PICK key DONE key

Menu Cursor : In keyboard operation, the reverse video bar
Wrapping cursor wraps in both directions . Wrap means

that if you advance the cursor past one end of
the menu, it reappears at the other end of the
menu .



DR Draw User's Guide

	

Cursors

For example, if you press the TAB key when the
Edit Menu cursor i s on the DELETE function, the
cursor appears on the ADD function . Similarly,
if you press the BACKSPACE key when the cursor
is on the ADD function, the cursor appears on
the DELETE function .

Graphics Cursor

	

The graphics cursor appears after you PICK any
of the Edit Menu functions but DELETE or
UNDELETE . The graphics cursor is a cross hair ;
its center marks your position on the drawing
surface .

Graphics Cursor :

	

The graphics cursor can move anywhere on the
Range of Motion

	

drawing surface inside the window, but you
cannot move the cursor beyond the window frame .

Graphics Cursor :

	

If you use a mouse to move the graphics
Mouse

	

cursor, the cursor echoes the mouse's movement .
If you need further information on the mouse,
consult the documentation supplied with it .

Graphics Cursor :

	

With a keyboard, you use the four arrow keys
Keyboard

	

to move the graphics cursor up and down and left
and right . To move the cursor diagonally, you
combine vertical and horizontal cursor
movements . To move the cursor continuously,
hold down the arrow key that is moving the
cursor .
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Cursors

Graphics Cursor :

	

You can move the cursor rapidly or slowly .
Speed and Distance The fast speed corresponds to a large cursor

movement each time you press the arrow key ; the
slow speed corresponds to a short movement .
One of the keys on your keyboard allows you to
reduce the cursor's speed and distance . The
same key allows you to return the cursor to its
original speed and distance .

	

The key is
identified in the Supplement or the
documentation that accompanied your computer
system .

Text Cursor

	

The text cursor marks the location of characters
you type from the keyboard . The cursor is an
underscore . You see the text cursor at two
different times during a DR Draw work session .

1 . When you PICK the TEXT design element from
the Add Submenu and then PICK a point for
entering text, the text cursor appears on
the drawing surface . Section 6 describes
the TEXT design element .

2 . When a prompt requires that you type a
response, the text cursor appears on the
second menu line immediately following the
prompt .

CURRENT ELEMENT

	

To draw pictures with DR Draw, you PICK design
•

	

lements from the Add Submenu . One design
•

	

lement in the picture file is called the
current element .

	

The current element is
defined as one of the following :

•

	

the most recently added element in a picture
file you are working on

•

	

the first-drawn element when you recall a
picture file

•

	

an element that you explicitly select as the
current element
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Extent

	

The current element is surrounded by a
rectangular dashed line called the extent .
Figure 4-4 shows you the current element and
the extent .

I

_w.-an a&-s-u....'monsoon= a&anwwwwwwwwwww&	wwwwwwwwwwwwwww•
Vwwwwwwwwwwwwwwww%.	wwwwwwwwwwwwwwwwwl
vwwwwwwwwwwwwwwwww1b.
wwwwwwwwwwwwwwwwwr.a

	

a someone-museum wwwwwwwuIqRwwwwwwwwwwW-.wwwwww~ •

The MOVE, COPY, and DELETE functions, as well
as several of the CHANGE functions, affect only
the current element .

Figure 4-4 . Current Element and Extent

Current Element

current
element

extent

Shared Extents

	

If two or more elements share the same extent
(for example, a circle inscribed in a square),
the first-drawn element is the current element
whenever you select the shared extent .
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STYLE

Initial Style

Changing Style

A design element can have one of four style
attributes :

•

	

type style
•

	

line style
•

	

fill pattern
•

	

marker style

The style that DR Draw assigns to each design
element when you create a new picture file or
recall an existing one is called its initial
style .

	

Table 4-2 lists the attributes and
initial styles for each design element .

Table 4-2 . Initial Styles

Using the STYLE function described in Section 5,
you can change a design element's style . For
example, you can change machine font text to
one of three other fonts, and you can change
the solid line of an open arc to one of several
other line styles .

Style

Design Element Attribute Initial Style

TEXT type style machine font
POLYGON fill pattern solid fill
OPEN CIRCLE line style solid line
FILLED CIRCLE fill pattern solid fill
OPEN ARC line style solid line
FILLED ARC fill pattern solid fill
LINES line style solid line
BAR fill pattern solid fill
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Style

Current Style When you change an element's style, you
establish a current style that replaces the
initial style . From that point on, all
• lements that share the attribute of the
element you changed appear in the current
style . For example, if you change the fill in
a bar, the new fill pattern appears in all
subsequent bars, and also in polygons, filled
•

	

ircles, and filled arcs .

The current style

•

	

only affects elements in your current picture
file

•

	

does not affect any elements added before you
changed style

•

	

remains in effect until the next time you
change style or until you save the file

When you save or recall a file, DR Draw resets
the style to the initial style . Elements
already in the picture file are not changed,
but all new elements appear in their initial
styles until you change style .

Open and Filled

	

An open design element consists of straight
Design Elements

	

or curved lines . The space enclosed by the
lines has nothing in it .

A filled design element consists of straight or
curved lines with a pattern inside . Fill
patterns include solid fill, cross hatching,
and the hollow fill described below .

You can make CIRCLE and ARC design elements
• ither OPEN or FILLED when you draw them .
POLYGON and BAR design elements are always
filled . Shapes drawn with LINES are always
open .
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Style

Hollow Fill

	

The hollow fill pattern produces an element that
looks like an open element .

	

You see the
difference when you overlay elements .

When you draw an open element on top of another
element, you can see the element underneath .
If you do the same with a hollow-filled
element, the hollow fill masks the element it
overlaps .

	

Figure 4-5 illustrates the
difference between an open element and one with
hollow fill .

open circle

	

circle with
hollow fill

Figure 4-5 . Hollow Fill
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Filenames

FILENAMES

	

When you PICK the CREATE, OUTPUT, RECALL, and
SAVE functions, DR Draw asks you to supply a
filename . Filenames identify picture files for
you, DR Draw, and the operating system . The
filename you select must be unique ; you cannot
have two picture files with the same filename
on the same diskette .

The filename can be any combination of letters
and numbers that does not exceed eight
characters . DR Draw ignores anything after the
eighth character . The alphabetic characters
can be uppercase, lowercase, or both .

Illegal Characters Do not use the following characters in a
filename :

Filetype

<> ,

	

!

	

I * ? & / $ C J ( ) •

	

•• ,

Some operating systems and applications reserve
these characters for special purposes .

In addition, do not use spaces in filenames .
DR Draw ignores spaces .

After you supply the filename, DR Draw adds a
•

	

PIX f i letype . For example, the filename CHART
becomes CHART .PIX. The filetype identifies the
file as a DR Draw picture file . Do not give a
•

	

PIX filetype to a file that you did not create
with DR Draw .

If you include a period as part of the
filename, as in the example in Table 4-3, DR
Draw treats the period and any subsequent
characters as an invalid filetype . DR Draw
discards the invalid filetype and supplies PIX
in its place .

3
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Table 4-3 . Filenames

Filenames

Filename Typed Filename Used Explanation

flow

	

flow .pix

	

valid as given

orgchart

	

orgchart .pix

	

valid as given

organization

	

organiza .pix

	

too many characters

org .plan

	

org .pix

	

period in filename

For additional information on specifying
filenames, consult your operating system
manual .

ACTIVE PICTURE

	

The picture file you are working on in the
FILES

	

EDIT function is called your active picture
file ; it is like a sheet of drawing paper you
spread on your desk or table .

Created and

	

If you create a new picture file, the active
Recalled Files

	

file is the only existing version of your
picture file ; no previous version is stored on
diskette .

If you recall an existing picture file, the
active file is a copy of the file you recalled .
The original version remains on diskette until
you replace it by saving the active file under
the same name .

For more information, see the descriptions of
the CREATE, RECALL,. and SAVE functions in
Section 5 .
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Active Picture Files

Abandoning an

	

If you PICK the CREATE, RECALL, OUTPUT, or
Active File

	

EXIT function without saving your active picture
file, DR Draw displays the following prompt :

Abandon active picture file? (Y/N)

An N (No) response returns you to the Main Menu
and allows you to save the file . A Y (Yes)
response abandons your active picture file,
which is like tearing up the sheet of drawing
paper and discarding the pieces in the
wastebasket .

	

You no longer have an active
file .

PICTURE FILE

	

Unless you specify otherwise, DR Draw saves
DISKETTES

	

picture files on the same diskette that contains
DR Draw . You can, however, save your picture
files on a separate diskette to give you more
room for file storage and to make it easier for
you to identify your DR Draw picture files .

Disk Drive

	

The disk drive identifier, a letter from A to
Identifier

	

P followed by a colon, identifies the drive in
which your diskette is located .

If you use a separate picture file diskette,
you must identify the drive when you give a
picture filename . For example, if DR Draw is
on the diskette in drive A and you want a file
called FLORPLAN on the diskette in drive B,
type

B :FLORPLAN

to any DR Draw filename prompts .
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Picture File Diskettes

Disk Drive When you specify a separate picture file
Identifier in diskette, DR Draw includes the disk drive
Messages

	

identifier in messages . For example, if you use
the SAVE function to save the file called
FLO RPLAN on the diskette in drive B, DR Draw
displays the following message :

B :FLORPLAN : saving file

End of Section 4



Section 5
Functions

INTRODUCTION This section describes in alphabetical order the
functions contained in the Main Menu, Edit
Menu, and Change Submenu . Section 6 describes
the design elements contained in the Add
Submenu .

The Main and Edit Menus are illustrated at the
beginning of Section 4 . The Main Menu contains
seven functions :

•

	

CREATE
•

	

DIRECTORY
•

	

EDIT
•

	

EXIT
•

	

OUTPUT
•

	

RECALL
•

	

SAVE

The Edit Menu also contains seven functions :

•

	

ADD
•

	

CHANGE
•

	

COPY
•

	

DELETE
•

	

MOVE
•

	

SELECT
•

	

UNDELETE

Change Submenu When you PICK the CHANGE function from the Edit
Menu, the Change Submenu appears on the second
line . The Change Submenu contains seven
functions :

•

	

COLOR
•

	

GRID
•

	

LAYOUT
•

	

REDRAW
• SCALE
• STYLE
•

	

VIEW
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Introduction

Prompts After you PICK a function, DR Draw in many cases
displays prompts that ask for needed
information or that instruct you how to
proceed .

When a function has two or more prompts, you
respond to one prompt before DR Draw displays
the next . The descriptions of the functions
reflect this sequence by following the text of
each prompt with a description of how you
respond .

Error Messages As outlined in Section 4, DR Draw displays error
messages when it encounters problems that
prevent it from proceeding as requested .

In several cases functions have two or more
error messages associated with them . In that
case, the description of the function gives
each error message, its cause, and your
response .
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ADD

Purpose

	

The ADD function lets you PICK design elements
to add to your picture file .

Add Submenu When you PICK the ADD function from the Edit
Menu, the Add Submenu appears on the second
menu line, as Figure 5-1 illustrates . If your
menu cursor is a reverse video bar, it appears
on the second menu line . If your menu cursor
is a cross hair, it appears on the drawing
surface . Section 4 describes menu cursors .

The Add Submenu contains seven design elements,
which are described in Section 6 .

Add
Text

Change [ Select
Polygon I __Circle	j

Move

	

-opy
Arc Lines

Undelete Delete J
Markers -1- Bar

ADD

Figure 5-1 . Edit Menu and Add Submenu
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CHANGE

CHANGE

Purpose

	

The CHANGE function lets you change

•

	

the style of design elements

•

	

the view of the picture file in the window

•

	

the scale (size and/or proportions) of design
elements

•

	

the layout used for output

•

	

the color of design elements

•

	

the grid's characteristics

and redraw the active picture file .

When you PICK the CHANGE function from the Edit
Menu, the Change Submenu appears on the second
menu line, as Figure 5-2 illustrates . If your
menu cursor is a reverse video bar, it appears
on the second menu line . If your menu cursor
is a cross hair, it appears on the drawing
surface . Section 4 describes menu cursors .

The Change Submenu contains seven functions .
Descriptions of these appear alphabetically in
this section .

Add	Chance
Style

	

View
Select Move Copy

Layout	Color
Undelete

Scale Grid
Delete
Redraw

Figure 5-2 . Change Submenu
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COLOR

COLOR

Purpose

	

The COLOR function lets you change the color of
the current element .

When you PICK the COLOR function from the
Change Submenu, the Color Submenu replaces the
Change Submenu on the second line . The Color
Submenu lists eight colors, in rectangles
numbered 0 through 7 . I f your menu cursor i s a
reverse video bar, it remains on the second
menu line . If your menu cursor is a cross
hair, it appears on the drawing surface .
Section 4 describes menu cursors .

The appearance of the Color Submenu depends on
the display you have . On some color display
monitors, the menu rectangles appear in the
color represented by the number . For example,
if color number 2 is red, the number 2
rectangle has a red fill in addition to the
number .

Sample Color File Some color monitors, printers, and plotters do
not support all eight colors . To learn which
colors are represented by the numbers on the
menu, create a picture file with eight bars .
Number the bars from 0 to 7, and change the
color of each one to the corresponding color .
You can save and print the file for quick
reference .
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COPY

COPY

Purpose

	

The COPY function copies the current element to
locations you choose on the drawing surface .

Prompts

	

When you PICK the COPY function, DR Draw
displays two prompts in the sequence below .

PICK reference point

PICK a reference point on or near the extent .
Reference points are described below .

In many cases a corner of the extent is the
easiest point to use as a reference point .

PICK location(s), press DONE to finish

Move the cursor to the reference point's new
location and press the PICK key . DR Draw
copies the element to the new location . Each
additional PICK copies the element to another
location . Each new copy of the element becomes
the current element . Press the DONE key to
return to the Edit Menu .

Reference Points The COPY function divides the extent into nine
invisible sectors, as Figure 5-3 illustrates .
All except the middle sector (number 5) extend
infinitely beyond the extent .

A design element has nine reference points,
which are marked in Figure 5-3 : the corners of
the extent, the midpoint of each side of the
extent, and the center of the extent . If, for
example, you PICK a point anywhere in sector
number 4, DR Draw uses the midpoint of the left
side of the extent as the reference point .
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Figure 5-3 . Reference Points

9

COPY
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CREATE

CREATE

Purpose The CREATE function permits you to begin a new
picture file . DR Draw opens an active picture
file under the name you supply .

•

	

ICKing the CREATE function is like the
following :

•

	

going to the cabinet where you store your
drawings

•

	

making a space for the new drawing by writing
a filename on an empty folder

•

	

returning to your drawing table

•

	

setting a fresh sheet of drawing paper in
front of you

Prompt

	

DR Draw displays the following prompt when you
PICK the CREATE function .

•

	

icture filename?

When you give a filename, DR Draw checks your
• irectory to be sure that filename does not
already exist with a PIX filetype . If the
file is not found, DR Draw automatically places
you in the EDIT function, and you can start
drawing .

Error Messages

	

You can receive one of two error messages when
you PICK the CREATE function .

CHART : already exists, press DONE

You gave a filename (in this case, CHART) that
is already in your directory with a PIX
filetype . Press the DONE key to return to the
Main Menu . To begin a new picture file, PICK
the CREATE function again and give a new
filename .

Abandon active picture file? (Y/N)

You PICKed the CREATE function without saving
your active picture file . DR Draw displays
this error message instead of the prompt .
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CREATE

I f you respond Y (Yes), DR Draw abandons the
active picture file and prompts

Picture filename?

Section 4 discusses abandoning an active
picture file .

If you respond N (No), DR Draw returns you to
the Main Menu . To continue working on your
active picture file, PICK the EDIT function .
To save the active file, PICK the SAVE
function .



the picture file . If design elements remain
after the first-drawn element is deleted,
DELETE works forward in sequence .

Each time you delete an element, the next
element in the sequence becomes the current
element .

The five design elements in Figure 5-4 were
added to the file in the order indicated by the
numbers . I f you start with the star as the
current element, DELETE works in the sequence
5-4-3-2-1 .

However, if you start with the arc as current
element, the sequence is 3-2-1-4-5 .

You can delete an element that is not inside
the window frame . For example, in Figure 5-4,
if you ZOOM IN until only the bar is visible,
you can still delete the star, arc, circle, and
square .

Overlapping

	

Deleting an element that overlaps another
Elements

	

also removes from the drawing surface some or
all of the element underneath . For example,
when you delete the circle in Figure 5-4, a
circular hole appears in the square .

The Grid In addition, if you delete any element from the
drawing surface when the grid is on, the grid
points under the element are also deleted .

To restore the missing parts of an element or
missing grid points, use the REDRAW function
described later in this section .

DR Draw User's Guide

DELETE

DELETE

Purpose The DELETE function removes the current element
from your picture file .

Design Element You delete design elements strictly by the
Order order in which you added them, starting with the

current element and working backwards in
sequence until you reach the first element in
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Figure 5-4 . Deleting Elements

DELETE
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DIRECTORY

DIRECTORY

Purpose The DIRECTORY function lists all files with a
.PIX f iletype on the diskette in a drive you
specify .

While you are using the EDIT function, you can
look at the directory without affecting work in
progress .

Prompts

	

When you PICK the DIRECTORY function, DR Draw
displays two prompts in the sequence below .

On which drive?

Give the disk drive's identifier, a letter from
A to P . I f you do not give a drive identifier,
DR Draw returns you to the Main Menu .

DIRECTORY complete, press DONE

Press the DONE key to clear the directory from
the screen and return to the Main Menu . To
resume work on an active picture file, PICK the
EDIT function .

Error Message

	

You can receive the following error message when
you PICK the DIRECTORY function .

No PIX files on disk, press DONE

No . PIX files are on the drive specified .
Press the DONE key to return to the Main Menu .



modify picture files .

When you PICK the CREATE or RECALL function and
give a correct filename, DR Draw automatically
places you in the EDIT function .

If you return to the Main Menu while editing a
picture file, you can PICK the EDIT function to
resume work on your active file . There are two
common reasons for returning to the Main Menu
in the middle of working on a picture file :

•

	

You wanted to check the directory .
•

	

You accidentally pressed the DONE key .

Edit Menu

Add

	

I Change

The Edit Menu replaces the Main Menu on the
first menu line . The Edit Menu lists the seven
functions shown in Figure 5-5 .

Select

	

Move	Copy	Undelete Delete

Figure 5-5 . Edit Menu

Error Message

	

You can receive the following error message when
you PICK the EDIT function .

No active picture file, press DONE

You PICKed the EDIT function, but you do not
have an active picture file . Press the DONE
key to return to the Main Menu .

DR Draw User's Guide

EDIT

EDIT

Purpose The EDIT function lets you draw, update, and
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EXIT

EXIT

Purpose

	

The EXIT function lets you leave DR Draw and
return to the operating system .

Error Message

	

You can receive the following error message when
you PICK the EXIT function .

Abandon active picture file?

You PICKed the EXIT function without saving
your active picture file .

If you respond Y (Yes), DR Draw abandons the
active picture file and returns you to the
operating system prompt . Section 4 discusses
abandoning an active picture file .

If you respond N (No), DR Draw returns you to
the Main Menu . To continue working on your
active picture file, PICK the EDIT function .
To save the active file, PICK the SAVE
function .

(YEN)
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GRID

GRID

Purpose

	

The GRID function allows you to change the
appearance or function of the drawing grid .

When you PICK the GRID function from the Change
Submenu, the Grid Submenu replaces the Change
Su bmenu on the second line . If your menu
cursor is a reverse video bar, it remains on
the second menu line . I f your menu cursor i s a
cross hair, it appears on the drawing surface .
Section 4 discusses menu cursors .

Depending on the status of GRID and SNAP, three
different Grid Submenus can appear . In its
initial state, the Grid Submenu has four
functions .

Grid Off

	

Size 2x ;Size 0.5XISnap Off

Figure 5-6a . Grid Submenu

GRID OFF When you PICK the GRID OFF function, DR Draw
turns off the grid, which removes the points
from the drawing surface . At the same time, DR
Draw automatically turns off the snap .

SIZE 2X When you PICK the SIZE 2X function, DR Draw
redraws the grid with the points twice as far
apart as in the present grid ; the grid becomes
half as dense . SIZE 2X does not affect the
size of elements in your picture file .

Message

	

You can receive the following message when you
PICK the SIZE 2X function .

Cannot show grid, press DONE

Using the SIZE 2X function, you made the grid
points so far apart that DR Draw turns the grid
off and reports its status to you . You have
not made an error ; you can leave the grid off
i f you want .
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GRID

You can make the grid more dense with the SIZE
0 .5X, ZOOM OUT, or ZOOM FULL functions .
However, after you PICK one of these functions,
you must PICK the GRID ON function to make the
grid visible again .

SIZE 0 .5X When you PICK the SIZE 0 .5X function, DR Draw
redraws the grid with the points half as far
apart as in the present grid ; the grid becomes
twice as dense . SIZE 0 .5X does not affect the
size of elements in your picture file .

Message

	

You can receive the following message when you
PICK the SIZE 0 .5X function .

Cannot show grid, press DONE

Using the SIZE 0 .5X function, you made the grid
too dense to be visible as individual points .
D R Draw turns the grid off and reports its
status to you . You have not made an error ; you
can leave the grid off if you want .

You can make the grid less dense with the SIZE
2X and ZOOM IN functions . However, after you
PICK one of these functions, you must PICK the
GRID ON function to make the grid visible
again .

SNAP OFF When you PICK the SNAP OFF function, DR Draw
turns the grid snap off . For more details on
SNAP, refer to Section 4 .

When the snap is off, you can PICK the cursor's
exact location on the drawing surface . The
cursor does not snap to the nearest grid point .

Second Submenu

	

The Grid Submenu changes according to the
current status of GRID and SNAP .

You see the following submenu after you turn
off the grid .
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GRID

[ Grid On	Size 2x	jSize 0 .5X I,

Figure 5-6b . Grid Submenu

GRID ON When you PICK the GRID ON function, DR Draw
turns the grid on and restores the points to
the drawing surface .

Because DR Draw automatically turned off the
snap when you turned off the grid, no SNAP
function appears on this submenu . You cannot
turn the snap on when the grid is off .

Third Submenu

	

You see the following submenu when you turn the
snap off but leave the grid on .

Grid Off , Size 2x	Size 0 .5X Snap On j

Figure 5-6c . Grid Submenu

When the snap is turned off, DR Draw PICKs the
cursor's exact location on the drawing surface .
The cursor does not snap to the nearest grid
point .

Turning off the snap is particularly useful
when you are entering text strings inside
boxes . For example, in the Menu Map at the
beginning of this user's guide (Figure 1-2),
the menu rectangles were drawn using the LINES
design element with the snap turned on . The
text strings were inserted in the boxes with
the snap turned off .
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GRID

SNAP ON

	

When you PICK the SNAP ON function, DR Draw
turns the snap on .
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LAYOUT

LAYOUT

Purpose

	

The LAYOUT function tells DR Draw which output
format to use when you send your picture file
to the screen, printer, or plotter . Only the
part of the picture file within the layout
appears in output .

When you PICK the LAYOUT function from the
Change Submenu, the Layout Submenu replaces the
Change Submenu on the second line . If your
menu cursor is a reverse video bar, it remains
on the second menu line . If your menu cursor
is a cross hair, it appears on the drawing
surface . Section 4 describes menu cursors .

The Layout Submenu contains three layout
formats .

P rtrait LLandscape Screen

Figure 5-7 . Layout Submenu

PORTRAIT

	

PORTRAIT is the format of a vertical sheet of
standard letter-size paper, 8 1/2-inches wide
by 11-inches high . A rectangular outline on
the drawing surface shows you the PORTRAIT
layout boundaries .

LANDSCAPE

	

LANDSCAPE is the format of a sheet of horizontal
paper, 8 1/2-inches high by 11-inches wide . A
rectangular outline on the drawing surface
shows you the LANDSCAPE layout boundaries .

SCREEN

	

SCREEN format uses the entire drawing surface ;
the window frame is the layout boundary . When
you PICK the CREATE function, DR Draw
automatically places you in SCREEN layout . If
you send a picture file produced in SCREEN
layout to a printer or plotter, DR Draw fits it
to the paper vertically .
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LAYOUT

LAYOUT

D

PORTRAIT

A

B D
LANDSCAPE

A C

D

SCREEN

Figure 5-8 shows the relationship of layout to
output .

HARDCOPY

	

SCREEN
OUTPUT

	

OUTPUT

A

	

C

B

	

D

A

	

C

B

	

D

Figure 5-8 . Layout to Output

A

	

C

B D

A

I F) D
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MOVE

MOVE

Purpose The MOVE function allows you to relocate the
current element to another position on the
drawing surface .

Prompts

	

When you PICK the MOVE function, DR Draw
displays two prompts in the sequence below .

PICK reference point

PICK a reference point on or near the element's
extent . Reference points are described under
the COPY function .

In many cases a corner of the extent is the
easiest point to use .

PICK new location, press DONE to finish

Move the cursor to the reference point's new
location anywhere on the drawing surface and
PICK that point . DR Draw deletes the element
from its current position and redraws it at the
new location .

If you are not satisfied with the element's
location, you can PICK another point . Again,
DR Draw deletes the element and redraws it in
the new location . When you are satisfied with
the location, press the DONE key to return to
the Edit Menu .
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OUTPUT

OUTPUT

Purpose

	

The OUTPUT function sends your picture file to
one of four output devices .

Output Submenu When you PICK the OUTPUT function, the Output
Submenu appears on the second menu line . The
Output Submenu lists the four possible output
devices in the order shown below . If your menu
cursor is a reverse video bar, it appears on
the second menu line . If your menu cursor is a
cross hair, it appears on the drawing surface .
Section 4 describes menu cursors .

Printer Plotter Screen 1 Screen 2

Figure 5-9 . Output Submenu

Printer/Plotter You can send your picture file to be printed on
printer or plotter paper or on transparencies .
I f you specify a printer or plotter, DR Draw
prints or plots a single copy of the picture
file, then returns you to the Main Menu .

Screen 1/Screen 2 You can send your picture file to a black and
white screen or to a color screen if you have
the necessary equipment and software . For more
information, refer to the Supplement .

DR Draw reproduces your picture file on a
display screen without the window frame, layout
lines, grid points, or menu lines .

To return to the Main Menu from screen output,
press the DONE key .

Prompt

	

DR Draw displays this prompt after you PICK one
of the output devices .

Picture filename?

Type the filename after the prompt . If the
filename is valid, DR Draw sends the picture
file to the output device you PICKed .
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OUTPUT

LANDSCAPE Layout

Printing Time

If your picture file is in LANDSCAPE layout and
you have specified a printer or plotter, you
see the message :

Preparing file for landscape output

DR Draw requires time to process a picture file
for printer/plotter output . The amount of
preparation time depends on the number and
types of design elements in the file . Do not
worry if the printer or plotter does not start
immediately .

Error Messages

	

You can receive one of two error messages when
you PICK the OUTPUT function .

Abandon active picture file? (Y/N)

You PICKed the OUTPUT function without saving
your active picture file . DR Draw displays
this message instead of the Output Submenu . If
you respond Y (Yes), DR Draw abandons your
active picture file and displays the Output
Submenu . Section 4 discusses abandoning an
active picture file .

If you respond N (No), you return to the Main
Menu .

CHART : not found, press DONE

DR Draw cannot find the file you named (in this
case, CHART) . Press the DONE key to return to
the Main Menu .

Check to see that you included a correct drive
identifier, if one is required . The drive
identifier appears in the message only if you
gave it in your response to the filename
prompt .
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RECALL

RECALL

Purpose The RECALL function lets you retrieve a picture
file that you saved . DR Draw opens an active
picture file by copying the file stored on your
diskette . The original remains on the diskette
unless you replace it with the SAVE function .

•

	

ICKing the RECALL function is like the
following :

•

	

going to the cabinet where you store your
drawings

•

	

taking out a drawing

•

	

making a photocopy of the drawing

•

	

returning the original to the storage cabinet

•

	

putting the copy on your drawing table

Prompt

	

DR Draw displays the following prompt when you
PICK the RECALL function .

•

	

icture filename?

Type the filename : for this example, CHART .
You do not need to give the PIX filetype ; DR
• raw searches only for files with that
filetype .

If the file is in your directory, you see the
following message :

CHART : reading file

• R Draw displays the picture file and
automatically places you in the EDIT function .
You can then begin work on the file .

Reading Files The amount of time DR Draw needs to read your
file will vary, depending on the number and
types of design elements in the file . For
example, circles take longer to read than bars .

Current Element When you RECALL a file, the current element i s
always the first design element that you added
when you began the file .

5-24
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RECALL

Retained

	

The following attributes of the recalled
Attributes

	

picture file are retained from the last time you
worked on the file :

•

	

the location of the window on the drawing
surface

•

	

the layout

•

	

the status of GRID and SNAP

Error Messages

	

You can receive one of three error messages when
you PICK the RECALL function .

CHART : not found, press DONE

You gave a filename (in this case, CHART) that
is not on the diskette . If you give a drive
identifier as part of the filename, DR Draw
includes it in the message .

Press the DONE key to return to the Main Menu .
To recall a picture file, PICK the RECALL
function again and give another filename .

Abandon active picture file? (Y/N)

You PICKed the RECALL function without saving
your active picture file . DR Draw displays
this error message instead of the prompt .

If you respond Y (Yes), DR Draw abandons the
active picture file and prompts

Picture filename?

Section 4 discusses abandoning an active
picture file .

If you respond N (No), DR Draw returns you to
the Main Menu . To continue working on your
active picture file, PICK the EDIT function .
T o save the active file, PICK the SAVE
function .

CHART : incorrect format, press DONE
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RECALL

DR Draw displays this message in several
situations .

1 . You gave a PIX f iletype to a file that was
not created with DR Draw . DR Draw cannot
read the file . You can avoid this situation
by not combining picture files and other
files on the same diskette .

2 .

3 .

Your computer lost power when you were
saving a file . You find the file in your
directory the next time you start your
computer, but the file is missing
information that DR Draw needs in order to
read it successfully .

There is a problem with the diskette from
which you are trying to recall the file .
The diskette might need to be reformatted,
in which case all files on the diskette are
lost . However, you might be able to save
some of the files if you copy the diskette
before you reformat it .
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REDRAW

REDRAW

Purpose

	

The REDRAW function lets you

•

	

see your picture file in its current state
•

	

redraw the grid

Several of the EDIT functions, especially
DELETE and MOVE, can alter the appearance of
design elements or the grid .

For example, i f you place a polygon on top of a
circle, the polygon masks some or all of the
circle . If you delete the polygon, you cannot
see the masked part of the circle until you use
the REDRAW function .

Similarly, when the grid is on, moving an
element deletes the grid points under the
element's original position . Use the REDRAW
function to restore the grid .

When the REDRAW is complete, DR Draw returns
you to the Edit menu .



• retain the file's original name
•

	

rename the file

When you rename a file, the original file
remains on the diskette under the old name .

The descriptions of the CREATE and RECALL
functions use the analogy of a storage cabinet
where you keep your pictures . With the SAVE
function the analogy takes one of two forms,
depending on whether you created or recalled
the file .

Created Files When you create a file, you write the file's
name on an empty folder in your storage
cabinet . When you save a file under its
original name, you go over to the cabinet and
slip the picture into its folder . When you
rename the file, you change the name on the
folder before putting the picture inside .

Recalled Files When you recall a file, the original stays in
the folder in the storage cabinet . You work on
a copy .

Saving the file under its original name is like
going to the folder, destroying the original,
and replacing it with the new version .

When you rename the file, you go to the cabinet
and open up a new folder . The new version of
the file, bearing the new name, goes into the
new folder . The old version remains in the
cabinet under its original name .

Prompt

	

DR Draw displays the following prompt when you
PICK the SAVE function .

CHART? (or type new name)

Press the RETURN key to save the file under its
original name (in this example, CHART) . To
save the file under a new name, type the new
name before you press the RETURN key .

5-28
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SAVE

Purpose The SAVE function stores your active picture
file on a diskette . When you save a file, you
can
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SAVE

D R Draw displays one of these messages while
the file is being saved :

CHART : saving file

or

NEWNAME : saving file

Error Message

	

You can receive one of two error messages when
you PICK the SAVE function .

No active picture file, press DONE

You PICKed the SAVE function without having an
active picture file . Press the DONE key to
return to the Main Menu .

CHART : already exists, press DONE

To rename the file, you gave the name of a file
that is already on the diskette with a PIX
filetype . Press the DONE key to return to the
Main Menu .
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SCALE

SCALE

Purpose

	

The SCALE function lets you

•

	

enlarge or reduce stroke font text

•

	

enlarge, reduce, or change the proportions of
elements other than text

The SCALE function affects only the current
element .

PICK a New Extent You tell DR Draw how much to enlarge or reduce
the current element by PICKing the opposite
• orners of a rectangle that becomes the
•

	

lement's new extent .

Changing

	

For all design elements but text, you can
Proportions

	

change the element's proportions . For example,
you can use SCALE to change a circle to an
oval .

Moving Elements

	

The new extent that you

	

define can be
with SCALE

	

anywhere inside the window frame . You can, for
example, use SCALE to change a large circle in
the upper left corner of the drawing surface to
a small oval in the lower right corner .

SCALE : Text When you PICK the SCALE function to enlarge or
reduce the size of stroke font characters, DR
Draw displays three prompts in the sequence
below .

Prompts

	

PICK corner of new extent

Move the cursor to a point on the drawing
surface and PICK the first corner of the new
text extent . Unless you want to move the
string at the same time, you can use the same
point that you PICKed when you first entered
the string . When you PICK the point, DR Draw
extends vertical and horizontal lines to show
you two sides of the extent .

PICK opposite corner of new extent
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SCALE

Chief Executive Officer

PICK this point ;

DR Draw displays these lines

Chief Executive Officer

Move the cursor diagonally and PICK the

opposite corner of the new extent .

DR Draw extends a second set of vertical and

horizontal lines . For the reasons given below,

the intersection of the two lines might not be

the point you PICKed . Figure 5-10 illustrates

how the two points can differ .

4",--- DR Draw displays these lines

*

	

	 ~ D R Draw scales the string

Chief--- Executive___ Off _cer_* to this size

Figure 5-10 . Scaling Text

PICK this point

You can change the size of stroke font

characters but not their proportions . The two

points you PICK define a rectangle into which
DR Draw tries to fit the text string . The

lines that DR Draw displays indicate the best

fit of the string in the rectangle you defined .

5-31
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The lines that DR Draw displays are an accurate
indicator of the string's new size and shape .

PICK moves second corner, DONE finishes

If you are not satisfied with the size of the
extent, you can move the cursor and PICK a new
second point .

When you press the DONE key, DR Draw redraws
the text string in the new size and returns you
to the Edit Menu .

Error Message

	

You can receive the following error message when
you PICK the SCALE function .

Cannot SCALE machine font, press DONE

You tried to SCALE machine font characters .
The size of machine font characters cannot be
changed .

SCALE : Non-Text

	

The SCALE function lets you enlarge, reduce,
Elements

	

or change the proportions of POLYGON, CIRCLE,
ARC, LINES, or MARKERS design elements .

When you PICK the SCALE function with a non-
text current element, DR Draw displays a
submenu that gives you the option of retaining
or changing the element's proportions .

Uniform Non-Uniform

Figure 5-11 . Scale Submenu

UNIFORM retains the element's proportions . The
resulting element is larger or smaller than the
original, but it is the same shape .

NON-UNIFORM changes the element's proportions .
In addition to being larger or smaller than the
original, the resulting element is a different
shape .
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Figure 5-12 . SCALE Example

Markers are a special case . Because they are
machine font characters, you cannot scale
single markers . You can, however, scale
markers that you entered in a group . DR Draw
changes the distance between the markers
without changing the size of the markers . For
more details on markers, refer to Section 6 .
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Figure 5-11 illustrates how
text, markers, and a polygon .

SCALE works on

original

	

uniform non-uniform
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Prompts

	

After you PICK the SCALE function, DR Draw
displays three prompts in the sequence below .

PICK corner of new extent

Move the cursor to a point on the drawing
surface and PICK one corner of the new extent .
When you PICK the point, DR Draw extends
vertical and horizontal lines to show you two
sides of the extent .

PICK opposite corner of new extent

Move the cursor diagonally and PICK the
opposite corner of the new extent . DR Draw
again extends vertical and horizontal lines .
The rectangle formed by the intersection of the
four lines allows you to preview the new
extent .

PICK moves second corner, DONE finishes

If you are not satisfied with the size and/or
shape of the extent, you can move the cursor
and PICK a new second point .

When you press the DONE key, DR Draw redraws
the element to fit the new extent, then returns
you to the Edit Menu .

Error Message

	

You can receive the following error message when
you PICK the SCALE function .

Cannot SCALE this element, press DONE

D R Draw displays this error message in two
situations .

1 . You tried to scale a single marker . Because
a marker is a machine character, you cannot
change its size .

2 . You tried to scale an element that is so
small that DR Draw thinks it is a single
point . This unusual situation can arise
when you zoom out many times .
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SELECT

SELECT

Purpose The SELECT function lets you choose a new
current element from among the elements on the
drawing surface .

You select the new current element by PICKing
opposite corners of a rectangle enclosing the
• lement . Make the rectangle larger than the
• xpected extent . This requirement is
especially important when you select a text
string, because a text extent is slightly
larger than the characters it surrounds .
Figure 5-10 shows text in an extent .

As you see in Figure 5-13, DR Draw looks inside
the rectangle for an element to select . If the
• ectangle does not surround the element
sufficiently, DR Draw retains the present
current element and returns you to the Edit
Menu .

Prompts When you PICK the SELECT function from the Edit
Menu, DR Draw displays three prompts in the
sequence below .

PICK corner of rectangle

Move the cursor to one corner of the rectangle
and PICK that point . DR Draw extends vertical
and horizontal lines from the point .

PICK opposite corner of rectangle

Move the cursor to the rectangle's opposite
corner and press the PICK key again . DR Draw
projects vertical and horizontal lines from
this point too . The rectangle formed by the
intersection of the two pairs of lines should
surround the element you have chosen .

PICK moves second corner, DONE finishes

I f you are not satisfied with the rectangle,
you can move the cursor and PICK a different
second corner . When you press the DONE key, DR
Draw selects the new current element, draws an
extent around it, and returns you to the Edit
Menu .
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Figure 5-13 . SELECT Example

PICK these points ;

DR Draw displays this

preview rectangle

DR Draw SELECTS

the element inside

the rectangle

SELECT

Two or more design elements can share the same
extent ; for example, the circle and square in
Figure 5-4 . When you select elements in a
shared extent, the first-drawn of them is the
current element .
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STYLE

Purpose

	

The STYLE function changes the style attribute
of your current element .

	

Depending on the
current element, the style attribute is one of
the following :

•

	

type style
•

	

line style
•

	

fill pattern
•

	

marker style

When you PICK the STYLE function from the
Change Submenu, the Style Submenu replaces the
Change Submenu on the second line . If your
menu cursor is a reverse video bar, it remains
on the second menu line . If your menu cursor
is a cross hair, it appears on the drawing
surface . Section 4 describes menu cursors .

The contents of the Style Submenu depend on
whether the current element is text, a filled
element, an open element or line, or markers .

For more information on styles, refer to
Section 4 and to the descriptions of the design
elements in Section 6 .

Text

	

When the current element is text, DR Draw
displays the following Style Submenu :

Machine SimplexIComplex Italic

Figure 5-14 . Style Submenu for TEXT

The description of the TEXT design element in
Section 6 discusses the three default fonts and
the font library . Appendix A explains how you
can replace the default fonts with fonts from
the library .

The initial style for text is the machine font .
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Filled Elements When the current element is a filled arc, filled
circle, polygon, or bar, DR Draw displays a
submenu of fill patterns . The type of computer
you have determines the number of fill patterns
in the submenu .

Some printers or plotters might not be able to
reproduce all the fill patterns you see on your
computer . You can create a sample file by
drawing a bar or polygon for each fill pattern
your computer displays . Printing the file lets
you see how the fill patterns appear in output .

The initial style for filled elements is a
solid fill .

Open Elements and When the current element is an open arc, open
Lines circle, or a line, DR Draw displays a submenu of

line styles . The type of computer you have
determines the number of line styles in the
submenu .

Some printers or plotters might not be able to
reproduce all the line styles you see on your
computer . You can create a sample file by
•rawing a line for each style your computer
• isplays . Printing the file lets you see how
the line styles appear in output .

The initial style for lines is a solid line .

Markers

	

When the current element is a marker, DR Draw
•

	

isplays a submenu of five marker styles .

Refer to the description of the MARKERS design
element in Section 6 for more details on
MARKERS .

The initial style for MARKERS is an asterisk .
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UNDELETE

Purpose The UNDELETE function redraws the element that
was most recently deleted from the picture
file .

DR Draw redraws the element, makes it the
• urrent element, and returns you to the Edit
Menu .

UNDELETE works only on the last deleted
element ; previously deleted elements are lost .

Design Element

	

Because it redraws

	

design elements, the
Order

	

UNDELETE function can change the order of design
•

	

lements in a picture file . The undeleted
•

	

lement becomes the newest addition to the
picture file .

For example, if you select the arc (number 3)
in Figure 5-4, delete, then undelete it, the
redrawn arc is element number 6 .

For more on design element order, refer to the
description of the DELETE function .

Error Message

	

You can receive the following error message when
you PICK the UNDELETE function .

No deleted element, press DONE

You PIC Ked UNDELETE without having deleted
anything . Press the DONE key to return to the
Edit Menu .
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VIEW

VIEW

Purpose The VIEW function permits you to move the window
over the drawing surface or to change design
element order .

When you PICK the VIEW function from the Change
Submenu, the View Submenu replaces the Change
S u bme n u on the second line . I f your menu
cursor is a reverse video bar, it remains on
the second menu line . If your menu cursor is a
cross hair, it appears on the drawing surface .
Section 4 describes menu cursors .

The View Submenu lists five functions .

Zoom In

Figure 5-15 . View Submenu

ZOOM IN ZOOM IN gives you a close-up view of a portion
of what is currently in the window . To
identify what you want to see in close-up, you
PICK the opposite corners of a rectangle that
DR Draw fits to the window frame .

Prompts

	

When you PICK the ZOOM IN function, DR Draw
displays three prompts in the sequence below .

PICK corner of window

PICK the first corner of the rectangle . When
you press the PICK key, horizontal and vertical
lines extend from the cursor's position to the
window frame .

PICK opposite corner of window

Move the cursor diagonally to the opposite
corner of the rectangle and press the PICK key
again . A second set of horizontal and vertical
lines extends from the cursor's position to the
window frame . The rectangle formed by these
lines gives you a preview of the area that will
be enclosed by the window frame .

PICK moves second corner, DONE finishes

ZoomFullJZoomOUL]	Pan

5-40

Put to Back
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VIEW

I f you are not satisfied with the location of
the second point, you can continue to move the
cursor and press the PICK key . When you press
the DONE key, DR Draw displays the close-up by
fitting the rectangle you defined to the window
frame . DR Draw then returns you to the Edit
Menu .

The Grid

	

ZOOM IN decreases the density of the grid ;
individual points are farther apart .

ZOOM FULL

	

ZOOM FULL fits all the elements in your picture
file to the current layout .

If part of the picture file is outside the
layout, ZOOM FULL proportionally reduces the
elements and the space between them .

If the whole picture file is within the layout,
ZOOM FULL proportionally enlarges the elements
and the space between them .

Figure 5-16 illustrates three ways ZOOM FULL
fits and centers the picture file in the
layout . The broken-line outlines represent
picture files, which can contain any
combination of design elements . The solid-line
outlines are the layouts .
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3 . vertical centering

VIEW

,
,

,,
,,,

,,

,

,
,,



DR Draw User's Guide

	

VIEW

I n the first example, the picture file is
larger than the layout but has the same
proportions . ZOOM FULL reduces the picture
file and fits it to the layout on all sides .

In the second example, the proportions of the
picture file and layout are different . ZOOM
FULL reduces the picture file to fit the layout
and centers the picture file horizontally .

In the third example, the picture file is
entirely within the layout but again has
different proportions . ZOOM FULL enlarges the
picture file and centers it vertically .

ZOOM OUT ZOOM OUT reduces both the elements in the
picture file and the space between them to two
thirds their present size . The effect of ZOOM
OUT is similar to what happens when you stand
before a picture, then step back from it .

ZOOM OUT also reduces the distance between grid
points by the same amount . The grid becomes
more dense .

PAN PAN allows you to move the picture file
horizontally, vertically, or diagonally in the
window . The effect of PAN is similar to what
happens if you move a rectangular frame over a
large sheet of paper .

When you PICK the PAN function, DR Draw
displays intersecting lines that indicate the
center of the window .

Prompt

	

DR Draw displays the following prompt when you
PICK the PAN function .

PICK new center of window

Move the cursor to a point on the drawing
surface that you want as the new center of the
window . When you press the PICK key, DR Draw
redraws the picture file with the new point in
the center of the window .



share the same extent, you can use PUT TO BACK
to take the element on top and put it
underneath .

Figure 5-17 illustrates one use of PUT TO BACK .
The following numbered sentences describe the
three parts of the figure .

1 . Draw a bar , then a circle that partly
overlaps the bar .

2 . Select the bar as the current element and
change its fill pattern . The bar now
overlaps the circle .

1

3 . Use PUT TO BACK to assign the bar to the
first-drawn position . The circle again
overlaps the bar .

2 .

Figure 5-17 . PUT TO BACK Example

The element that you PUT TO BACK remains the
current element .

End of Section 5

3
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PUT TO BACK PUT TO BACK changes design element order by
making the current element the first element in
the picture file . When elements overlap or



Section 6
Design Elements

INTRODUCTION

	

This section describes the seven DR Draw design
elements in alphabetical order .

•

	

ARC
•

	

BAR
•

	

CIRCLE
•

	

LINES
•

	

MARKERS
•

	

POLYGON
•

	

TEXT

Add Submenu When you PICK the ADD function from the Edit
Menu, the Add Submenu appears on the second
menu line . The Add Submenu lists DR Draw's
seven design elements in the order shown below .
If your menu cursor is a reverse video bar, it
appears on the second menu line . If your menu
cursor is a cross hair, it appears on the
drawing surface . Section 4 describes menu
cursors .

I-,***.--"-

Figure 6-l . Edit Menu and Add Submenu

Aad Chance Select Move I Copy T Undelete Delete
Text Polygon I Circle Arc Lines Markers Bar
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Introduction

Prompts After you PICK a design element, DR Draw
displays prompts that instruct you how to draw
the element .

Some design elements have two or more prompts,
in which case you respond to one prompt before
DR Draw displays the next . The design element
descriptions list the prompts in the order you
receive them and follow each prompt with a
description of how you respond .
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ARC

ARC

Definition An arc can either be part of the circumference
of a circle (a curved line) or a filled pie
section .

Prompts

	

When you PICK the ARC design element, DR Draw
•

	

isplays three prompts in the sequence below .

PICK arc center

PICK a point on the drawing surface to be the
center of the arc .

PICK arc radius/beginning of arc

•

	

ICK a second point on the drawing surface .
This point serves two purposes :

1 . It defines the radius of the arc .

2 . It defines the beginning of the arc . If you
think of an arc as resembling the sweep of a
windshield wiper, the beginning of the arc
is like the wiper's position at the start of
its sweep .

PICK end of arc

•ICK a third point to define the end of the
arc . To use the windshield wiper analogy
again, the end of the arc is like the wiper's
position at the end of its sweep .

Because the arc's radius is established when
you PICK the second point, the third point can
be anywhere on a line rom the center, as
Figure 6-2 illustrates .
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ARC

end of arc
(third point)
PICK anywhere
on this line

arc center (first point)

Figure 6-2 . Drawing an Arc

arc radius/
beginning of arc
(second point)
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OPEN Arcs

FILLED Arcs

After you PICK the last point, DR Draw shows
you a submenu :

Changing Style For more information on changing style, see the
subsection on STYLE in Section 4 and the
description of the STYLE function in Section 5 .

Drawing Arcs The order in which you PICK the second and third
points determines the appearance of the arc you
draw . In both parts of Figure 6-4, the three
points are the same, but the order of the
second and third points is reversed . The arrow
shows how DR Draw always starts with the second
point and draws counterclockwise . If you PICK
the sequence on the left, you get a pie slice .
If you PICK the sequence on the right, you get
the pie with the slice missing .

Figure 6-3 . Arc Submenu

An OPEN arc is a curved line that is part of the
circumference of a circle . The initial line
style is a solid line . You can change style to
one of several other line styles .

A FILLED arc is a pie section . The initial
style for f ill is solid . You can change the
fill to one of several other patterns,
including a hollow fill .
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ARC

3

	

2

2

J

Figure 6-4 . Drawing ARC's

1

In addition, because the distance between
points 1 and 2 is shorter on the right, the pie
has a smaller radius than the slice .
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BAR

Definition

	

A bar is a filled rectangle .

Prompts

	

When you PICK the BAR design element, DR Draw
displays two prompts in the sequence below .

PICK corner of bar

PICK a point on the drawing surface .

PICK opposite corner of bar

Move the cursor diagonally to the opposite
corner of the rectangle and press the PICK key
again .

Fill

Changing Style

- - - - - - - - - - - - - - -. .... . ....... ..a ..a....ar... .∎∎~	∎	a	~aa	∎∎.aa	aa.∎∎	r....a .∎∎	∎	r	∎∎	~	∎•	∎∎.a..a.aaa	∎	r.rr..∎	∎∎	•	•∎ ..a. . .r	∎∎ .aaa	∎∎	•∎ .a.a .a....a. ..

As soon as you PICK the second corner point, DR
Draw draws the bar and returns you to the Edit
Menu .

The initial style for bars is a solid f ill . You
can change the fill to one of several other
patterns, including a hollow fill .

For more information on changing style, see the
subsection on STYLE in Section 4 and the
description of the STYLE function in Section 5 .

Text in Bars You can insert text in a bar with hollow fill,
but you must add the text after you draw the
bar . Otherwise, the hollow fill pattern masks
the text .

	

You can avoid this situation by
drawing the box with the LINES design element
instead .
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CIRCLE

Definition

	

A circle can be either a circular outline or a
filled disk .

Prompts

	

When you PICK the CIRCLE design element, DR Draw
displays two prompts in the sequence below .

PICK circle center

PICK a point on the drawing surface to be the
center of the circle .

PICK circle radius

Move the cursor any direction and PICK another
point to establish the circle's radius .

Submenu

	

After you PICK the second point, DR Draw shows
you a submenu :

Open

	

r , ed

Figure 6-5 . Circle Submenu

OPEN Circle A n OPEN circle is a circular outline . The
initial line style is a solid line . You can
change its style to one of several other line
styles .

FILLED Circle The initial fill style is a solid fill . You can
change the fill to one of several other
patterns, including a hollow fill .

CIRCLE
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CIRCLE

Changing Style For more information on changing style, see the
subsection on STYLE in Section 4 and the
description of the STYLE function in Section 5 .

Circles on

	

Because of the resolution and aspect ratio of
Your Screen some display monitors, circles can appear

slightly oval on the drawing surface and in
screen output . However, this effect is not
present in printer or plotter output .



DR Draw User's Guide

	

LINES

LINES

Definition The LINES design element can be a single
straight line or a series of connected line
segments .

11

Prompt

	

When you PICK the LINES design element, DR Draw
displays a single prompt .

PICK points, press DONE when finished

PICK a starting point and move the cursor to
another point on the drawing surface .

If you want a single straight line, press the
DONE key to return to the Edit Menu .

I f you want a series of connected line
segments, continue moving the cursor and
pressing the PICK key . Af ter you PICK the
endpoint of the last line segment, press the
DONE key to return to the Edit Menu .

Rubberband Line If your computer supports this feature, you can
preview a line segment before you PICK its
endpoint . DR Draw connects the starting point
and the cursor with a line that stretches like
a rubberband as you move the cursor over the
drawing surface . When you are satisfied with
the position of the line, PICK the endpoint .

Style The initial style for lines is a solid line .
You can change style to one of several other
line styles .

Changing Style For more information on changing style, see the
subsection on STYLE in Section 4 and the
description of the STYLE function in Section 5 .
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Text in Boxes You can place text inside boxes drawn with
lines, as in Figure 6-6 . Unlike bars,
polygons, filled circles, and filled arcs,
shapes drawn with lines do not have a fill
pattern that masks your text .

Drawing Over Lines You can draw over lines . For example, to draw
the lines that connect the boxes in Figure 6-6,
follow this sequence :

•

	

PICK a starting point on the lefthand box .

•

	

Move the cursor to the r ighthand box and PICK
the endpoint of the first line segment .

•

	

Move the cursor back over the line to its
midpoint and PICK again .

•

	

Move the cursor down to the lower box and
PICK the final point .

•

	

Press the DONE key .

LHFT

C N ,iT N ,l~
Figure 6-6 . LINES Example

FIGHT
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MARKERS

Definition A marker is a character that you can use to mark
points, highlight, or accent design elements .
Five marker styles are available .

Initial Style

Changing Style

0

	

X

Prompt

	

When you PICK the MARKERS design element, DR
Draw displays a single prompt .

PICK points, press DONE when finished

To draw only one marker, move the cursor to the
desired position on the drawing surface and
press the PICK key . Then press the DONE key to
return to the Edit Menu .

To draw several markers, move the cursor and
PICK each marker position before you press the
DONE key to return to the Edit Menu .

Groups of Markers When you add several markers at once, DR Draw
treats them as a single element . Functions
like MOVE, COPY, and DELETE affect the entire
group . In addition, you cannot select
individual markers from a group that was
entered together .

The initial style for MARKERS is an asterisk .
You can change style to one of several other
marker styles .

For more information on changing style, see the
subsection on STYLE in Section 4 and the
description of the STYLE function in Section 5 .

Printing Markers Markers are machine characters, not stroke font
characters . The appearance of markers on
printed output depends on your printer or
plotter . For ready reference you can create
and print a file with samples of each marker
style .

Marker Size Because markers are machine characters, you
cannot scale them individually . You can,
however, scale the extent of a group of
markers, as Figure 5-12 illustrates .

6-12
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POLYGON

Definition A polygon is a closed figure made up of straight
line segments . Closed means that the beginning
point of the first line segment is the same as
the endpoint of the final line segment . The
figures below are all polygons :

POLYGON

Prompt

	

When you PICK the POLYGON design element, DR
Draw displays a single prompt .

PICK points, press DONE when finished

PICK a point on the drawing surface . Complete
the first line segment by moving the cursor and
PICKing another point . Then move the cursor
and PICK points to complete each subsequent
line segment . Complete the polygon by joining
the first and last points . Press the DONE key
to return to the Edit Menu .

Rubberband Line If your computer supports this feature, you can
preview each line segment before you PICK its
endpoint . DR Draw connects the starting point
and the cursor with a line that stretches like
a rubberband as you move the cursor over the
drawing surface . When you are satisfied with
the position of the line, PICK the endpoint .

Fill A polygon is a filled element . The initial
style i s a solid fill . You can change the fill
to one of several other patterns, including a
hollow fill . The fill pattern appears when you
press the DONE key .

Changing Style For more information on changing style, see the
subsection on STYLE in Section 4 and the
description of the STYLE function in Section 5 .
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ZOOM IN and PAN When you use ZOOM IN or PAN so that part of the
polygon is outside the window frame, DR Draw
eliminates the fill pattern . If you then use
PAN, ZOOM FULL, or ZOOM OUT to bring the entire
element back inside the window frame, DR Draw
restores the fill pattern .

For more information on these DR Draw
functions, refer to Section 5 .
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TEXT

Text Strings A text string is a word, phrase, sentence, or
any other group of characters and spaces you
enter from the keyboard .

You can use a variety of font styles from the
DR Draw font library, which is described later
in this section and in detail in Appendix A .
Available characters include alphabetic and
numeric characters, punctuation marks (except
for the exclamation point) , and the Greek
alphabet .

Prompt

	

When you PICK the TEXT design element, DR Draw
displays a single prompt .

PICK start, type, RETURN ; DONE finishes

Move the cursor to the place where you want
your text string to begin and press the PICK
key . The text cursor replaces the graphics
cursor on the drawing surface to indicate where
typed characters appear .

Type the text string and press the RETURN key .

The text cursor disappears, and the graphics
cursor reappears one text line below the
previous line . You now have the following
options :

•

	

PICK the cursor's present location as a point
for entering text .

• Move the cursor to a point on the same line
as the previous string and PICK the start of
a new string .

• Move the cursor to another position on the
drawing surface and PICK the start of a new
string .

•

	

Press the DONE key to complete your text
input and return to the Edit Menu .
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RETURN Key and

	

The text prompt makes a distinction between
DONE Key the RETURN key and the DONE key . They are the

same key on your keyboard, but they are
functionally different .

When you press the RETURN/DONE key at the end
of a text string, it functions as a RETURN key .
The graphics cursor moves down a line, and you
can enter more text .

When you press the RETURN/DONE key again,
without PICKing a new point for entering text,
it functions as a DONE key . DR Draw terminates
your text input and returns you to the Edit
Menu .

Correcting Typing

	

If you notice a typing error in your text
Errors

	

string before you press the RETURN key, you can
correct it by using the BACKSPACE key . Because
the BACKSPACE key deletes characters, you have
to retype the string from the point of the
error .

If you see the error after you press the RETURN
key, use DELETE to erase the entire string and
enter it again .

Current Element When you enter multiple strings and press the
DONE key to end your text input, the last
string you entered becomes the current element .

Text String Length A single text string can be up to eighty
characters long .

However, you can enter text strings that are
longer than the available line length on your
display . For example, if you

•

	

have an 80-column display

•

	

start a text string anywhere after the first
column

•

	

enter an 80-character text string
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This string is too loll_
characters appear here		L	 cursor
as you type

the string extends past the right edge of the
window frame . DR Draw handles this situation
in the following manner :

•

	

The text cursor stops when it reaches the
window frame .

•

	

From then on, each character or space that
you type appears in the position immediately
preceding the cursor, as Figure 6-7
illustrates . By displaying the characters in
this way, DR Draw permits you to check the
accuracy of your typing .

•

	

When you finish the string and press the
RETURN key, the entire string becomes part of
your active picture file . However, as Figure
6-7 also shows, you can only see the part of
the string that is inside the window frame .
You can use PAN, ZOOM OUT, or ZOOM FULL to
bring the whole string back onto the drawing
surface and make it fully visible .

This string is too I n
what you see after you
press the RETURN key

what is on your diskette

-window frame

___`
i

This string is too long for your display .

Figure 6-7 . Text Too Long for the Display
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Machine Fonts Machine font is the type style generated by your
computer . The size and shape of machine font
characters depend on the computer you are
using . You cannot change the size of machine
font text .

Printers and plotters also have their own
machine fonts distinct from the computer's .
For that reason, you can expect printed output
of machine font text to be different from what
you see on your display monitor .

Stroke Fonts The other fonts are called stroke fonts, which
means that they are part of the software
included with the DR Draw package . Using the
SCALE function described in Section 5, you can
change the size of stroke font text .

Screen and printed output of stroke font text
look the same .

Text Style Regardless of the current style, text appears in
machine font as you type . If your current
style for text is one of the stroke fonts, DR
Draw displays a bouncing extent to show how
much space the string will occupy . When you
press the DONE key, DR Draw rewrites the string
in the current font style .

Font Library DR Draw offers you a library of twelve stroke
fonts . Table 6-1 lists the menu names and the
defaults for the stroke fonts .

Table 6-1 . Default Stroke Fonts

Menu Name Default Font

Simplex Simplex Roman
Complex Complex Roman
Italic

	

Triplex Italic

Appendix A contains samples of all the stroke
fonts and tells you how you can replace the
default fonts with others from the library .
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TEXT

Changing Style For more information on changing style, see the
subsection on STYLE in Section 4 and the
description of the STYLE function in Section 5 .

Zooming on Text If you use ZOOM IN, ZOOM OUT, or ZOOM FULL on a
picture file that combines machine font text
and another element (for example, a polygon),
the polygon changes in size, but the text does
not . Zooming also changes their relative
positions and can cause the polygon to overlap
the text .

When you use one of the ZOOM functions on a
picture file that combines stroke font text and
other elements, everything enlarges or reduces
equally . The relative positions remain the
same .

Section 5 describes the ZOOM functions .

Recommended

	

You

	

might find it desirable to make a
Procedure practice of immediately changing machine font

text to one of the stroke fonts . If you do,
your printed output matches what you see on
your display screen, and you can use the ZOOM
functions without affecting the relationship of
the design elements in your picture file .

End of Section 6





Appendix A
Font Library

INTRODUCTION DR Draw's font library allows you to select from
twelve stroke fonts, including serif and sans-
serif Roman fonts, as well as italic, script,
Greek, and gothic fonts .

design element :

•

	

If you PICK the Simplex submenu selection, DR
Draw uses the font that is named FONTA .BIN .

•

	

If you PICK the Complex submenu selection, DR
Draw uses the font that is named FONTB .BIN .

•

	

If you PICK the Italic submenu selection, DR
Draw uses the font that is named FONTC .BIN .

When you receive DR Draw, the three font files
on your program diskette contain DR Draw's
three default fonts : Simplex Roman, Complex
Roman, and Triplex Italic . You can retain the
defaults, or you can replace one or more of the
default fonts with selections from the font
library .

COPY YOUR DISKETTE The distribution diskettes that you receive with
DR Draw include the font library diskette .
Make a working copy of the library diskette
before you use the font library .

	

Store the
original library diskette in a safe place in
case you need to make copies in the future .

The Supplement tells you how to copy a
diskette .

PROGRAM DISKETTE Your DR Draw work diskette contains three
AND DEFAULT FONTS font files, named FONTA .BIN, FONTB .BIN, and

FONTC .BIN . These files correspond in the
following manner to the three stroke font
selections in the Style Submenu for the TEXT
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Program Diskette and Default Fonts

Table A-1 lists the font filenames on the
program diskette, their corresponding submenu
selections, and the default fonts .

Table A-l . Default Stroke Fonts

For information on changing fonts, refer to
"Changing Fonts" in this appendix .

FONT LIBRARY FILES The font library diskette contains twelve font
files, including files for the three default
fonts . Table A-2 lists the fonts and their
corresponding filenames on the font library
diskette :

Table A-2 . Font Library Files

Font Name Filename

Simplex Roman
Complex Roman
Duplex Roman
Indexical Roman

SIMPROM
COMROM
DUPROM
INDROM

Triplex Italic
Indexical Italic
Gothic Italic

TRIITA
INDITA
GOTITA

Simplex Script
Complex Script

SIMSCR
COMSCR

Simplex Greek
Complex Greek
Indexical Greek

SIMGRE
COMGRE
INDGRE

Filename
Submenu
Selection Default Font

FONTA .BIN

	

Simplex

	

Simplex Roman
FONTB .BIN

	

Complex

	

Complex Roman
FONTC .BIN

	

Italic

	

Triplex Italic
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Font Library Files

1

J

0)

Figure A-1 shows the word Draw in the four
Roman fonts . Note that the size of the
characters and the letter spacing differ from
one font to the next .

Figure A-l . Illustration of the Four Roman Fonts

"Font Character Sets" in this appendix shows
the full character set for each font .



DR Draw User's Guide

	

Changing Fonts

CHANGING FONTS

	

To replace one or more of the default fonts with
a font from the library, you must use operating
system commands .

If you are using DR Draw, return to the Main
Menu, and PICK the EXIT function .

When you see the operating system prompt, you
can use your operating system's file copying
command to copy font files from the library
diskette to your work diskette . In most cases
you will place the work diskette in the A drive
and the library diskette in the B drive . Then
copy the font file you want from the library
diskette, renaming it to FONTA .BIN, FONTB .BIN,
or FONTC .BIN .

When you copy the font files, remember to
include the f iletype for the file on the
library diskette . Table A-2 does not list
filetypes because they can vary .

For detailed information on file copying, refer
to your operating system manual .

STYLE SUBMENU

	

Replacing the default fonts with fonts from
for TEXT

	

the library does not change the Style Submenu
for the TEXT design element . The submenu still
lists the stroke font styles as Simplex,
Complex, and Italic .

The submenu selection Simplex always uses the
font file named FONTA .BIN . Although the
default font for FONTA .BIN is Simplex Roman,
you can copy any font to the work diskette and
rename it FONTA .BIN .

The submenu selection Complex always uses the
font file named FONTB .BIN . Although the
default font for FONTB .BIN is Complex Roman,
you can copy any font to the work diskette and
rename it FONTB .BIN .

The submenu selection Italic always uses the
font file named FONTC .BIN . Although the
default font for FONTC .BIN is Triplex Italic,
you can copy any font to the work diskette and
rename it FONTC .BIN .
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Fonts and Picture Files

FONTS AND PICTURE When you recall a picture file, DR Draw
FILES

	

remembers the Style Submenu selection you PICKed
f or each text string and uses the font
currently in the corresponding font file on the
program diskette .

For example, suppose you enter three text
strings

•

	

"DR Draw", using the submenu selection
Simplex

•

	

"Graphic Application",, using the submenu
selection Complex

•

	

"User's Guide", using the submenu selection
Italic

If FONTA .BIN, FONTB .BIN, and FONTC .BIN contain
the default fonts, "DR Draw" appears in Simplex
Roman, "Graphic Application" appears in Complex
Roman, and "User's Guide" appears in Triplex
Italic .

After you save the picture file, you EXIT from
DR Draw . Using operating system commands, you
copy font files to the work diskette, renaming
them as follows :

• DUPROM to FONTA .BIN

• GOTITA to FONTB .BIN

•

	

SIMSCR to FONTC .BIN

When you recall the picture file, "DR Draw"
appears in Duplex Roman, "Graphic Application"
appears in Gothic Italic, and "User's Guide"
appears in Simplex Script .
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ERASING FONT FILES Do not under any c .ircumstances erase any of the
font files on your library diskette .

If you erase FONTB .BIN or FONTC .BIN from the
work diskette and then PICK either the Complex
or Italic submenu selection, DR Draw
automatically uses the font that is in
FONTA .BIN .

If you erase FONTA .BIN, you cannot start DR
Draw . You see the message :

No font files, press RETURN

Press the RETURN key to return to the operating
system prompt .

RESTORING FONTS TO If you change the font files in FONTA .BIN,
THE DEFAULTS

	

FONTB .BIN , and FONTC .BIN, the changes are
retained on your work diskette . If you want to
restore the defaults, you can return to the
operating system and copy SIMPROM from the font
library diskette to FONTA .BIN, COMROM to
FONTB .BIN, and TRIITA to FONTC .BIN .

FONT CHARACTER

	

Each of the following figures shows a full
SETS

	

character set for one of the available fonts .
These examples are scaled equally so you can
compare the size of the characters in the
fonts .

Six fonts have numerals and basic punctuation
marks . In these fonts, the keyboard pound sign
(#) translates to a degree symbol, and the left
and right angle brackets ( < and > ) translate
to opening and closing single quotes .

The remaining six fonts have no numerals or
punctuation .

Note also that the Greek alphabet has no
letters corresponding to the J and V keys .
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Figure A-8 . Simplex Script Character Set
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Appendix B
Additional DR Draw Messages

INTRODUCTION

	

This appendix describes six error messages that
you might see while starting or using DR Draw .

STARTING DR Draw

	

When starting DR Draw, you might see one of the
following messages .

No DRMSG80 .TXT, press RETURN

If your system has an 80-column display
monitor, you cannot start DR Draw without a
file called DRMSG80 .TXT on your work diskette .

If you see this message, the file DRMSG80 .TXT
is not on your work diskette .

	

Use your
operating system's file-copying command to copy
the file from the distribution diskette you
received with your DR Draw package to the work
diskette .

No DRMSG40 .TXT, press RETURN

If your system has an 40-column display
monitor, you cannot start DR Draw without a
file called DRMSG40 .TXT on your work diskette .

If you see this message, the file DRMSG40 .TXT
is not on your work diskette .

	

Use your
operating system's file-copying command to copy
the file from the distribution diskette you
received with your DR Draw package to the work
diskette .

No graphics input, press RETURN

You see this message if one of the following
conditions exists .

1 . The GSX program has not been installed . GSX
must be installed before you can start DR
Draw .

Some systems install GSX automatically when
you start DR Draw . In other systems you
must install GSX before you can start DR
Draw . Refer to the Supplement if you are
not sure which type of system you have .

B-1
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Starting DR Draw

2 . In the ASSIGN .SYS file on your work
diskette, the device driver for your display
monitor is either missing or incorrectly
specified .

The file specification of the monitor driver
in the ASSIGN .SYS file is preceded by a
logical device number from 01 to 10 .

Ensure that the ASSIGN .SYS file on the work
diskette meets the following requirements :

a . A logical device number from 01 to 10
precedes the filename of the monitor
device driver .

b . The filename preceded by the logical
device number from 01 to 10 corresponds
to a monitor device driver file on the
work diskette .

USING DR Draw

	

While using DR Draw, you might see one of the
following messages .

Cannot add more elements, press DONE

D R Draw has a limit of two hundred design
elements per picture file . You see this
message if you try to add more than two
hundred .

Not enough space on disk, press DONE

When you are in a picture file and try to use a
CREATE, RECALL, or SAVE function, this message
appears if insufficient space exists on the
diskette where the file will be stored . The
storage space required varies, depending on the
function you PICK .

• CREATE : The diskette must have at least 12
Kilobytes of available space, in addition to
the size of the file . The following two
examples illustrate how this restriction
applies to the CREATE function .
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Using DR Draw

1 . If the diskette has 10 Kilobytes of space
when you PICK the CREATE function, DR Draw
displays the message and does not permit
you to start the new file . You can either
delete unwanted files from the diskette or
use a diskette with sufficient space .

2 . If the diskette has 15 Kilobytes of
available space, you can start the new
file and add design elements that consume
3 Kilobytes of space before DR Draw
displays the message and does not allow
you to add more design elements .

Save the file, then delete unwanted files
from the diskette or copy the file to a
diskette with sufficient space .

• RECALL : When you recall a file, DR Draw
produces an active picture file by making a
copy of the file on your diskette .
Therefore, the minimum available space on the
• iskette must be 12 Kilobytes plus the size
of file you are recalling . However, if you
intend to add design elements to the file,
the diskette must have space for the new
design elements, in addition to the size of
the file and the 12 Kilobyte minimum .

If you cannot recall the file or if the
•

	

iskette has insufficient space for
additional design elements, return to the
operating system . You can delete unwanted
files from the diskette or copy the file to a
•

	

iskette with sufficient space .

• SAVE : When you SAVE a file to another drive,
the diskette on that drive must have
available space equal to 12 Kilobytes plus
the size of the file you are saving .

To see how much space remains on the diskette
and to check the size of a picture file, use
the appropriate operating system commands . For
more information on the commands, refer to your
operating system manual .
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Using DR Draw

Bad drive identifier, press DONE

DR Draw displays this error message when you
use a drive identifier for a drive that does
not exist on your system . This situation can
arise when you PICK the CREATE, RECALL, SAVE,
DIRECTORY, and OUTPUT functions .

For example, if your system has only two
drives, A and B, and you type

J :CHART

in response to the "Picture filename?" prompt,
DR Draw displays the message .

End of Appendix B
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INTRODUCTION

DR Draw -
Graphic Application

User's Guide
Release Note 01

Copyright L© 1984 by Digital Research Inc .
Digital Research and its logo are registered
trademarks of Digital Research Inc . DR DrawJ

is a trademark of Digital Research Inc .
Compiled January 1984 .

This release note contains changes and additions
to the DR Draw'" Graphic Application User's
Guide, First Edition . The affected functions
and design elements are listed alphabetically .

COLOR If your menu cursor is a reverse video bar, a
small rectangle marks your position on the
Color Submenu . I f you are working in color-,
the submenu selections appear in color .

DIRECTORY

	

The directory now stays on the screen longer,
and a message has been deleted .

When DR Draw displays the directory, the Main
Menu immediately appears on the screen . The
message "DIRECTORY complete, press DONE" is not
•

	

isplayed .

The directory remains on the screen until the
next time a DR Draw function uses the drawing
surface . For example, if you PICK the RECALL
function after displaying the directory, the
• irectory remains on the screen until DR Draw
•

	

isplays the recalled picture file .

GRID

	

The first selection in the Grid Submenu is now
GRID, not GRID ON or GRID OFF . I f you PICK the
GRID function with the grid visible, DR Draw
turns the grid off . If the grid is not visible
when you PICK the GRID function, DR Draw turns
the grid on .

5004-2009
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LAYOUT

	

Files saved in SCREEN layout appear horizontally
in printer or plotter output .

The appearance in printer or plotter output of
files saved in PORTRAIT or LANDSCAPE layout is
unchanged .

OUTPUT

	

The OUTPUT function has the following changes :

•

	

new output device listed on the submenu
•

	

message deleted
•

	

second filename prompt added

New Device CAMERA, the new selection on the Output Submenu,
lets you send your picture file to a camera
that makes prints or slides from computer
output . After the film has been exposed, DR
Draw returns you to the Main Menu .

In output from the CAMERA submenu selection,
picture files appear the same as they do in
output from the PRINTER and PLOTTER submenu
selections .

Message Deleted

	

The message "Preparing file for landscape
output" does not appear .

Filename Prompt When you PICK the OUTPUT function after saving
or abandoning a picture file . DR Draw now
retains the filename . For example, i f you PICK
an output device after saving or abandoning a
file named CHART, DR Draw displays the
following prompt :

CHART? (or type new name)

If you press the RETURN key, DR Draw outputs
the most recently saved version of CHART . If
no saved version of the file exists, DR Draw
displays this message :

CHART : not found, cress DONE

To output another picture file, type the
filename after the prompt, and press the RETURN
key .
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I f you have not previously saved or abandoned a
file when you PICK the OUTPUT function, DR Draw
prompts the following :

' 1 C tu'" e' L 1 L

	

_ iMe

Respond to this prompt as the manual describes .

RECALL When you PICK the RECALL function after saving
• r abandoning a picture file, DR Draw now
• etains the filename . For example, i f you PICK
the RECALL function after saving or abandoning
a file named CHART, DR Draw displays the
following prompt :

HART ? (or type ne,~' na pe )

If you press the RETURN key, DR Draw recalls
the most recently saved version of CHART . If
no saved version of the file exists, DR Draw
displays this message :

not found, press DONE

To recall another picture file, type the
filename after the prompt, and press the RETURN
key .

I f you have not previously saved or abandoned a
f i le when you PICK the RECALL f unct ion . DR Draw
prompts the following :

PLcture filename :'

Respond to this prompt as the manual describes .

SELECT In addition to defining a rectangle that
entirely encloses a design element, you can
select a current element by doing one of the
following :

•

	

enclose the corner of a design element's
extent

•

	

enclose any vertex of a design element except
TEXT

For polygons, lines, and markers, a vertex is
any point you PICK while drawing the element .
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For circles, virtually any point on the
circumference is a vertex . However, the center
of a circle is not a vertex .

The vertices of an arc include the beginning,
end, and almost any point on the curved line .
In addition, the center of a filled arc is a
vertex .

In selecting a current element, DR Draw follows
this sequence :

l . Select any entire design element inside the
rectangle . If none exists, go to the next
step .

2 . Select any element, the corner of whose
extent is inside the rectangle . If none
exists, go to the next step .

3 . Select any element whose vertex is inside
the rectangle . If none exists, retain the
present current element as current element .

If DR Draw finds more than one element at any
step in the sequence, the first-drawn element
becomes the current element .

If your menu cursor is a reverse video bar, a
small reverse video rectangle marks your
position on the submenu of fill patterns .

TEXT The maximum length for a single text string is
79 characters--not 80 characters, as stated in
the manual .

FONT LIBRARY

	

The submenu selection Simplex always produces
text in the Simplex Roman font .

The font file FONTA .BIN has been renamed
DRAW . BIN .

The font file in DRAW .BIN must be SIMPROM
(Simplex Roman) . Do not copy and rename
another font file to DRAW .BIN .
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NEW ERROR MESSAGES If you copy and rename a font file other than
SIMPROM to DRAW .BIN, you cannot start DR Draw .
Instead, you see this message :

rj A

Tne nnn in the message is the filetype, which
can vary .

To start DR Draw, first copy the file
SIMPROM .nnn from the font library diskette, and
rename it to DRAW .BIN on the work diskette .
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if you are using versions 1 .1 or 1 .0 of PC DOS
and you have problems duplicating your DR
Draw" distribution diskettes with DISKCOPY, use
the FORMAT and COPY programs instead of
DIISKCOPY to duplicate the diskettes .
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NOTICE TO USER

From time to time changes are made in the file names
and i n the files actually included with the
distribution disk .

	

This manual should not be
construed as a representation or warranty that such
files or facilities exist on the distribution disk
or a s part of the materials and programs
distributed .

	

Most distribution disks include a
"READ .ME" file, which explains variations from the
manual and which do constitute modification of the
manual and the items included therewith . Be sure to
read that file before using the software .





1 . DEFINITIONS - These definitions shall
govern :

A . 'DRI means DIGITAL RESEARCH
INC ., P .O . Box 579, Pacific Grove,
California 93950, the author and
owner of the copyright on this
SOFTWARE .

B . "CUSTOMER" means the individ-
ual purchaser and the company
CUSTOMER works for, if the com-
pany paid for this SOFTWARE .

C . ''COMPUTER'is the single micro-
computer on which CUSTOMER
uses this program . Multiple CPU
systems may require supplemen-
tary licenses .

D ''SOFTWARE'is the set of com-
puter programs in this package,
regardless of the form in which
CUSTOMER may subsequently
use it, and regardless of any modi-
fication which CUSTOMER may
make to it .
''LICENSE" means this Agreement
and the rights and obligations
which it creates under the United
States Copyright Law and Califor-
nia laws .

F 'RUNTIME LIBRARY" is the set of
copyrighted DRI language sub-
routines, provided with each lan-
guage compiler, a portion of which
must be linked to and become
part of a Customer program for
that program to run on the COM
PUTER .

2. LICENSE
DRI grants CUSTOMER the right to use this
serialized copy of the SOFTWARE on a sin-
gle COMPUTER at a single location so long
as CUSTOMER complies with the terms of
the LICENSE, and either destroys or returns
the SOFTWARE when CUSTOMER no
longer has this right . CUSTOMER may not
transfer the program electronically from

io

DIGITAL RESEARCH
LANGUAGES END USER LICENSE AGREEMENT

Use and possession of this software package
is governed by the following terms .

one computer to another over a network .
DRI shall have the right to terminate this
license if CUSTOMER violates any of its
provisions . CUSTOMER owns the diskette(s)
purchased, but under the Copyright Law
DRI continues to own the SOFTWARE
recorded on it and all copies of it . CUSTO-
MER agrees to make no more than five (5)
copies of the SOFTWARE for backup pur-
poses and to place a label on the outside of
each backup diskette showing the serial
number, program name, version number
and the DRI copyright and trademark no-
tices in the same form as the original copy .
CUSTOMER agrees to pay for licenses for
additional user copies of the SOFTWARE if
CUSTOMER intends to or does use it on
more than one COMPUTER . If the micro-
computer on which CUSTOMER uses the
SOFTWARE is a multi-user microcomputer
system, then the license covers all users on
that single system, without further license
payments, only if the SOFTWARE is used
only on that microcomputer . This is NOT a
license to use the SOFTWARE on main-
frames or emulators .

3. TRANSFER OR REPRODUCTION
CUSTOMER understands that unauthorized
reproduction of copies of the SOFTWARE
and/or unauthorized transfer of any copy
may be a serious crime, as well as subject-
ing CUSTOMER to damages and attorney
fees . CUSTOMER may not transfer any
copy of the SOFTWARE to another person
unless CUSTOMER transfers all copies,
including the original, and advises DRI of
the name and address of that person, who
must sign a copy of the registration card,
pay the then current transfer fee, and agree
to the terms of this LICENSE in order to use
the SOFTWARE. DRI will provide additional
copies of the card and LICENSE upon
request. DRI has the right to terminate the
LICENSE, to trace serial numbers, and to
take legal action if these conditions are
violated .



4 . COMPOSITE PROGRAMS
As an exception to Paragraph 3, CUSTO-
MER is granted the right to include portions
of the DRI RUNTIME LIBRARY in CUSTO-
MER developed programs, called COM-
POSITE PROGRAMS, and to use, distribute
and license such COMPOSITE PROGRAMS
to third parties without payment of any
further license fee . CUSTOMER shall,
however, include in such COMPOSITE
PROGRAM, and on the exterior label of
every diskette, a copyright notice in this
form : "Portions of this program, 91982 DIG-
ITAL RESEARCH INC ." I n cases where
such COMPOSITE PROGRAM is contained
in READ-ONLY-MEMORY (ROM) chips, a
copyright notice in the form listed above,
must be displayed on the exterior of the
chip and internally in the chip (in ASCII
literal form) . As an express condition to the
use of the RUNTIME LIBRARY, CUSTO-
MER agrees to indemnify and hold DRI
harmless from all claims by CUSTOMER
and third parties arising out of the use of
COMPOSITE PROGRAMS .

5. LIMITED WARRANTY
The only warranty DRI makes is that the
diskette(s) on which the SOFTWARE is
recorded will be replaced without charge, if
DRI in good faith determines that the media
was defective and not subject to misuse,
and if returned to DRI or the dealer from
whom it was purchased, with a copy of the
original registration card, within ten days of
purchase . Customer will receive support
from the Vendor from whom customer has
purchased the software . I n addition, support
is available from DRI directly, for qualified,
registered customers under DRI's then cur-
rent support policies. DRI reserves the right
to change the specifications and operating
characteristics of the SOFTWARE it pro-
duces, over a period of time, without notice .

6. DRI MAKES NO OTHER WARRAN-
TIES, EITHER EXPRESSED OR IMPLIED,
AND DRI SHALL NOT BE LIABLE FOR
WARRANTIES OF FITNESS OF PURPOSE

Form E-2 (10/22/82)

OR MERCHANTABILITY, NOR FOR INDI-
RECT, SPECIAL OR CONSEQUENTIAL
DAMAGES SUCH AS LOSS OF PROFITS
OR INABILITY TO USE THE SOFTWARE .
SOME STATES MAY NOT ALLOW THIS
DISCLAIMER SO THIS LANGUAGE MAY
NOT APPLY TO CUSTOMER . I N SUCH
CASE, OUR LIABILITY SHALL BE LIMITED
TO REFUND OF THE DRI LIST PRICE .
CUSTOMER MAY HAVE OTHER RIGHTS
WHICH VARY FROM STATE TO STATE .
CUSTOMER and DRI agree that this pro-
duct is not intended as "Consumer Goods"
under state or federal warranty laws .

7. MISCELLANEOUS
This is the only agreement between CUS-
TOMER and DRI and it cannot and shall not
be modified by purchase orders, advertis-
ing or other representations of anyone,
unless a written amendment has been
signed by one of our company officers .
When CUSTOMER opens the SOFTWARE
package or uses the SOFTWARE, this act
shall be considered as mutual agreement
to the terms of this LICENSE . This LICENSE
shall be governed by California law,
except as to copyright matters which are
covered by Federal laws, and is deemed
entered into at Pacific Grove, Monterey
County, CA by both parties .

by
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SAVE THIS LICENSE FOR FUTURE REFERENCE
Copyright = 1982 . DIGITAL RESEARCH, INC ., Pacific Grove, CA .
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