【收藏巨献--历代CPU最全明细参数表】- 中关村在线

收藏巨献--历代CPU最全明细参数表

类型：原创 作者：中关村在线 biershoff 日期：2004-08-30 12:15:10

简介

曾几何时，我们判断计算机性能高低的标准只是处理器产品数字的大小以及外频的高低。数字大的表示电脑的运算速度越快。例如，80286要比8088和8086要快，但80386要比80286快，而80486则是最快的。但是时光荏苒，现在的计算机世界已经不同于十几年前了。那么今天就让我们来看看当前的处理器。

与以往单凭处理器产品数字和外频来判断处理器性能相比，如今判断的标准还加入了处理器产品名称，型号名称，核心名称以及架构。要想通过这些纷繁复杂的技术标准来判断处理器的性能的确不是一件简单的事情。当然，你可以通过一些媒体了解具体某款或者某几款处理器的性能，但是，这多少有些片面。今天我们要做的就是把过去7年内AMD和英特尔公司推出的处理器做一个详细列表，相信这样可以帮助你在更好的了解处理器的同时，也为自己在以后购买处理器时能够做到心中有数。

由于现在的处理器更新换代的速度极快，因此在这次的测评中，我们将英特尔Pentium II处理器，AMD Athlon处理器之前的产品都排除在外。这次测评中两家公司的处理器产品的性能测试都是在适合处理器本身的条件下进行的。

那么我们这次对比处理器的测评都将就那些细节进行评定呢？主频大小，总线频率，缓存大小，晶体管数量，处理器核心名以及其他一些细节都将在下面的测试中被逐项列出。由于处理器的型号是我们对于处理器的第一印象，因此这次的评定也将包括AMD Athlon XP以及后续处理器，英特尔Pentium 4以及后续处理器的型号。我们首先要对处理器的核心名以及架构进行列表。总体来说，它将更好的帮助我们去了解不同的x86处理器的性能究竟如何。

我们首先来看一下AMD处理器，也许有些英特尔的支持者会问为什么不先看英特尔处理器。但是凡事都有先后，A在字母表中排了I前，因此我们还是先来看一下AMD公司的产品。


类型：原创 作者：中关村在线 biershoff 日期：2004-08-30 12:17:40

AMD处理器产品列表

首先有几点需要说明，在列表中，通过核心名为Applebred和Thorton的处理器的模具尺寸与晶体管数量可以看出，他们的核心其实分别为Thoroughbred和Barton。但由于他们的L2缓存大小分别只有Thoroughbred和Barton核心处理器的四分之一和一半，因此我们在他们的旁边加了一个星号。他们原本是AMD公司为了补充Barton处理器阵容而设计的，但现在看来这些已经无关紧要了，因为AMD马上就要停产Barton处理器，而将使用老的Thoroughbred作为Socket A Sempron处理器的核心。

列表中的Paris，Victoria和Palermo三款核心的晶体管数量有所减少，因此我们尚不能确定这三款核心晶体管的具体数字，但是我们仍然可以通过这三款核心其他的技术参数来对他们有所了解。早期架构在socket 754下，缓存为512K的Athlon 64的核心为Claw Hammer，但是它的实际缓存大小只有设计的一半。但是新型号处理器，例如外频为2.2GHz，缓存为512K的3200+；外频为2.4GHz，缓存为512K的3400+以及外频为2.6GHz，缓存为512K的3600+，他们所用的核心实际上是Newcastle。减少晶体管数量对于Paris核心来说无疑是一件好事，因为它最初的产品是“低级别”Newcastle核心，而后来的产品则在原来的构造下在L2缓存上减少了1870万个晶体管。

请注意列表中的Toledo核心，我们在它所在行的最后标注了2C，表明这是一款双核心。同样Opteron也是一款同时期的双核心处理器，但是我们现在还不清楚不同的Opteron处理器在未来是否会使用不同的核心。

从列表中，我们可以看到Athlon处理器的核心包括了从Pluto到Newcastle的多款核心。它拥有10级整数管线，15级浮点管线，算术逻辑单元，位址产生单元以及浮点单元。其中浮点单元拥有MMX, 3DNow!/+以及SSE/SSE2技术支持。未来的Athlon 64将会在整数管线以及浮点管线长度上有所增加，有可能分别达到12/17级或者更高的级别以增高处理器的主频。我们预计AMD公司将最终推出31级管线的处理器以期在技术上超过英特尔公司的产品，但是AMD不会将所有的处理器都配备31级管线，因为这样做在使得处理器主频升高，性能有所加强的同时，会大量的耗费能源。因此，我们认为AMD处理器的管线长度在10到15的范围内最为合适。


类型：原创 作者：中关村在线 biershoff 日期：2004-08-30 12:22:42

Intel处理器产品列表

请注意，与上一页AMD处理器列表相同，在这张英特尔处理器列表中某些核心所在行同样被加注了一个星号，这说明被标注的核心是速度更快的核心的“低级别”系列。这些被标注的核心则基本上为Celeron处理器的核心。而被标注了双星号的核心则表示该核心在不同阶段的模具尺寸各不相同。当然大多数的芯片模具尺寸都会有所变化，但是Cascades，Coppermine以及Northwood三款核心的模具尺寸变化较大。AMD的Thoroughbred A到Thoroughbred B两款核心的模具尺寸只相差了4平方厘米，而Coppermine核心的模具尺寸则由106平方厘米变为90平方厘米，Northwood核心的模具尺寸页由146平方厘米变为131平方厘米。

你可以从这张表中看到，英特尔也有双核心产品，在他的旁边我们标注了2C。我们甚至可以看到英特尔的Tukwila核心是一款16核心。但是16核心显然对于广大消费者而言还是一个神话，因为象这样的一款核心它的晶体管数量要达到几十亿个。

与AMD相比，英特尔在过去的7年中推出了几款主要的核心构造系列。AMD的K7/Athlon核心在过去的几年中受到了广泛的认可，公司也凭借这款核心获得了为数不少的商业利润。而英特尔公司则凭借其更加雄厚的的实力与资本，不断的推陈出新。先是凭借Pentium III处理器而与其竞争对手AMD在争夺处理器市场的斗争中打了个平手。而后英特尔又推出了性能更加强劲的NetBurst核心，并将它植入Pentium 4处理器中。事实证明，NetBurst核心是一款很好的台式机处理器核心，但对于笔记本而言，它的性能略显不足。因此英特尔决定生产专为笔记本而设计的处理器。最后，在AMD推出其Athlon 64处理器后不久，英特尔公司也随即推出了以Prescott为核心的处理器。


类型：原创 作者：中关村在线 biershoff 日期：2004-08-30 12:26:30

处理器解析表

在列出处理器解析表之前，我要首先向大家解释一下我们为什么要列出一个这样的处理器解析表。这是由于当前处理器型号众多，这在客观上就增大了消费者选择的难度，消费者很难通过比较处理器的型号而得出究竟哪款性能更加的结论。比如。核心为Thoroughbred，主频为2250MHz的Athlon XP处理器型号为2800+，而同为2800+的以Barton为核心的Athlon XP的外频则只有2000MHz。而就英特尔处理器而言，情况似乎更糟，因为英特尔不同型号的处理器的缓存大小，总线频率，甚至架构均有所不同。

在上面的文章中，我们已经为读者列出了英特尔和AMD两家公司在最近几年生产的处理器核心的解析表。但是这似乎并不够，因为消费者更关心的是那款处理器的性能更加强劲，那款处理器的性价比更高。因此我们在下面会给大家列另外一个解析表，旨在能够告诉读者究竟哪个型号的处理器速度更快，性能更好。但是这并不是一个很精确的结果，只是一个很粗略的评估。下面就列出了诸多不同的处理器家族的性能指数。我将它们的性能指数与它们的主频相乘变得到了处理器最终的性能分数。

由于这只是一个粗略的估计，因此我们并没有凭借处理器的性能得分而对他们进行性能排名。如果下面的测试中遗漏了那款处理器或者没有新发布的处理器，希望广大读者可以见量。当然，下面的解析表只是一个参考，因为每个读者都有他们心中自己评定处理器好坏的标准，而且也没有一个固定的公式去衡量一款处理器的全面性能究竟如何。

如果读者不喜欢计算或者并不在意下面的评定结果，可以直接跳过这页。这个解析表是针对那些想了解更多细节的读者而制作的。需要说明的一点是，我们将处理器分开评定的目的是只在同一个系列中对多款处理器进行评定，因此处理器的分数是在特定环境下测定的，与其他处理器的分数并无联系，例如Dothan的得分是1.6而Athlon FX的得分则只有1.15。而事实上，两者的性能差距并没有数字反映出的那么大。

Duron，Athlon，Athlon XP以及Sempron处理器

128K L2缓存 + 100 MHz 总线 = 0.7
128K L2缓存 + 133 MHz 总线 = 0.75
256K L2缓存 + 100 MHz 总线 = 0.8
256K L2缓存 + 133 MHz 总线 = 0.85
256K L2缓存 + 166 MHz 总线 = 0.9
512K L2缓存 + 133 MHz 总线 = 0.95
512K L2缓存 + 166 MHz 总线 = 1.0
512K L2缓存 + 200 MHz 总线 = 1.05

Athlon 64处理器

256K L2缓存 + 单通道 (Socket 754) = 0.9
512K L2缓存 + 单通道 (Socket 754) = 0.95
1024K L2缓存 + 单通道 (Socket 754) = 1.0
512K L2缓存 + 双通道 (Socket 939) = 1.04
1024K L2缓存 + 双通道 (Socket 940) = 1.11
1024K L2缓存 + 双通道 (Socket 939) = 1.15

Celeron 2及Pentium 4处理器

128K L2缓存 + 400 前端总线频率 = 0.6
256K L2缓存 + 400 前端总线频率 = 0.75
256K L2缓存 + 533 前端总线频率 = 0.80
512K L2缓存 + 400 前端总线频率 = 0.84
512K L2缓存 + 533 前端总线频率 = 0.91
1024K L2缓存 + 533 前端总线频率 = 0.93
1024K L2缓存 + 800 前端总线频率 = 0.98
512K L2缓存 + 800 前端总线频率 = 1.0
512K L2缓存 + 800 前端总线频率 + 2048K L3缓存 = 1.15
2048K L2缓存 + 1066 前端总线频率 = 1.2

移动Celeron，移动P4，Celeron M以及Pentium M处理器

128K L2缓存 + 400 前端总线频率 = 0.6
256K L2缓存 + 400 前端总线频率 = 0.75
256K L2缓存 + 533 前端总线频率 = 0.80
512K L2缓存 + 533 前端总线频率 + Northwood = 0.91
1024K L2缓存 + 533 前端总线频率 + Prescott = 0.93
512K L2缓存 + 400 前端总线频率 + Dothan = 1.25
512K L2缓存 + 400 前端总线频率 + Banias = 1.3
1024K L2缓存 + 400 前端总线频率 + Dothan = 1.35
1024K L2缓存 + 400 前端总线频率 + Banias = 1.4
2048K L2缓存 + 400 前端总线频率 = 1.5
2048K L2缓存 + 533 前端总线频率 = 1.6


类型：原创 作者：中关村在线 biershoff 日期：2004-08-30 12:28:38

Duron及Athlon处理器

我并不想具体在细节上对早期的Athlon和Duron处理器进行比较，因为他们在属于他们的那个时代都曾进辉煌过。但是就现在而言，他们的确已经过时了，如果有读者想要对他们进行细节了解，我们在下面的测试中对他们进行了粗略的测定。

早期的以Pluto及Orion为核心的，采用Slot A架构的Athlon处理器拥有L2缓存，缓存的大小是主频的1/2，2/5或者1/3——主频越快，比率越低。例如主频为700MHz的Athlon处理器的L2缓存为350MHz，而主频为750MHz的Athlon处理器的L2缓存则为300MHz，主频更高的850MHz的Athlon处理器的L2缓存更低，为340MHz。一般来说，当时在Athlon处理器与Pentium III处理器的评测中，双方不相上下，两款处理器在不同的测试项目中都有自己的优势。Athlon处理器的x87浮点性能更好，而Pentium III处理器则在最优化应用软件MMX和SSE的测试中，成绩超过Athlon处理器。

架构在socket A下的处理器在L2缓存技术方面有所进步。AMD处理器的性能在当时的一段时间内要超过英特尔处理器产品的性能。Athlon Thunderbird的缓存达到了1.4GHz，而Pentium III曾经试图达到1.13GHz但最终以失败告终，后来的Pentium III Tualatin达到了1.4GHz的水平，但这是在英特尔推出了Pentium 4处理器后才得以实现的。因此当时AMD是众多游戏玩家的至爱。

Athlon XP及Sempron处理器

Athlon XP处理器更改了Athlon处理器的某些架构，以获得更好的性能。由于Athlon XP处理器的推出是为了与英特尔的Pentium 4处理器相抗衡，因此AMD推出了一些新的型号并且提出了“主频不是一切”的处理器性能理念。AMD公司声称Athlon XP处理器的性能相当于Thunderbird核心，但是很少有人相信这种说法，更多人认为这只是一种商业说法，由于英特尔公司新推出的处理器在主频方面有了显著的提高，而Athlon核心根本赶不上英特尔的脚步，因此“主频不是一切”的理念被提了出来。

随着处理器大战的延续，两家公司不断推出新的产品。Thoroughbred核心是一款高工作频率核心，但是并没有达到其设计的初衷。因此Thoroughbred B核心诞生了，它使得处理器的工作频率略有提高，达到了2250MHz。值得一提的是Thoroughbred B核心在冷却条件合适的时候可以超频到2.3GHz到2.4GHz，但是相比而言Thoroughbred核心的工作频率则被限制在了2.1GHz到2.2GHz之间。

Thoroughbred之后，AMD推出的Barton核心在缓存技术方面又有所突破。由于缓存的增加可以提高处理器的工作性能，因此AMD重新调整了其处理器型号。而此时英特尔公司的处理器产品在缓存以及主线频率方面都有所提高，但是公司并没有调整处理器型号。AMD推出2500+，2600+以及2800+以追赶英特尔公司的脚步，但是事实上是英特尔推出前端总线频率为800MHz，主频为200MHz的“C”系列Pentium 4处理器后，AMD新推出的前端总线频率为200MHz的Athlon XP 3200+的性能只相当于P4 2.8C。一般的消费者会简单的认为3200+的性能与3.2C不相上下，但是实际情况并非如此。

Athlon XP及Sempron处理器

关于AMD的移动处理器实在没有什么可以多介绍的，与其台式机处理器相比，移动处理器只是在减少主频的情况下减少了电能的消耗，因此移动处理器工作在低电压状态。AMD移动Athlon XP处理器由于其在超频性能上表现良好因而收到广泛的推崇。

Athlon 64及Opteron处理器

就Athlon 64处理器而言，它的命名是由于其64位地址和整数位。但是Athlon 64处理器的核心并非Athlon处理器核心的升级版本。它仍然保持了10/15级管线。拥有了x86-64的支持，的确是一个很成功的商业行为同时也吸引了不少消费者的眼球。但由于64位还没有成为现在市场的主流，因此它多少还是显得英雄无用武之地。但是随着Windows XP-64的问世，相信它在不久的将来一定会物尽其才。

Athlon 64处理器性能上的优势主要依靠于可以很好的减小延迟的整合内存控制器。它可以帮助内存在很大的情况下仍然保持L3缓存很小，同样可以在内存频率升高的同时减少内存延迟。Athlon 64 3200+处理器的内存延迟为81ns，P4 3.2C处理器的内存延迟为77ns。同时，Athlon 64 3400+处理器的内存延迟达到了48ns。


类型：原创 作者：中关村在线 biershoff 日期：2004-08-30 12:30:32

Celeron, Pentium II以及Pentium III处理器

老的Pentium Pro P6架构拥有12级管线，它拥有三个专门的位址产生单元，两个算术逻辑单元——一个用来解决简单的计算，另外一个单元用来解决复杂的计算，以及一个浮点单元。其中浮点单元拥有CPU指令集，SEE(AMD直到Athlon XP处理器之前的产品均不具备这项支持)和MMX的支持。由于有了这些，使得他们在技术上领先于AMD的产品。

由于使用了Tualatin核心，使得Athlon处理器的主频可以轻松超至1.4GHz。实际上，后来的Celeron 1.0A以及Celeron 1.4A处理器在超频方面表现的也相当不错。总线频率为133MHz的Celeron 1.1A处理器更是表现出了良好的全面性能。由于市场的需要，英特尔公司在后来的日子里停产了这几款性能优越的处理器，转而开发了主频更高的Pentium 4和NetBurst处理器。

Celeron 2及Pentium 4处理器

NetBurst架构拥有20级管线，从而大大加强了数据处理能力。为了减少核心引入指令以及编译码的时间，英特尔公司推出了一种新的缓存，名叫trace缓存。它被证明可以有效的提高处理器数据处理效率。在NetBurst架构下的P4处理器的逻辑算法单元以核心频率的两倍速度运行，并能以一半核心时钟周期执行部分指令，整数指令则以其于速度的两倍执行。

而其后的Prescott架构则在NetBurst架构的基础上加了3级管线，达到了23级管线。除此之外，Prescott架构的L2缓存是Northwood架构的两倍，还加入了SSE3的支持，架构在Prescott下的64位至强处理器系列现在已经开始发售。据推断在XP-64面世以后，英特尔公司也将推出相应的64位台式机处理器。

英特尔近两年来全力推展同步多执行绪技术，公司称其为超线程技术。英特尔直到P4 3.06处理器后才将这项技术植入后续处理器中。后来的至强平台，800MHz前端总线频率的所有"C"处理器均拥有超线程技术的支持。超线程技术就是利用特殊的硬件指令，把两个逻辑内核模拟成两个物理芯片，让单个处理器都能使用线程级并行计算。从而兼容多线程操作系统和软件，提高处理器的性能。在一个程序出错的同时，另一个程序仍然可以运行，这样就可以使得运行性能提高20%到50%。“超线程”技术可以使芯片同时进行多线程处理，使芯片性能得到提升。

现在让我们来看看socket 775 LGA架构，英特尔同样在这种架构下推出了多款处理器。通常而言，编号数字大的产品说明产品的性能越好，但是我们看到这样一个现象，5xx针脚处理器的性能要高于7xx针脚处理器，而某些3xx针脚处理器则要比他们的后辈性能优越。所有5xx针脚处理器使用的均是Prescott核心，拥有800MHz前端总线频率以及1MB大小的L2缓存。其他产品的具体情况读者可以在下表中找到。这样你就会明白为什么会出现产品编号数字大的处理器在性能上反而不敌编号数字小的处理器产品的原因了。

Mobile Celeron, Mobile P4, Celeron M以及Pentium M处理器

在Pentium 4处理器的基础上，加以主频的限制，变造就了非常适合于笔记本使用的英特尔移动处理器。主频越高意味着需要的能量就越大，对于笔记本而言就也就意味着需要增强电池的使用时间。面对来自Transmeta的压力，英特尔推出了集高性能与低耗电于一体的Israel核心处理器。而最终产品就是目前笔记本电脑的主流处理器Pentium M。Pentium M处理器在能量消耗方面表现极为优秀，英特尔公司为了维持其在移动处理器市场的龙头地位，将Pentium M处理器架构在P6之上。

P6架构的改进之处在于其增大了L2缓存，这使得大部分缓存可以处在低能量“睡眠”模式中。P6架构的L1缓存仍为PIII的两倍，达到了64k。浮点性能由于MMX/SSE单元的倍增而得以增强，构架在其他方面也都略有改动。总体来说，Pentium M移动处理器的性能相当于同主频的Athlon处理器，但是耗电则要略低。运用Pentium M移动处理器的笔记本电池要比运用Pentium 4处理器，移动Celeron或者移动Athlon XP的笔记本电池在使用时间上提高25%到50%。

通过上面表的长度就可以看到现在移动处理器在现实生活中占据了越来越重要的位置。

Itanium及Itanium 2处理器

Itanium处理器是目前最不被广大消费者了解的处理器产品。即便是最便宜的型号，其售价也超过了$1000。这并不值得奇怪，因为英特尔公司当时推出这类处理器时便将目标瞄向了高端团体市场。Itanium处理器被用来处理大量的并行进程，它还可以在512路SMP系统中工作，当然，这不能全面的解释Itanium这款高端处理器。

最初，英特尔公司将Itanium处理器作为64位处理器，并且将它架构在了一个新的IA-64结构下。IA-64架构与x86架构相似，是一款面向未来的架构体系。实际上，它的竞争对手并非至强或是Opteron处理器，Itanium的问世是英特尔公司为了占领高端64位处理器市场而推出的。它真正的竞争对手是基于IBM Power4/5, HP PA-RISC, Sun UltraSparc-III以及DEC Alpha的服务器。

就处理器结构设计而言，英特尔使用了一种在以前的大型机上运用的技术，超长指令字(VLIW)。这是一种非常长的指令组合，它把许多条指令连在一起，增加了处理器运算的速度。但是Itanium并非严格意义上的超长指令字处理器，这是由于超长指令字有其自身比较明显的弱点，而英特尔改进了这些弱点，并重新命名，称之为精确并行指令(EPIC)。与至强和Opteron处理器相比，Itanium处理器可以同时最多执行3条指令。Itanium 2处理器则可以在一个周期内执行8条指令。就性能而言，主频为1GHz的Itanium处理器相当于主频为2.66GHz的至强或者Opteron处理器，而主频为1.5GHz的Itanium 2处理器的性能则相当于4GHz的至强或者Opteron处理器。

为了达到最佳性能，Itanium处理器使用了128位四泵总线，使用标准SDRAM内存。最初的Merced版Itanium处理器拥有四个算术逻辑运算器单元，两个浮点单元以及三个分支处理单元，两个SIMD单元(例如MMX/SSE)和两个地址产成单元。而后的改进版McKinley Itanium处理器则拥有六个算术逻辑运算器单元，三个分支处理单元，两个浮点单元以及SIMD单元，两个读取单元，两个存储单元和四个地址产成单元。除此之外，McKinley版本的缓存带宽是Merced版本的三倍。