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What’s New in Protel DXP 
This document gives an overview of the new features in Protel DXP. It is intended to be read while you 
explore the new features in the software. 

To help you get started with Protel DXP it is recommended that you do the Introductory Tutorial. The 
tutorial is a simple design for a multivibrator, it will take you through the entire design process – from 
creating a project, to capturing the schematic, transferring the design to the PCB Editor, generating 
output, and also simulating the schematic. Doing this tutorial will give you a good overview of 
designing in Protel DXP. 

Protel DXP is a project-centric PCB design platform, with powerful new navigation and object 
management features, new high-level design capabilities such as design variants and multi-channel 
design, and numerous enhancements in the design tools. 

The Protel DXP user interface has been extensively redesigned, bringing superior functionality to the 
design space. Features such as panels that can be docked, float, or set to Pop Out mode, automatic 
fade for floating panels and toolbars whenever an edit is performed, support for dual-monitors, and 
click and drag customization of resources, all go to make the design process more efficient and 
enjoyable. 

The documentation in Protel DXP has been restructured, the on-line help presents information in a 
concise reference format for commands, dialogs, and what’s this help. To complement the reference-
style help there are design articles which explain concepts, and are written from an applied 
perspective, and tutorials, which detail how to perform various tasks in Protel DXP. Think of the 
articles and tutorials as a library of information, a library that will expand over time as new material is 
made available on the Protel website. 

A New Approach to Design 

The Protel DXP Project 
When you design in Protel DXP, you start by creating a project.  The project links the elements of your 
design together, including the source schematics or netlist, and the PCB file.  The project also stores 
the output setups; including schematic and PCB print setups, Gerber and NC drill, and the BOM 
configuration.  

To create a new project select New Project from the File menu. As you add documents to the project, 
such as schematic sheets or a PCB, a link to each document is entered into the project file. The 
schematic and PCB documents can be stored anywhere on your network, they do not need to be in 
the same folder as the project file.  

To edit a document that is part of a project, first open the project to display a list of the documents in 
the project, then double click on the document you wish to edit in the Protel DXP Projects panel. 

To add a new document to the active project right-click on any document in the project and select 
New from the floating Project menu. Note that this action adds the document to the project – to get a 
schematic sheet to become part of a schematic hierarchy you place a sheet symbol on the parent 
schematic, and set the sheet symbol Filename field to that of the child schematic sheet. 

Tips 

• As well as being able to open and edit documents by first opening their project, you can also 
directly open and edit any document. 

• Project documents store on the same drive are referenced using relative linking in the project file, 
documents stored on another drive are referenced using absolute linking.  
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The Design Process in Protel DXP  
To create you design in Protel DXP you capture, compile, debug and 
generate output.  

Capture 

You capture your design by placing components from the libraries, and 
wiring them. This can be on a single sheet, or across multiple sheets. 

The first step of design capture is placing components. To access 
components in the libraries first add them to the Installed Library list. To do 
this make the Libraries panel active, then click the Libraries button at the top 
of the panel to display the Add Remove Libraries dialog. Supported library 
formats include the new Protel DXP integrated libraries (*.IntLib), the Protel 
DXP libraries (*.SchLib and *.PcbLib), and Protel 99 SE schematic and PCB 
libraries (*.Lib). 

Libraries included in your project are automatically made available in the 
panel whenever you are working on a document from that project. 

Validate 

Once the design has been captured the next step is to check the 
connectivity in the design – checking for both drafting type errors, such as a 
wire not terminating on a pin, and also checking for electrical design type 
errors, such as a floating input pin. To check the connectivity you compile 
the project. Compiling creates a connective model of the design, and 
checks this connective model for drafting and electrical errors. 

To compile a project select Project » Compile PCB Project from the menus, 
or right-click on a document in the Projects panel. When the project is 
compiled the Compiled panel will appear, you can use this to browse the 
design, or alternatively you can navigate using the new spatial navigation 
features (described later in this document). 

The error checks performed during compiling are configured in the Error 
Reporting and Connection Matrix Tabs of the Options for Project dialog 
(Project » Project Options).  

Debug 

Any warnings or errors detected in the compile process are displayed in the 
Messages panel at the bottom of the DXP interface. They are also listed in 
the schematic or PCB Navigator panel, from the panel you can quickly 
navigate to an error or warning. To debug the schematic project double set 
the Navigator panel to Navigate Violations, then single-click in the different 
fields to navigate to a specific violation. To debug the PCB set the Navigator 
panel to Rules, from there you can either examine the violations for a 
specific rule, or select All Rules in the Rule Classes and list all violations. 

Output 

Once you have a warning/error free compile you can generate outputs and 
transfer the design to PCB layout, or from the PCB you generate outputs for 
fabrication and assembly. As well as being able to configure and generate 
the outputs from the File menu, you can configure and generate all Project 
outputs by selecting Output Jobs the Projects menu. Setups configured 
here are stored in the Project file. 

Panels in Protel DXP 
Protel DXP makes extensive use of 
panels – you use them to open files, 
access libraries, navigate your 
schematic or board, and edit objects.  

Panels can be divided into 2 groups: 
panels you use from any editor, such as 
the Libraries or Projects panel; and 
panels you use with a specific editor, 
such as the PCB Navigator panel. 

Panel display is controlled in the 
following ways: 

Select Workspace Panels in the View 
menu to switch to another panel, or to 
turn a panel on or off. 

 The Panels button located at the 
bottom right of the workspace can also 
be used to display or hide any panel. 

 Click the small down arrow at the 
top of the panel area to switch to 
another active panel. 

Click on a Tab at the bottom of the 
panel area to switch panels, right-click 
on a panel Tab to close a panel. 

Positioning Panels 

Positioning options include: 

Docked – positioned on an edge of the 
application, click the stuck-pin icon  
to switch to Pop Out mode. 

Pop Out – the panel presents as a 
button on the edge of the workspace, 
click on the button to pop the panel 
out, click back in the workspace and it 
will hide. Click the stick-pin icon  to 
switch to Docked mode. 

Float – float within the workspace –
floating panels automatically fade 
during an edit when the cursor 
approaches. 

Tips 

• Click and drag on a Panel Tab, or 
the Panel name, to move only that 
Panel. 

• Hold the CTRL key to prevent 
docking. 

• Right-click on a panel title bar to 
control where the panel can dock 



 

 5 

 

Design Synchronization – Matching the Schematic to the PCB 
One of the challenges of PCB design is keeping the schematic and the PCB synchronized, or matched. 
Invariably design changes are made –  to the schematic, the PCB, or both.  

Underlying design synchronization in Protel DXP is a powerful comparison engine. This comparison 
engine is used to compare the source schematic project to the PCB. It can also be used to compare 
any other design documents, such as the PCB to a netlist, a netlist to a netlist, a schematic sheet (or 
project) to a schematic sheet (or project), in fact any appropriate comparison can be performed. 

How the Schematic Components Link to their PCB Footprint 

The key to synchronizing between the schematic and PCB is the linking from each schematic 
component to its corresponding PCB footprint. In Protel DXP this can be done in 2 ways, either by 
designator, or by a unique identifier. 

To check the status of the component links select Component Links from the Project menu in the PCB 
editor. The Component Links dialog displays the linkage state of the components. 

 

Component that are linked with a matching unique ID are listed in the Matched Components region 
on the right, components that are not matched by a unique ID are shown in the 2 fields on the left. At 
the bottom of the dialog are controls that can be used to quickly match components, or you can select 
unmatched schematic and PCB components and match them manually.  

Generally it is better to match components using a unique ID, this allows you to re-annotate the 
designators on the schematic or the PCB, and always be able to resynchronize the design. 

If you attempt to synchronize the design and unique IDs are not assigned for all the components, you 
will be prompted to attempt to match these components by designator. Note that this matching is by 
designator only, it does not check the footprint or comment. If you are unsure if matching by 
designator will be correct click No when prompted, then launch the Component Linking dialog to 
review the matching.  

Passing Design Changes Between the Schematic and PCB 

Select Update in the Design menu to transfer design changes from the schematic to the PCB, or from 
the PCB back to the schematic. The Engineering Change Order dialog will appear, listing the changes 
that need to be applied to the target document(s), to make them match.  

Not all differences can be resolved when you perform an Update, for instance net connectivity 
changes can not be transferred from the PCB back to the schematic. If there are changes that can not 
be transferred a Confirm dialog will appear, detailing how many changes can not be performed. If you 
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click No in this dialog the Differences dialog will appear, listing all differences found between the 2 
views of the design. The role of this dialog is described below. 

Resolving Differences - How Does it Work? 

The comparison engine works by performing a detailed comparison of the connective model (netlists) 
compiled from each design view. The result of this comparison process is a set of differences. The 
process of detecting and resolving differences between design documents works in the following way: 

Compare the design views: Typically this is the schematic project to the PCB. This is done either by 
selecting Update in a Design menu, or by selecting Show Differences in the Project menu. 

Generate the list of differences: If you selected Update then Protel DXP knows which way you want 
the changes applied, so the Differences dialog is not displayed. If you selected Show Differences all 
differences are listed in the Differences dialog. 

Set the change direction: If you have opted to examine the differences first, you must set the change 
direction in the Differences dialog. Right click and choose from the floating menu to set all updates in 
one action, or click in the Update Decision column and individually set the change direction.  

Generate the Change list: After setting the direction you generate an ECO. The ECO is a list of actions 
that will be performed to resolve the differences. 

Apply the changes: Execute the ECO to perform the updates.  

For a list of the object kinds supported in a schematic-to-PCB comparison, look in the Comparator Tab 
of the Project Options dialog. Not all object kinds are supported in each design view, for example a 
Protel Netlist does not support Rooms or Classes. 

Designator management 
There are tools in both the schematic editor and PCB editor for assigning designators on a positional 
basis. It is important to be aware if the schematic-to-PCB linking is being done via designator or 
unique ID. If it is done by designator, you should always perform an Update to resynchronize the 
schematic and PCB after changing the designators on either side. If linking is done by Unique ID then 
you are free to annotate in either editor as often as you like before performing an Update. To check 
how the linking is being done select Component Links from the Project menu in the PCB Editor. 

Select Tools » Annotate in the schematic editor to assign the component designators. The Update 
Change list displays the designators as they are currently assigned, to change the annotation pattern 
select the direction in the top left of the dialog, click Reset Designators, then click the Update 
Changes List button. When the correct designation pattern has been established click the Accept 
Changes button to generate an ECO, which is used to update the schematics. 
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New Workspace Concepts 
Protel DXP introduces 2 powerful new concepts to design editing – workspace filtering and alternate 
views of object data. Together these editing techniques give a high level of control over what objects 
are displayed in the workspace, and editing those objects.  

Filtering the Objects in the Workspace 
How often have you wanted to control exactly what is currently displayed? Perhaps you wanted to 
examine the routing a particular net and compare it to another net, or check the location of a set of 
components, without the visual clutter of seeing all the other components. Protel DXP’s new 
workspace filtering system delivers precisely this – complete control over exactly what is visible in the 
workspace, with an option to Mask objects that have been filtered out. When you mask filtered 
objects only the objects targeted by your filter remain at normal brightness.  

 

Filtering can be invoked in a variety of ways, including: 

1. Clicking on an entry in the schematic or PCB Navigator panel, all objects are faded, except the 
object(s) belonging to the entry you clicked on. 

2. Typing a query in the List panel. Queries provide a powerful mechanism to target objects in the 
workspace. 

3. Selecting a net, component, or typing a query in the PCB Filter toolbar. 

4. Selecting an entry in the Filter popup menu, press the Y key to pop up the menu. 

Tips 

• To change the fade level of masked objects click on the  button on the bottom right of 
the workspace. 

• Only objects displayed at normal brightness can be selected and edited. 

• Browsing by Design Rules is an excellent way of verifying what each rule will apply to. 

• The PCB Filter Toolbar is a convenient way of filtering by component, net, or query – right click on 
any toolbar to enable it. 

Looking for a net on the board?  The same section of the board, after clicking on the net 

name in the PCB Navigator panel to filter for that net 
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Edit multiple objects in  

the Inspector 

The Object Inspector 
Workspace filtering is not only useful for easing the task of controlling what you 
see, it is also an excellent method of controlling what can be edited. Once you 
have applied a filter only those objects displayed at normal brightness can be 
selected or edited. 

An individual object can be editing in the traditional way, by double-clicking on 
it to display its dialog. Alternatively, you can use the new Object Inspector panel. 
The Object Inspector can be enabled by selecting View » Workspace Panels » 
Inspector from the menus, or by pressing the F11 shortcut key. There are 2 
advantages to using the Object Inspector, the first is that it can remain open, you 
simply click once on any object to display and edit its attributes in the inspector, 
the other advantage is that it can be used to edit multiple objects, including 
different kinds of objects. As you add objects to the current selection, only 
attributes that are common to the selected objects will be displayed. Any 
changes you make are applied to the object as soon as you click outside the attribute being modified. 

Querying for Objects 
Protel DXP brings a powerful new approach to targeting objects in your design – queries. A query is a 
combination of symbols — keywords, object identifiers, operators, and values – that is analyzed, and 
then applied to every object in the workspace to see if the object complies with that query. The results 
of the query then become available for display in the workspace. 

Queries can be simple, such as: 

OnTop 

Where the OnTop keyword targets all objects on the Top Layer of a PCB. Queries can also be very 
specific, such as:  

IsPad And (Not IsElectrical) And OnMultilayer And (HoleSize > 20)  

Which targets pads (IsPad), that do not have a net name assigned (Not IsElectrical), that are on the 
Multilayer (OnMultilayer) and have a hole size greater than 20mils (HoleSize > 20). 

A complete list of keywords, object 
identifiers and operators are available 
in the Query Helper dialog. Use the 
Query Helper to build queries and 
check their syntax before applying 
them. To open the Query Helper click 
the Helper button in the List panel, or 
the Query Builder button in any of the 
design rule setups. 

Filtering with Queries 

Queries can be used for filtering, 
giving you the ability to precisely 
target a set of objects in the 
workspace. You can filter using 
queries in the List panel, or in the Filter 
Toolbar. Once you have applied a filter 
to target the objects, you can easily 
view and edit those objects. For 
example, an earlier image shows how the panel can be used to filter for a net, this filter could also 
have been applied by typing InNet(‘NetName’) in the Filter Editor or the Filter Toolbar (where 
NetName is the name of the net you wish to filter for).  
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Scoping Design Rules with Queries 

Queries are also used to scope design rules, the query defines what the rule will target. To simplify the 
process of setting up rule scopes, each rule has a set of standard options (All, Net, Net Class, Layer, 
Net and Layer), selecting one of these will build a query automatically. There is also an Advanced 
option – if you use this option you write your own query. 

Rule Priority 

The order that rules are applied 
is defined by their priority. The 
priority is displayed in the main 
window of the Design Rules 
dialog, if you navigate down 
using the tree on the left, when 
you select a rule Type (for 
example Width) you can click 
the Priorities button at the 
bottom of the dialog and change 
the priority. The highest priority 
rule is priority 1. 

The List Panel 
As well as the traditional graphical view, where the objects are arranged in the workspace as you 
placed them, you can also view and edit objects in the new List panel. The List panel is a combination 
of a query editor, highlight controls, and a spreadsheet. When you type in a query at the top of the 
panel and enable the Mask highlighting option, the contents of the spreadsheet are automatically 
updated to remove all objects filtered out by the query. The spreadsheet is a genuine alternate view – 
any action you perform in the spreadsheet, such as selecting a group of objects, or editing an object, 
occurs simultaneously in the graphical view.  

 
Tips 

• Queries typed in the List panel apply in both the graphical view and the spreadsheet. 

• Build a selection in the spreadsheet using the standard SHIFT+click and CTRL+click key 
combinations, then right-click on a selected attribute and Remove Non-Selected to reduce the list 
to only selected objects. You can also chose Edit Selected to edit this attribute in all selected 
items.  

• Right click to create a report from the spreadsheet, from the Report Preview window you can 
export to a text, CSV, or Excel spreadsheet file. 
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Navigating the Design 
Both the schematic and PCB editors have new Navigator panels. These panels are used to browse your 
design, by components, nets, or errors (and rules as well in PCB). The Navigator panels use the new 
workspace masking feature to fade away all objects, except those that you have clicked on in the 
panel. 

Schematic Navigator Panel 
Prior to compiling the design, the schematic is a collection of 
objects – components, wires, buses, ports, and so on. The net 
related objects define how the connections in the design must be 
created, but until the design is compiled there is no connective 
view, or model, of the design. 

When the design is compiled a connective model is created – and 
the schematic editor Navigator panel can then be used to navigate 
the design, using this connective model.  

There are a number of highlight options at the top of the Navigator 
panel. The Mask option fades unrelated objects as you browse, and 
the Graph option displays the connective relationship between 
objects – red when navigating by nets, green when navigating by 
components.  

As well as navigating in a panel centric mode, where you click on 
the object of interest in the panel, if you click the Hierarchy button 
on the panel you can then navigate directly in the sheet. As you 
click on an object in the sheet it will be highlighted according to 
the options at the top of the panel. For example, enable the Graph 
option, click Hierarchy, then click on a wire to examine the 
connectivity created by that wire. You can trace a net off sheet by 
clicking the small red diamond that appears on a highlighted port. 

For a more comprehensive view of the compiled design, use the 
Compiled panel. As well as navigating by net or component, you 
can also examine the elements that make up each compiled entity.  
 

Defining Design Rules in the Schematic 
PCB specific design rules can be defined in the schematic, they are added as parameters. 
Whenever you add a parameter to an object there is an  button. If this is clicked 

the resulting Parameter Properties dialog will include an  button, click this to 

display the Choose Design Rule dialog ,where the rule type can be chosen, and then 
configured in an edit rule dialog.  

In the PCB Editor the scope of a rule – the set of objects that the rule will target – is defined in 
the rule. In the schematic editor the scope of the rule is defined by where the parameter is 
added. The following schematic parameter–to– PCB rule scope options are supported: 

• Pin parameter – pad scope 

• Port parameter – net scope 

• Parameter Set object on a wire – net scope  

• Parameter Set object on a bus – net class scope 

• Component parameter – component scope 

• Sheet symbol parameter – component class scope 

• Sheet parameter – All scope 

 

 
Highlight by Masking 

 
with Show Parts enabled 

 
graph the net, with parts not shown  
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True Multi-channel Design 
How often has your design includes a section of the circuit that is repeated – repeated twice, 4 times, 
or perhaps 32 times. Protel DXP includes a number of features that bring full support for multi-channel 
design – including sheet symbol instantiation, multi-channel designator management, automatic 
component class and room creation, and channel placement and routing replication. 

True multi-channel design means that you only draw the channel schematic once – there is no need to 
create multiple copies of the sheet. The schematic project remains in this state, even after you transfer 
the design to PCB layout. The channel can be referenced by multiple sheet symbols, or you can use 
the new sheet symbol instantiation syntax to reference all channels from a single sheet symbol.  

The Repeat keyword is used to define the number of times the channel is to be instantiated. When the 
project is compiled the compiler instantiates the channel the required number of times as it builds the 
internal compiled model, using a simple annotation scheme to uniquely identify each component in 
each channel. It does not duplicate the channel sub-sheet, instead it creates a table of designators. 
Once the project is compiled a Tab appears at the bottom of the Schematic Editor window, with one 
Tab for each channel of that sub-sheet. 

Multi-channel support flows though to the PCB Editor. The components are placed in their channel 
groups (component classes), with each component class on the board being placed in a placement 
room.  

After you place the components in one channel you can use the Autoroute » Room command to route 
the channel, then select the Tools » Rooms » Copy Room Formats command to step and repeat the 
placement and routing across all the channels. 

Creating a Multi-Channel Design 

1. Draw the channel on a sub-sheet.  

2. Place a sheet symbol on the parent 
sheet to represent this sub-sheet. 

3. Define the number of channels – this 
is done by including the Repeat 
keyword in the Sheet Symbol Name 
field, as shown in the adjacent 
figure. In this example the Name of 
the sub-sheet is CIN, and the 
channels are to be numbered 1 to 8. 

4. Nets that are common to all sub-sheet are connected in the normal way, for example the Effects 
net. 

5. Nets that connect individually to each sub-sheet are bought in as a bus, with one bus element 
connecting to each sub-sheet. You will note that the net label on the wire does not include a bus 
element number, and the sheet symbol includes the Repeat keyword. When the design is 
compiled this bus is resolved into the individual nets Headphone1, Headphone2, thru to 
Headphone8, with one assigned to each channel. 

6. Once the design has been compiled it is transferred to the PCB Editor in the normal way. The 
transfer process will automatically create a component class for each schematic sheet in the 
design, a room for each component class, and group the components in each class in their room, 
ready for placement. 

7. After placing and routing one channel select Tools » Copy Room Formats in the PCB Editor to 
copy the placement and routing of that channel to the other channels. 

8. Select View » Channels from the Project menu to examine the designators assignments for the 
project. 
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Tips 

• Compile the Multi-channel Mixer example to see how a multi-channel design works. 

• The name of the sheet symbol is used to uniquely identify each component in each channel, for 
example R1 in channel 8 would become R1_ CIN8. Use short names for the sheet symbols to keep 
the designators short. 

• Remember that there is always only one schematic sheet of the channel, the designator 
assignments for each channel are stored in a table (Project » Channels). When the multi-channel 
design is compiled there is still only one sheet shown, the difference now is that there are Tabs 
along the bottom of the sheet in the Schematic Editor, one for each channel.  

Designing Assembly Variants 
Protel DXP supports assembly variants. An assembly variant is created when you wish to design one 
PCB, but load it in different configurations – each 
configuration being an assembly variant.  

The typical process is to first complete the full 
design and lay out the PCB. Once it is complete, and 
the schematic and PCB synchronized, you are ready 
to define the assembly variants. 

 
Variants are created and managed in the Variant Management dialog,  

from there you generate variant specific output, such as assembly drawings 

Select Project » Variants to create an assembly variant. The Variant Management dialog shows the set 
of components for the entire design. Once you have added in the required variants and set the Not 
Fitted option for those components that are to be left off in that variant, you can generate the variant 
specific outputs, including the Bill of Materials, the pick and place file, and the assembly drawing. 

Interfacing to a Version Control System 
Version Control – interface directly from the Protel DXP interface to popular 3rd party version control 
systems, including Visual Source Safe®. Right-click in the Project panel to add a project to the version 
control system, or select Version Control in the project menu for a complete set of features.  

The VCS interface in Protel DXP complies with the Microsoft SCC interface standard, giving direct 
access to an SCC compliant VCS from within the DXP environment. 
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Integrated Component Libraries 
An integrated component library is a complete and portable package, it can include the schematic 
symbols, the PCB footprints, the SPICE models and signal integrity models, with the ability for further 
model types to be added in the future.  

To build an integrated component library you start by creating a library package. The library package is 
a project file that defines what components are in the integrated library. Once the library package is 
complete, you compile it to produce the integrated library. 

The Figure below shows the steps to creating an integrated library. 

 

1. Create the source Library Package. 

2. Once the library package has been created add in the schematic symbol libraries (Projects » Add 
to Project). There is no limit on the number of schematic libraries that can be added in. While 
Protel 99 SE schematic libraries can be included in DXP’s Installed libraries list, they can not be 
compiled into an integrated library – open and save them in Protel DXP first. 

3. Create/edit the component symbols in each schematic library. Each schematic component is 
created in its entirety – draw the graphics and place the pins for each part in the component. If 
there are pins that are on the component that you do not want displayed, place them in the library 
editor and set their display state to hidden. 

4. Configure the search paths to the models in the Options for Project dialog. Note that the current 
location of the Library Package file is automatically included as a search path, add in others to 
point to the location of your footprints and other models. After adding in a new path click the 
Refresh list to confirm that the models are being located correctly. You can also add model files 
into the library package. 

5. For each component, select Tools » Edit Component in the library editor menus to link in the 
appropriate models. This can include the PCB footprint, a SPICE model, or a signal integrity 
model. Note that each model is normally referenced by name only, when you compile the library 
the compiler looks down the search path for each model, and compiles it into the library. You can 
specify the exact location of each model if required. When you compile the library package the 
search order for models is – exact location; models included in the library package; models in the 
installed library list; then models down the search path. 

6. When the library is complete and ready to compile, select Project » Compile Integrated Library 
from the menus. The integrated library is compiled from the various source libraries and model 
files. The compiler checks are configured in the Options for Project dialog, and warnings/errors 
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are displayed in the Messages panel. The compiled integrated library is written to the location 
specified in the Output Path field in the Options for Project dialog. 

7. The integrated library is now ready for use. If the Open outputs after compile option is enabled it 
will automatically be added to the installed library list. 

Structuring Your Libraries 

The Library Package/Integrated Library structure is flexible, you can add in as few or as many 
schematic libraries as you like. The integrated libraries supplied with Protel DXP are organized with 
each being like a manufacture’s databook – a schematic library has been created for a series of 
components, then this library is added into the library package.  

Signal Integrity Models 

The signal integrity simulator uses pin models rather than component models, to configure a 
component for signal integrity simulation you either set the Type and Technology options, which will 
use default pin models, or import and IBIS model. 

Accessing the Libraries 

In Protel DXP all library types, including schematic PCB and integrated libraries are accessed through 
the Libraries panel.   

Tips 

• You do not have to use integrated libraries, Protel DXP supports independent schematic and PCB 
libraries, Both Protel 99 SE libraries and Protel DXP libraries can be used, add these into the Library 
List, then access the symbols/footprints via the Libraries panel. 

Situs Topological Autorouter 

Design rule compliance  

Situs offer complete design rule compliance 
for all electrical and routing design rules, 
including via style and blind and buried vias.  

BGA Packaging Support 

It includes built in strategies for BGA 
component routing, supporting an 
unlimited number of BGA pads.  

There is also a new Fanout Control design 
rule, use this to control the fan out 
requirements of the multi-pin surface 
mount components in your design. 

User definable Routing Strategies 

Situs comes with a number of default 
routing strategies, each focused to route 
well in a specific situation. Select the 
preferred routing strategy before 
launching the router. 

The default strategies cannot be edited. 
They can be duplicated, and any number of 
user defined strategies can be created. 
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PCB Layout Enhancements 

Board Shape 

The board shape defines the boundary, or extents of the board. It is used by Protel DXP to determine 
the extents of the power planes for power plane edge pullback, and for calculating the board edge 
when outputting design data to other tools, such as the 3D viewer. 

When a new board file is created a default board shape is also created. This can be resized, or 
redefined using the commands in the Design » Board Shape sub-menu.  

Tips 

• Press the Spacebar to change the corner style while you are defining the board shape. 

• If your design already includes a board boundary defined on a mechanical layer, use the Define 
from Selected Objects command to automatically match the board shape to your shape. Make 
sure that the shape defined by the selected objects on the mechanical layer is closed – there is no 
gaps in the boundary. 

 

Sheet Templates 

If you open the PCB example files supplied with Protel DXP you will notice that most of them display 
the board on a sheet, and that the sheet includes a border, grid reference, and title block.  

Rather than use special objects to implement the template; the border, grid references and title block 
are drawn on one of the mechanical layers (Mechanical16 in the examples).  

The sheet itself – the white region – is a special drawing feature. It is controlled using the options in 
the Board Options dialog. The sheet can be associated with mechanical layers – by placing objects on 
mechanical layers you can then create any sort of drawing template you require. Once the template 
elements are placed on a mechanical layer, the layer can be Linked to the Sheet in the Board Layers 
dialog. 

The board shape defines the edge of the board, and is used for automated functions such as the power plane pullback.  
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While the sheet size and location can be defined manually, if you have linked the sheet to a 
mechanical layer the white sheet background is resized automatically to fit the objects on the linked 
layer when you select View » Fit Sheet from the menus. 

Tips 

• Protel DXP includes a set of pre-defined PCB templates (\Altium\Templates), open the required 
template and copy the contents from it and paste them into your board file. 

• The sheet can hidden at any time, disable the Display Sheet option in the Board Options dialog. 
All linked mechanical layers will also be hidden. 

• If you set the workspace start and end colors to black (Board Layers dialog) you can easily switch 
from the new sheet mode to the tradition full black mode by switching the sheet display on and 
off in the Board Options dialog. 

New Rule Scoping System 

You create design rules to define the requirements of your design. Each rule has a rule scope, the 
scope defines exactly what the rule is to apply to, such as all objects on the board, or all objects in a 
particular net. Rather than using a fixed, predefined set of rule scopes, Protel DXP uses queries to 
define what objects a rule is to apply to. To make the scoping system more flexible, the order that 
rules are applied (the rule precedence), is user-definable.  

For information on using queries to scope rules, refer to the Querying for Objects section earlier in 
this document.  

Component Placement Rooms 

Protel DXP has enhanced component placement room functionality, including: polygonal rooms, copy 
room formatting, creating a room to fit a component class, and autorouting and unrouting in a room. 
The set of tools for working with rooms are detailed below. Watch the status bar when using each of 
the tools: 

Place Rectangular Room – place a rectangular room on the top or bottom side of the board (Tools » 
Rooms menu). 

Place Polygonal Room – place a polygonal room on the top or bottom side of the board (Tools » 
Rooms menu). 

Copy Room Formats – copy the placement and routing in the selected room, to other rooms that 
contain an identical set of components. Use this feature in a multi-channel design, after placing and 
routing one channel Protel DXP will automatically place and route the other channels (Tools » Rooms 
menu). 

Wrap Room Around Components – if you have already placed the components in a component class 
use this command to automatically wrap the room around the components. 

Create Non-Orthogonal Room from selected components – create a component class from the 
selected components, then create a non-orthogonal room around them (Tools » Rooms menu). 

Create Orthogonal Room from selected components – create a component class from the selected 
components, then create an orthogonal room around them (Tools » Rooms menu). 

Create Rectangle Room from selected components – create a component class from the selected 
components, then create a rectangular room around them (Tools » Rooms menu). 

Autoroute room – autoroute all connections that start and end within a room (Autoroute menu). 

Un-route room – un-route all connections that have at least one node in a room (Tools » Un-Route 
menu). 

Slice a room – use this to slice one room into 2 rooms (Edit » Slice menu). 
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Dimensioning tools  

Protel DXP includes a comprehensive set of dimensioning tools, including: Linear, Datum, Baseline, 
Leader, Angular, Center, Radial, Linear Diameter, Radial Diameter. Dimensions can be placed from the 
Dimensions sub menu, or the Dimensions toolbar. 

Dimensions are associative, once they are connected to 
an object they will remain connected to the object as it 
is moved. To associate a dimension to an object, such as 
a track end, look for the small hollow circle drawn in the same color as the layer being placed on, this 
circle indicates that the dimension will associate with this point. Each dimension type also offers 
complete control over the units, the precision, the text alignment, and the arrow characteristics – 
double click on a dimension to edit any of these parameters.  

Keep an eye on the Status bar when you are placing a dimension – each type has a different placement 
sequence, the Status bar will prompt you what to do next as you place the dimension. For information 
on a particular dimensioning tool press F1 when the mouse is over a dimension menu entry or toolbar 
button. 

Enhanced Splitting of Power Planes  

DXP’s new power plane splitting feature 
works like cutting with a knife. To split a 
plane make the plane the current layer, and 
switch to single layer mode (Shift+S shortcut 
toggles single layer mode). 

Select Place » Line from the menus. Starting 
from just outside the board shape, place lines 
to define the cut, or separation, between the 
2 regions you are splitting apart. The width of 
the line defines the no-copper separation, 
press the Tab key during line placement to 
change the width.  

When you split a plane you must start from 
outside the board shape and finish outside 
the board shape. You can also cut within the 
plane, as long as you always start and finish 
on the edge or an existing cut.  

 

Fully Definable Pad Shapes 

Protel DXP supports 3 types of pad 
definition: 

• Simple - where the pad properties 
are the same on all layers  

• Top-Mid-Bottom – where the top 
layer and bottom layer are defined 
individually, and all mid-layers are 
defined as a set 

• Full Stack – where the pad 
properties can be defined uniquely 
on every layer. 
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Summary of other Enhancements 

Schematic Capture  

User-definable component and pin parameters  

Unlimited user-definable component parameters and pin parameters, editable in the library and on 
the schematic sheet.  

On-sheet graphical component editing  

Edit and move components pins on the schematic sheet. Double click on a component to unlock the 
pins and move them. 

Circuit Simulation Enhancements 

Import and export waveform data  

Import and export plot points to a spreadsheet, and Copy the chart to the clipboard and paste into 
other Windows applications. 

Enhanced plot graphics  

Improved access to plot elements such as titles, labels, lines, and so on.  

Overlay different waveforms  

Different waveform types can share the same plot, with support for multiple Y axes. 

Multiple scaled plots  

Display from 1 to 4 scaled plots simultaneously, right-click and select Document Options to configure 
the number of plots. 
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Signal Integrity Enhancements 

Signal integrity analysis with the DXP environment 

Analyze the SI performance 
of the PCB from either the 
schematic or the PCB 
editors, perform reflection 
and crosstalk analysis on 
selecting nets, and display 
the waveforms within the 
Design Explorer. 

Signal integrity 
analysis from the 
schematic 

You can also perform an SI 
analysis on the design from 
the schematic without having a PCB as part of the project. In this mode a default average route length 
can be defined, as well as the PCB stackup. 

Enhanced model integration  

SI models can be included in the new integrated component libraries.  

Project Outputs 
Generate ODB++ output directly from the PCB 

Automatically load outputs into CAMtastic. 

Dual monitor support 
Protel DXP takes full advantage of a dual monitor configuration. You can arrange the documents 
across both monitors, or you can use the second monitor for secondary views, such as the object 
Inspector Panel or the Filter Panel. 

To position a document on the second monitor right-click on a document Tab and select Open in 
New Window to create a second DXP window, ready to position on your second monitor. 
Alternatively, you can drag a document Tab out when DXP is not maximized. Note that this second 
window is not a second instance of Protel DXP, it runs in the same MS Windows process. 

To position an individual panel on the second monitor simply click and hold on the actual Panel name 
in the caption bar of the panel, and drag and position it. Hold the CTRL key as you drag it to prevent it 
from docking to the edge of application. 
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Glossary 
Analyze document – compiles (netlists and validates) the selected document. 

Compile Integrated Library – creates an integrated library that includes the schematic symbols, plus 
any models that have been linked to the symbols. Note that an integrated library can not be edited. 

Compile Project – create a connective model (or netlist) of the design, and check the validity of this 
connective model. When a PCB project is compiled the connective model only exists in memory. The 
connective model can be examined in the Compiled Panel. If the project has already been compiled 
only those documents that have been changed since the last compile are recompiled. 

Connective model – general term to describe the generic internal netlist that is created when a 
compile is performed.  

Design View – general term used to describe any of the different views of the design, for example the 
set of sheets that make up the schematic project is one view of the design, the PCB is another view, 
and a netlist is another. 

Filtering – a technique used to control what is available in the workspace views. Filtering can be done 
via the Navigator panel, via the Find Similar Objects dialog, or via a query. The display of the filtered 
result set depends on the highlight controls 

Highlighting – wherever a filter can be applied you also have options to control how to highlight the 
result set. Highlighting options include: masking, selecting and zooming. 

Inspector – the Inspector panel presents the properties of the current selection for editing. It can be 
used to edit an individual object, or multiple objects. 

List panel – alternate view into the set of design objects in the current document. The List panel has 3 
distinct areas; the query editor at the top, a set of highlighting controls, and the spreadsheet-like list 
view at the bottom. 

Masking – a filter highlighting mode that effectively removes objects from the editable workspace. In 
the graphical view this ‘removal’ is done via fading, or dimming, all the objects that have been filtered 
out, leaving only the objects targeted by your filter shown at normal brightness. The brightness of 
filtered objects is controlled by adjusting the Mask Level (click the button at the bottom of the 
workspace). Masking in the List view is done by removing masked objects from the list. 

Multi-channel design – technique of instantiating a section (sub-sheet) in a design multiple times.  

Panel – a window that provides another view into a design, or the design environment. There are 2 
types of panels, workspace panels that are available at any time, such as the Files panel or the Projects 
panel; and editor panels, which are only available when a document of that kind is visible, such as the 
schematic or PCB Navigator. 

Query – method of targeting objects in the workspace. Uses a query engine to first parse the query 
string, then check each object to see if it complies with query or does not comply with the query.  

Variant – variants are different assembly configurations of the one design. A variant of a design 
specifies the fitted and not fitted components in that variant. Applicable output documents, including 
the BOM, pick and place files, and assembly drawings are created for each variant.  Note that the 
project documents always define the complete (or fully loaded) design, so there is only one set of 
fabrication documents for the PCB. 

Version Control System (VCS) – document management system that stores electronic documents, 
providing access to them through a formal interface that tracks when documents are taken out of the 
VCS (checked-out), and when they are returned to the VCS (checked-in). The VCS tracks the changes 
each time a document is checked back in, either by saving a new copy, or saving the differences 
between the versions. The VCS allows you to restore (or rollback) a design back to any earlier version. 
Document access permissions can also controlled in the VCS. The VCS interface in Protel DXP 
complies with the Microsoft SCC interface standard, giving direct access to a SCC compliant VCS from 
within the DXP environment. 

Workspace Views – a workspace view is an interface where you can edit design objects. Protel DXP 
includes 3 workspace views, the main graphical view, the List view, and the Inspector panel. 


